PDA

View Full Version : Spa stuttering like crazy



Roguebantha
08-05-2015, 01:56
For some reason, Spa is stuttering terribly for me between the final two turns and the finish line. The nature of it almost makes me wonder if I'm running into Ramgate with my Geforce GTX 970, but that seems incredibly unlikely.

Anyone else experiencing this issue?

Aldo Zampatti
08-05-2015, 02:00
Can you please post your system specs? GPU CPU? How many FPS you have?
What are your in-game vistual settings?

As a rule of thumbs: Use Medium/low settings with low AA, and then go UP from there.
Use a frame limiter (this might help with frametimes thus reduce stuttering and freeing up CPU)
Try VSYNC if you're above 60fps
Use render frames ahead=2 as minimum to avoid stutter, if you can tolerate input lag (very little) try 3 álso

Roguebantha
08-05-2015, 02:05
AMD FX-8350
Geforce GTX 970
16 GB of RAM at 1866 Mhz
And my visual settings...ugh...1920x1080 @ 59 Hz. V-Sync on, MSAA and SMAA on...and then everything else lol.

It'd seem to make sense that my settings were up too high except that every other track works just fine. It's only on Spa that I have massive stuttering issues, and only on that one section.

EDIT: Perhaps this could be the issue? I am using an Xbox One controller on a 970. But it's not just an FPS drop, it's like the game just stops for up to a second.
http://forum.projectcarsgame.com/showthread.php?21874-Bug-report-Force-feedback-cause-graphic-lag-loss-of-FPS-with-some-controllers

Aldo Zampatti
08-05-2015, 02:12
AMD FX-8350
Geforce GTX 970
16 GB of RAM at 1866 Mhz
And my visual settings...ugh...1920x1080 @ 59 Hz. V-Sync on, MSAA and SMAA on...and then everything else lol.

It'd seem to make sense that my settings were up too high except that every other track works just fine. It's only on Spa that I have massive stuttering issues, and only on that one section.

Spa (start/finish line) is a very demanding place :)

Try turning SMAA OFF, and use FXAA low. AA can be MSAA or HIGH for your system very easy.
For a 970 desktop I would recommend turning to LOW or OFF Deailed Grass from visual, CAR to ULTRA, TRACK to ULTRA, and then, EnvMap, Reflections, Motion Blur, Shadows, to medium.

keep Render Frames Ahead=2

Reboot the game and give it a spin. Please let me know how it worked out :)

Mahjik
08-05-2015, 02:13
That section is pretty performance heavy. You might need to dial things back one more notch for that track. FWIW, with my old system, I had to dial back iRacing settings when I had races on Spa.

Roguebantha
08-05-2015, 02:25
Huh, interesting! Are there any other places that have such performance heavy parts? I could test on other parts and see whether it replicates.

Mahjik
08-05-2015, 02:28
Huh, interesting! Are there any other places that have such performance heavy parts? I could test on other parts and see whether it replicates.

The start/finish area on Imola is fairly performance intensive as well as the 1st sector of Zolder.

Roguebantha
08-05-2015, 02:30
Hmmm never experienced problems with Imola but I'll try again, as well as Zolder. Thanks for the info! I'll get back to you guys and see how it goes. I wouldn't have expected my system to struggle so much with the game XD

Aldo Zampatti
08-05-2015, 02:33
Hmmm never experienced problems with Imola but I'll try again, as well as Zolder. Thanks for the info! I'll get back to you guys and see how it goes. I wouldn't have expected my system to struggle so much with the game XD

Try Azure circuit... the part of.... well, Everything! :D Azure Coast part 1 also :)
This is a next next-gen game... that's why :D But looks beautiful, doesn't it?

Roguebantha
08-05-2015, 02:36
Hahaha sure does!! Good to know! And glad to have a goal to strive for computationally; run Project CARS without lag XD

Aldo Zampatti
08-05-2015, 02:39
WMD Community is here for help! If you're happy, we are happy!

(I sounded like a loyal employee and everything!!!) :P

Keithb23
08-05-2015, 02:54
If you can learn to live without AA, many people do, that will eliminate one of the biggest performance hits. Try reflections on low as well, its likely you won't even notice a difference. Shadows on medium-low, environment mapping low, you can dial back the motion blur as well.

Enjoy the game and report your findings!

Beans
08-05-2015, 03:42
The exit of the hairpin at Brands Hatch can be a scosh laggy with high enough settings

Mattias
08-05-2015, 07:14
That is weird, I run these on ultra with my GTX 670, i5 (3000k something), 16gb ram. No issues.
My friend with GTX 980 and i7 has issues though, lots of shutter lags on all tracks. Even if he just puts all settings on high.

Shouldn't it be reverse? That my old card should have these problems.

Aldo Zampatti
08-05-2015, 07:20
That is weird, I run these on ultra with my GTX 670, i5 (3000k something), 16gb ram. No issues.
My friend with GTX 980 and i7 has issues though, lots of shutter lags on all tracks. Even if he just puts all settings on high.

Shouldn't it be reverse? That my old card should have these problems.

It's mostly driver related. Other parameter can influence also, as HyperThreading on the i7, Windows CPU Scheduler it is not that smart.
Normally Limiting Frame Rate Helps as well as playing with Render Frames Ahead parameter (try 2/3/4/1 values).

To limit, you can you Afterburner, nvidia inspector or -fpscap xxx in the Launch parameter (i.e.: -fpscap 60)

Mattias
08-05-2015, 07:25
Thanks! I'll have him test these things.
I too suspect the HyperThreading and will try out disabling that. We also did play around with Render Frames Ahead but that didn't help. We also turned on V-sync to limit frame rates at 60, but will try -fpscap instead next time.
After trying v-sync and render frames ahead in game and that didn't work, we tried the same thing but with the Nvidia Control Panel. Didn't help either.

Can only hope a driver update fixes it. But I am going to try to find out what causes this... I have a GTX 970 on the way and if I get the same issues I will fix them ;)

Aldo Zampatti
08-05-2015, 07:27
Thanks! I'll have him test these things.
I too suspect the HyperThreading and will try out disabling that. We also did play around with Render Frames Ahead but that didn't help. We also turned on V-sync to limit frame rates at 60, but will try -fpscap instead next time.
After trying v-sync and render frames ahead in game and that didn't work, we tried the same thing but with the Nvidia Control Panel. Didn't help either.

Can only hope a driver update fixes it. But I am going to try to find out what causes this... I have a GTX 970 on the way and if I get the same issues I will fix them ;)


I think I saw your post in steam forums :D
good luck and let us know!

Beans
08-05-2015, 07:45
Thanks! I'll have him test these things.
I too suspect the HyperThreading and will try out disabling that. We also did play around with Render Frames Ahead but that didn't help. We also turned on V-sync to limit frame rates at 60, but will try -fpscap instead next time.
After trying v-sync and render frames ahead in game and that didn't work, we tried the same thing but with the Nvidia Control Panel. Didn't help either.

Can only hope a driver update fixes it. But I am going to try to find out what causes this... I have a GTX 970 on the way and if I get the same issues I will fix them ;)

As a note though, Look at my sig I'm actually running 780 SLI at the moment (not the 980s) and using hyper threading. It's a temp. PC so no real overclock to speak of. Running ultra on most everything with MSAA at my resolution! I'm not even running the latest driver that helps with SLI. There must be something else going on with your friends PC.

Joeri Blootacker
08-05-2015, 08:44
one of the first ones to check when having FPS issues, is the "detailed grass" :)
even though it has been very much optimized.
changing ENV and Reflections from Ultra to High or MED, can make a huge difference in FPS, without losing much quality ;)
bit like ALDO was mentioning ;)

cyberfred
08-05-2015, 08:50
hi guys , it seems I have similar problem on this track , BUT only after few laps :
I begin a race , 20 cars , beautiful weather , perfectly smooth (gtx 980 , 1920 , Ultra , vsync on 60 fps) , one lap ok , second lap ok , etc...
but the game begin to stutter like crazy after a while (perhaps after 4 or 5 laps) , unbelievavle : my gtx 980 is only at 45% usage and my cpu (3770k@4.5) 30%.

Any ideas ?
thaks for help.

Joeri Blootacker
08-05-2015, 08:53
hi guys , it seems I have similar problem on this track , BUT only after few laps :
I begin a race , 20 cars , beautiful weather , perfectly smooth (gtx 980 , 1920 , Ultra , vsync on 60 fps) , one lap ok , second lap ok , etc...
but the game begin to stutter like crazy after a while (perhaps after 4 or 5 laps) , unbelievavle : my gtx 980 is only at 45% usage and my cpu (3770k@4.5) 30%.

Any ideas ?
thaks for help.

try once to disable the shader cache in your Nvidia profile

sammyv6s
08-05-2015, 09:00
I get a ton of stuttering on every track, mostly when braking into corners
Its REALLY bad on the Kart races.

Playing on Xbox one
Really annoying..almost ruins the game for me :(

Rivanov
08-05-2015, 09:00
try once to disable the shader cache in your Nvidia profile
Do you change this in the Nvidia Controlpanel? Or in Nvidia Geforce Experience?

Joeri Blootacker
08-05-2015, 09:02
Do you change this in the Nvidia Controlpanel? Or in Nvidia Geforce Experience?

Control panel. (in the game profiles)

Rivanov
08-05-2015, 09:05
Will this enhance my FPS too with my GTX 970 or is this mainly a setting for SLI configs?

cyberfred
08-05-2015, 09:12
thank you Joeri Blootacker , I try it and I'll tell you if it works ;)

bubbleguuum
08-05-2015, 09:16
Try to turn off force feedback (set it to 0%).

Mattias
08-05-2015, 09:17
Setting force feedback to 0% would ruin the entire driving experience and not a proper fix. But if that fixes the problem there is a deeper issue somewhere.

Joeri Blootacker
08-05-2015, 09:18
Will this enhance my FPS too with my GTX 970 or is this mainly a setting for SLI configs?

Shader cache on or off should have no or minimal impact on FPS.
if you are having FPS issues with your GTX 970, can you share your full system specs in your user profile ?
perhaps also your settings.

Rivanov
08-05-2015, 09:21
I don't have real FPS problems.. but i'm looking for the best settings to balance the highest IQ with the best FPS. :)
I can post my settings tonight.

Clear weather I get 60+ fps but in the rain the drop to 40/50. Maybe that is the best it can get, i don't know.. but i'm curious if there is some setting that can help a bit. :)

cyberfred
08-05-2015, 09:27
@Joeri : arf it s the same with shader cache disabled :(
But I find a small solution : alt tab back to windows and alt tab back to game , the stuterring is gone !
but after a while same problem , very annoying :/
gpu only @50% :(

perhaps the combo I use is bugged : ford MKiV and spa , I ll try another car on this track

Aldo Zampatti
08-05-2015, 15:05
I don't have real FPS problems.. but i'm looking for the best settings to balance the highest IQ with the best FPS. :)
I can post my settings tonight.

Clear weather I get 60+ fps but in the rain the drop to 40/50. Maybe that is the best it can get, i don't know.. but i'm curious if there is some setting that can help a bit. :)

When it's raining, 3 settings have MAJOR impact. 1) EnvMap, 2)Reflections and 3) Particles. Try reducing those to LOW, and give it another Go. If you get 60+ consistently, up the settings gradually


@Joeri : arf it s the same with shader cache disabled :(
But I find a small solution : alt tab back to windows and alt tab back to game , the stuterring is gone !
but after a while same problem , very annoying :/
gpu only @50% :(

perhaps the combo I use is bugged : ford MKiV and spa , I ll try another car on this track

Are you running SLI? Single GPU? What CPU do you have? Let me know your precise settings, I might be able to guide you further

Mahjik
08-05-2015, 15:11
Setting force feedback to 0% would ruin the entire driving experience and not a proper fix. But if that fixes the problem there is a deeper issue somewhere.

He's referring to the person using an Xbox One controller. There is a known issue when using an Xbox One controller with FFB enabled, as it will cause stuttering. If you are using an Xbox One (not 360) controller, it could be your issue. Some of the PS3 controller emulators will do the same thing.

Joeri Blootacker
08-05-2015, 15:16
Just as a reference :
i'm on SLI (Nvidia) and use the default profile with 3 tweaks :

Triple buffering - Disabled
Energy mode - Optimum performance
Vertical Sync - On - smooth


my ingame Settings
All to High (except Car and track detail on Ultra)
and Detailed grass to medium.

cyberfred
08-05-2015, 15:50
No sli , single gpu gtx 980 and i7 3770k@4.5 ghz Windows 8.1 64 bits, I try to play with low settings and same problem, after a while, stuttering :(

cyberfred
08-05-2015, 15:53
He's referring to the person using an Xbox One controller. There is a known issue when using an Xbox One controller with FFB enabled, as it will cause stuttering. If you are using an Xbox One (not 360) controller, it could be your issue. Some of the PS3 controller emulators will do the same thing.

THAT S IT ! Without force feedback, stuttering are gone ! Unbelievable, and indeed I use one controller !

Aldo Zampatti
08-05-2015, 15:59
THAT S IT ! Without force feedback, stuttering are gone ! Unbelievable, and indeed I use one controller !

Nice to see it worked out! Give the "likes" to Joeri and Mahjik ! and thanks for reporting back

cyberfred
09-05-2015, 00:19
no more issue with FFB off on xbox one controller after few hours , it s great , but any idea when this bug will be solved ?
I know it s better with a wheel , but I like to have FFB on my xbox one controller !

Aldo Zampatti
09-05-2015, 00:20
no more issue with FFB off on xbox one controller after few hours , it s great , but any idea when this bug will be solved ?
I know it s better with a wheel , but I like to have FFB on my xbox one controller !

Don't have an official statement about this. But it is in the shorlist for sure.

cyberfred
09-05-2015, 01:33
ok thank you very much aldo , great game !!!!