PDA

View Full Version : G27 profile not being acknowledged.



syn
08-05-2015, 02:41
No matter what I do, during the wheel calibration, the game detects i have 900 degrees set as the profile, when both my global and per game setting on the logitech profiler are set to 540.
I own a G27. Has anyone had this issue? What can I do to solve it?

thisisbleep
08-05-2015, 02:47
Have you set the Logitech software to accept the in-game settings? If you do not I assume that it will just use the default profile and ignore the changes that you have made in the game.

syn
08-05-2015, 02:49
Yeah, I have the "Allow game to adjust settings" checked on the logitech proiler, first on the profile I made for pcars (how do I know if it's using the x32 or the x64 executable, by the way?), and then on the global profiler, for good measure. Still, as soon as I alt tab to pcars, I feel a little tug on the wheel, and it resets itself to it's max rotation.

Aldo Zampatti
08-05-2015, 03:01
Yeah, I have the "Allow game to adjust settings" checked on the logitech proiler, first on the profile I made for pcars (how do I know if it's using the x32 or the x64 executable, by the way?), and then on the global profiler, for good measure. Still, as soon as I alt tab to pcars, I feel a little tug on the wheel, and it resets itself to it's max rotation.

I personally don't give a dime about the Profiler (I close it directly). I'll let PCARS detect my wheel, and then I set everything in-game.

Depends on the car, I change the Steering Ration which is basically Degress of rotation. That gives me a per-car option :)

thisisbleep
08-05-2015, 03:02
When running the game you can alt-tab out and check the task manager to see which EXE is running.

Is the Logitech profiler software up-to-date? You could also try deleting the local files and verifying the game through Steam.

syn
08-05-2015, 03:06
I personally don't give a dime about the Profiler (I close it directly). I'll let PCARS detect my wheel, and then I set everything in-game.

Depends on the car, I change the Steering Ration which is basically Degress of rotation. That gives me a per-car option :)

Does this give you a soft or a real lock? I want my wheel to stop rotating when I hit the limit I put on it. How do you set the wheel rotation from the ingame menus?

And yeah, the logitech profiler is up to date. Game was just downloaded, reinstalling it seems redundant?

Aldo Zampatti
08-05-2015, 03:13
I don't set xxx Degrees.
I just have the Force Feedback at 100, and If I'm driving a formula car, It will lock (but not as hard as the profiler does, but it locks) when it reaches the limit

syn
08-05-2015, 03:16
yeah, a soft lock. That shouldn't be necessary. The profiler is there for a reason, and it should be able to interface correctly with the game. This is a pretty weird bug.

Also, hola compatriota!

Aldo Zampatti
08-05-2015, 03:22
Otro Ché por aquí :)

Give the soft lock a try, never bothered to me in the past 2 1/2 year, but depends on your own taste.

syn
08-05-2015, 03:24
Well, since i'm brand new to the hobby, and I use trackIR, the helmet cam doesn't let me see the ingame wheel, so I often can't tell if i've hit the soft lock or not.

And I know the soft lock is a valid workaround, but i don't believe it's an acceptable fix for a 1.0 release, specially on the most popular wheel of the market.

Aldo Zampatti
08-05-2015, 03:33
Hard lock should be supported in game, since I don't use it, I can not tell. I'll search around for a solution for you and I will get you back. But AFAIK, I saw no internal conversations regarding this. I'll Direct more guys to here to help you out.

syn
08-05-2015, 04:09
Very much appreciated, thanks!

ermo
09-05-2015, 17:39
No matter what I do, during the wheel calibration, the game detects i have 900 degrees set as the profile, when both my global and per game setting on the logitech profiler are set to 540.
I own a G27. Has anyone had this issue? What can I do to solve it?


Yeah, I have the "Allow game to adjust settings" checked on the logitech proiler, first on the profile I made for pcars (how do I know if it's using the x32 or the x64 executable, by the way?), and then on the global profiler, for good measure. Still, as soon as I alt tab to pcars, I feel a little tug on the wheel, and it resets itself to it's max rotation.

I would suggest trying to set the profiler rotation to 900 degrees and then set the 540 degree rotation you want to use in-game instead as shown in the attached images. A Deadzone Removal Range setting of 0.15-0.18 is probably also a good idea.

I leave the in-game FFB strength at 100 and tweak the global Tire Force to suit my preferences because experiments have shown that keeping the in-game FFB strength at 100 gives the wheel the largest dynamic range and having the Deadzone Removal Range set at 0.15-0.18 ensures that the wheel is tight around Top Dead Center; with DRR set to 0, the wheel can feel light in around Top Dead Center as signals below a certain threshold apparently do not activate the wheel motors.

Best of luck mate! :)

syn
09-05-2015, 21:16
Thanks for the help, but that still doesn't solve pCars communication with the logitech profiler. Just a few moments ago, something clicked, and the game recognised the profile, turning only 540 degrees, even on the wheel settings. However, somethign bugged out, and the buttons in the wheel didn't respond anymore. After a restart, wheel is back to normal functions, and pCars again overrides every profile i toss at it.

There is definitely a bug here. Is there somewhere I can get a support ticket opened or something of the sort?

ermo
09-05-2015, 22:00
Thanks for the help, but that still doesn't solve pCars communication with the logitech profiler. Just a few moments ago, something clicked, and the game recognised the profile, turning only 540 degrees, even on the wheel settings. However, somethign bugged out, and the buttons in the wheel didn't respond anymore. After a restart, wheel is back to normal functions, and pCars again overrides every profile i toss at it.

There is definitely a bug here. Is there somewhere I can get a support ticket opened or something of the sort?

1) Don't set the profiler to 540 degrees. Set it to 900 degrees. Don't ask why, just do it.
2) Set the 540 degrees rotation you want in-game.
3) Note that the Logitech Profiler game profiles functionality appears to be bugged (not just in pCARS, mind). If at all possible, use the profiler global settings for pCARS; set to 900 degrees as per 1) and tick Allow Game To Override Settings.
4) As far as I'm aware, Logitech no longer cares about their wheel business so good luck getting them to fix any profiler bugs.

The above is what I do and it works well for me. Enjoy Project CARS on your G27 wheel. =)

syn
09-05-2015, 22:57
Yeah, the profiler may be the culprit. What a shame. Soft lock is extremely confusing for my senses, I always end oversteering. In any case, thanks again for the help.