PDA

View Full Version : Oculus + fps drop + latest update



Fusuy
09-05-2015, 02:19
It's clear I'm the only one experiencing this (that or no one has bothered to read other forums lol) Heres the copy paste I've had up on various sites; Posted yesterday.

Today I decided to jump in the Lycan and take it for a spin around Imola. Once I jumped in it I noticed my FPS was low and there was some screen tearing/artifacts. I hadn't even left the pits yet. Once I left the pits and going quite slow, it was still noticable but not entirely worse since I was out of the pits and away from the grand stands. This is now happening to every car I jump in. Almost double images on certain objects too. This wasn't even career mode.. I remember last night my last race in career (open wheel) was running around 60-75+fps (only dropping near grand stand/pitlane) even at high speeds I was getting good FPS. To be fair I haven't tried it on the track I was racing on last night. But after I finish posting this up a few times, I'll test that track with the same car and see if I'm still getting the same issues. However, I don't see how it could be the same as last night if I'm getting screen tearing/artifacts today =\

My settings before today was moderate, only having 1 or 2 things set to high. For the best part MEDIUM was mostly selected with post processing (rays) set to low and others left standard 60-75fps.

Today my settings are all set to low and ALL post processing effects turned off. I still can't stop this double image issue. It's not the driver issue NVIDIA had awhile ago. Its weird, and frustrating. <60FPS + tearing/artifacts everywhere, even when not moving. Temps are fine. Double image (some places)


Win8.1
i7-4770k 3.5-4ghz
Gigabyte G1 980
8GB 1600mhz ram

Morgan Henstridge
09-05-2015, 02:37
Hi Fusuy, I don't have my DK2 hooked up at the moment.

First place i would check is the DK2 Setup sticky (http://forum.projectcarsgame.com/showthread.php?21856-Oculus-rift-DK2-Setup-Guide). Lots of good info in there that may help.

Fusuy
09-05-2015, 05:51
Thanks :) I found using Vsync does fix almost all of my issues and I can put some of the GPU settings back up (not all) but vsync causes head tracking lag. Not sure why all of this is happening after the update with the lycan =\ anyway I'll take a look at that thread, at worst i'll deal with it with vsync on :D

Morgan Henstridge
09-05-2015, 05:58
When I had my DK2 hooked up, I was using Vsync ON in game, and was using nvidia inspector to set the frame rate lock to 75fps (rift fps)

This seemed to be the best combo for me, but your mileage may vary :)

You will also want to lower the settings so you are ALWAYS over 75fps with the Rift, otherwise the slowdown can induce movement lag and is quite an immersion breaker.

Aldo Zampatti
09-05-2015, 06:33
Thanks :) I found using Vsync does fix almost all of my issues and I can put some of the GPU settings back up (not all) but vsync causes head tracking lag. Not sure why all of this is happening after the update with the lycan =\ anyway I'll take a look at that thread, at worst i'll deal with it with vsync on :D

What Morgan Said. AND/OR setting Render Frames Ahead=1 will also reduce lag and genera discomfort in oculus :)

monty585
21-05-2015, 18:40
I'm sorry for this noobiness, but where do you go exactly to change these settings? Force vsync off (outside of game), framerate lock, render ahead... etc.

Thanks!

Aldo Zampatti
21-05-2015, 20:25
I'm sorry for this noobiness, but where do you go exactly to change these settings? Force vsync off (outside of game), framerate lock, render ahead... etc.

Thanks!

2 of those can be set in-game if you have defaults on your nvidia driver.

In-game: Options&Help / Visual / Performance tab.

You will find V-SYNC and Rendered Frames Ahead.

Framerate lock can be accomplished with external tools (like RivaTuner) or using -fpscap xx on the game start parameters.

monty585
22-05-2015, 17:42
Is anyone else noticing that anti-aliasing of any sort is adding lag and judder in head tracking? If I hold my head still, the framerate is great and it looks awesome. And if I have everything on ultra, but anti-aliasing turned off the head tracking is great. But there's jaggies. But the second I turn on the lowest setting of anti-aliasing (even if all graphics are low or off), micro judder/lag starts. I'm running a titan x so I would think I could at least get one degree of AA without performance decreases. Oh yeah, the weird thing is even with AA ON, my frame rate is great (over 75fps) but the judderiness remains, like it's a two-eye render head tracking issue, not a video card per se issue. Anyway, yeah...