PDA

View Full Version : Xbox 360 Wireless Racing Wheel Support?



Blessa
09-05-2015, 07:13
I have the old 360 racing wheel I have connected with an xbox wireless dongle, it works well with most games but it would great to see support or at least tweaking guides for pCars.
The controller doesn't get detected in any of the profiles except the xbox one controller.

If anyone knows any workarounds for this, please leave a reply.
Thank you!

thezepter
11-05-2015, 11:36
I have this Wheel too and can´t get it to work correctly. I configured it as an custom wheel and there is a horrible 20..30° Deadzone. Pls. support this wheel !!! The ingame calibration works great, but i cant remove this fu*** Deadzone.

I´ve tried Windows 10 and Windows 8.1. No Problems with other Games.

psaunder
15-05-2015, 12:31
I have same issue. Early in the game development, it was possible to map the MS SpeedWheel as a custom wheel, but it doesn't seem to be possible any more.

tinok
15-05-2015, 14:28
I have the same Problem i had buy PC and i try my first game ... but for now it is not playable with this good wheel!

I had buy extra RAM and a new graphic card only to play Project Cars!!!

Valver
15-05-2015, 15:13
Does the wheel give full forcefeedback, just rumble effects, or nothing?

Dwayne
15-05-2015, 15:40
If you are under PC you can try my wrapper linked in this post (http://forum.projectcarsgame.com/showthread.php?21992-Setting-up-a-gamepad&p=908071&viewfull=1#post908071). No guarantee that it will work and you most probably will have to configure it (read the readme for instructions) but as long as it as directinput driver (xbox gamepads have it so xbox wheels probably support it too) it should work ;)

TheUnknownZ
15-05-2015, 18:26
Confirmed for working on the discontinued xbox 360 steering wheel!! It got rid of the horrible deadzone completely. The ffb is not working but that's all on Microsoft. Awesome work Dwayne, thank you very much for the time and effort for creating that tool:cool: now I can finnaly enjoy this game;)

Dwayne
15-05-2015, 20:13
Confirmed for working on the discontinued xbox 360 steering wheel!! It got rid of the horrible deadzone completely. The ffb is not working but that's all on Microsoft. Awesome work Dwayne, thank you very much for the time and effort for creating that tool:cool: now I can finnaly enjoy this game;)Glad it worked :)

Out of curiosity can you tell me if it worked out of the box or did you had to find and change the guid? I'm asking as if you had to change it you can post it here so it would be easier to configure for other people.

Ba11y
16-05-2015, 20:49
Sorry to jump in on your thread , but I can also confirm that the workaround by Dwayne works great in getting rid of the dead zone for Xbox 360 wheel . This is how I had to do it - When I first copied the files into the PCars install folder the wheel calibration would not let me change any buttons so I followed your instructions : "select and copy the guidInstance value" for my wheel and it then worked . Thanks a lot mate , saved me having to buy a new wheel just yet :D:D

thezepter
18-05-2015, 12:56
Glad it worked :)

Out of curiosity can you tell me if it worked out of the box or did you had to find and change the guid? I'm asking as if you had to change it you can post it here so it would be easier to configure for other people.

guidInstance : {0D56C5A0-F4A1-11E4-8001-444553540000} (I think it´s the same)

@Dwayne: Thanks for your tool ! Solved my deadzone problem, but now i have trouble with the Pedals (Accelerate & Brake) from the MS wireless wheel.
I get only digital signals . No analogues . So you can drive a car ^^
Any idea ? (sorry for my english, iám from Germany)

Dwayne
18-05-2015, 14:23
guidInstance : {0D56C5A0-F4A1-11E4-8001-444553540000} (I think it´s the same)

@Dwayne: Thanks for your tool ! Solved my deadzone problem, but now i have trouble with the Pedals (Accelerate & Brake) from the MS wireless wheel.
I get only digital signals . No analogues . So you can drive a car ^^
Any idea ? (sorry for my english, iám from Germany)If you get digital instead of analog with analog pedals then it's because the game reads them as being digital or they are not properly calibrated. If in the remap it correctly shows the axis (Z) then it might need to be recalibrated.

First check with in-game pedal calibration. If you still got the same then check if they are properly mapped in windows. Click start menu and in the command line box type "joy.cpl" and press enter. Select your controller and click properties. A test window should show how your pedals behave. If they work digital then try to recalibrate them.

If it didn't solved your problem then the game incorrectly reads the axis capabilities of your pedals. That would be strange as I don't change any controller capabilitie, only thing is that I set it up to detect it as a joystick but no report from other users that it would influence the behavior of the pedals.

Anyway, in v0.1.4 there's an option to change the device type and subtype. Edit the ini and change newdevicetype (20-joystick) to =22. newdevicesubtype defines the subtype, in case of a wheel 2 is for combined pedals and 3 for dual/separated (don't know if you can get separated for xobx devices under directinput though, for the xbox gamepad it's not possible although there's a possible workaround).

If none of the above worked then I can't solve your problem. v0.1.4 don't have enough debug information to see what's happening but I'm planning to release a new one with extended info, that might help understand what's going on.

p.s
Does MS wheels have any kind of real force feedback or only centering spring?

thezepter
18-05-2015, 20:52
If you still got the same then check if they are properly mapped in windows. Click start menu and in the command line box type "joy.cpl" and press enter. Select your controller and click properties. A test window should show how your pedals behave. If they work digital then try to recalibrate them.

If it didn't solved your problem then the game incorrectly reads the axis capabilities of your pedals. That would be strange as I don't change any controller capabilitie, only thing is that I set it up to detect it as a joystick but no report from other users that it would influence the behavior of the pedals.

p.s
Does MS wheels have any kind of real force feedback or only centering spring?

Thanks ! :cool: joy.cpl is my friend ^^ I cant find the menue in Windows 10. ^^ Pedals work fine now after reset and recalibration.

And yes, this Wheel has real force feedback, but not with your way to use this wheel. If i config the wheel in normal (custom wheel) with fu*** deadzone, the force feedback work fine.

Fallen_Tyrael
31-05-2015, 07:19
Hi, I would also like to see support for this wheel on PC.

The problem im having is that i can seem to set my wireless 360 wheel as a xbone one controller, but it refuses to detect it if i try to set it up as a custom wheel :(

So my questions are... How did any of you get the wheel to detect as a custom wheel?
thezepter: how did you get the real force feedback to work when the microsoft drivers dont support it?
and if i use the wrapper will it detect my wheel using custom wheel and will the rumble effect still work for the wheel like it does if i use it as an xbone one controller?
I understand that the propper force feedback will never work for the 360 wheel because microsoft are a bunch of lying muppets and arnt going to update the drivers, but id like to at least keep the rumble.

Thank you in advance for any help.

Puff3r
21-06-2015, 01:23
Ok, so I suppose I am confused as to how to use this tool correctly. I have the 360 Wireless Wheel and have downloaded the most recent version of the tool, 0.4.2. I extracted the files to a temp folder and tried to setup the reload buttons but nothing seems to occur. I copied the required files to my PCars folder, using the x64 dll's. I then opened the editor and chose Disable Xinput. Again, nothing seems to happen. So I manually edited the ini. At that point I changed the guid to a value that was not the wheel ( the directions are a bit confusing here, it says both to set it to the guid for the wheel and also to "fake your device so the game don't recognize it". I then set the game to custom wheel and attempt to map the wheel. In game I get no response from the wheel or pedals. I have tried with the guid for my wheel, my keyboard, and a guid completely made up. All give the same error, no reply from the wheel. I can set it to Xbox One controller, but then the deadzone is back.

HBR-Roadhog
21-06-2015, 05:27
I'm a bit surprised to see that there are people who still have these wheels. Did they not stop selling these a few years ago? I had one and gave it away about 5 years ago. Every one of my friends who had one had issues with them, either the shifters breaking off or the wheel would get to where it always wanted to turn full left or full right making them unusable. Even when they worked correctly and connected to the 360 they were buggy shifting gears for no reason, popping up pause menu just out of the blue or suddenly looking left or right when no buttons had been touched.

I always used mine just for oval racing and it seemed that the shifters would break off using it for road courses and sure enough my friend broke his shifter and then after I gave mine away the shifter broke off. One friend went through like 4 of them in less than a year before he finally bought a good wheel. I know a few other people who had more than one due to the poor durability of the wheel until finally they could not get another one and had to move on. All of them now have Fanatec wheels and while the initial cost is much higher than the MSWheel the long term cost is actually cheaper and is a much much better wheel.

Dwayne
21-06-2015, 09:58
Ok, so I suppose I am confused as to how to use this tool correctly. I have the 360 Wireless Wheel and have downloaded the most recent version of the tool, 0.4.2. I extracted the files to a temp folder and tried to setup the reload buttons but nothing seems to occur. I copied the required files to my PCars folder, using the x64 dll's. I then opened the editor and chose Disable Xinput. Again, nothing seems to happen. So I manually edited the ini. At that point I changed the guid to a value that was not the wheel ( the directions are a bit confusing here, it says both to set it to the guid for the wheel and also to "fake your device so the game don't recognize it". I then set the game to custom wheel and attempt to map the wheel. In game I get no response from the wheel or pedals. I have tried with the guid for my wheel, my keyboard, and a guid completely made up. All give the same error, no reply from the wheel. I can set it to Xbox One controller, but then the deadzone is back.Works fine for me :cool:

In theory with 0.4.2 you just need to enable "disable xinput" without needing to manually change the guid, unless you got more than one controller device. One thing I didn't mention in the readme is that the redist for VS 2013 (https://www.microsoft.com/en-us/download/details.aspx?id=40784) are needed but since it didn't gave you any error at game launch I suppose you have it installed.

Anyway, PM me your log if you want so we can try to solve the issue.

Puff3r
22-06-2015, 13:04
So it is confirmed, I am an idiot. The wrapper works perfectly. It never occurred to me that after choosing Custom Wheel I would have to actually map the wheel, pedals, and buttons, as the wheel worked fine in menus. Thank you, Dwayne, for the awesome tool and the offer of assistance.

7Dave7
23-06-2015, 19:17
I'm using the 360 wireless racing wheel and everything works fine. Make sure you calibrate in the control panel first, then in game select mode 2 and calibrate in game. If it still has the deadzone then download Durazno v0.6-18.zip from here:

https://drive.google.com/folderview?id=0B1wssOeJs5_7czZ1WW93SzFxUWs&usp=sharing

Follow the instructions in the zip. You may not need durazno so try without it first. I'm using it and everything including force feedback is working and no deadzone issue. Hope this helps someone.

EDIT:I removed durazno and tried the wheel again and everything still works fine so it is not needed. Mode 2 is the key to make the X360 wheels work. Everything including force feedback and no deadzone is working great. I have no wrappers or anything else installed. Hope you guys have the same results.

gonzo1207
29-06-2015, 01:28
I'm using the 360 wireless racing wheel and everything works fine. Make sure you calibrate in the control panel first, then in game select mode 2 and calibrate in game. If it still has the deadzone then download Durazno v0.6-18.zip from here:

https://drive.google.com/folderview?id=0B1wssOeJs5_7czZ1WW93SzFxUWs&usp=sharing

Follow the instructions in the zip. You may not need durazno so try without it first. I'm using it and everything including force feedback is working and no deadzone issue. Hope this helps someone.

EDIT:I removed durazno and tried the wheel again and everything still works fine so it is not needed. Mode 2 is the key to make the X360 wheels work. Everything including force feedback and no deadzone is working great. I have no wrappers or anything else installed. Hope you guys have the same results.

what do you mean "mode 2"??? what is mode 2? that's not even an option anywhere.

7Dave7
29-06-2015, 04:03
Options>Controls>Configuration

Scroll down the list, near the bottom you will see controller input mode, make sure it's set to 2.

Puff3r
29-06-2015, 17:43
Options>Controls>Configuration

Scroll down the list, near the bottom you will see controller input mode, make sure it's set to 2.

Are you using Custom Wheel or a different default controller? I tried Custom Wheel with Mode 2 and no wrapper, dead zone was horrible. Went to the settings and set deadzone to 0 and sensitivity to 100, still uncontrollable. The wrapper provided by Dwayne has worked for me.

Also, you say you have force feedback, I thought the drivers for the 360 wheel never had FF enabled.

7Dave7
29-06-2015, 17:57
I'm using custom wheel, deadzone set at 0, sensitivity 50. When I used Dwaynes wrapper the wheel was limp like the wheel was unplugged, no force applied to it, no vibrations, rumble etc. I then tried Durazno to see if it worked any better but it didn't seem to do anything. Somewhere in between I stumbled onto the mode 2 setting and everything is now working great with no wrappers. I thought I had tried mode 2 before but must not have. I know with mode 1 or 3 the deadzone is horrible. If mode 2 doesn't work for you try installing the Durzano wrapper with deadzone at 0 and set up the wheel mode 2 and see if it works. If it does, remove Durazno and see if it still works properly. Make sure to calibrate the wheel in windows control panel first then in game. I'm using Windows 7 by the way.

Puff3r
29-06-2015, 19:06
I'm building rockets in Kerbal Space Program right now, but I will try this later this evening and post my results here. Thanks for the suggestions.

7Dave7
29-06-2015, 19:20
You're welcome, hope it works for you. I gotta build me some rockets in KSP when I get time.

Puff3r
30-06-2015, 02:25
Ok, so here are the results. I first went back to complete stock, deleted my save and all game files and registry entries. Win 7 also, btw. After reinstalling PCars, I recalibrated my wheel in Windows and chose Custom Wheel and 0 deadzone with 75 sensitivity. Wheel felt like playing in a bowl of banana pudding. Installed Durazno and followed instructions. WHAT A DIFFERENCE!!!! Wheel is sharp and reactive, with FFB. Blown away. Thanks for the help to everyone in this post. Game is so much better when the wheel functions properly.

****EDIT*****

Forgot to mention I was using Mode 2 for all testing as well.

7Dave7
30-06-2015, 02:32
I'm glad it's working for you. It does make so much more difference when it's working right.

gonzo1207
03-07-2015, 01:15
Ok, so here are the results. I first went back to complete stock, deleted my save and all game files and registry entries. Win 7 also, btw. After reinstalling PCars, I recalibrated my wheel in Windows and chose Custom Wheel and 0 deadzone with 75 sensitivity. Wheel felt like playing in a bowl of banana pudding. Installed Durazno and followed instructions. WHAT A DIFFERENCE!!!! Wheel is sharp and reactive, with FFB. Blown away. Thanks for the help to everyone in this post. Game is so much better when the wheel functions properly.

****EDIT*****

Forgot to mention I was using Mode 2 for all testing as well.

I'm seriously going insane trying to get this deadzone fixed by following what you guys are saying and i'm having no luck... Here's what i'm doing: 1) i calibrate in windows
2) copy and paste duranzo exe and dll into pcars directory
3) run exe
4) start the game up
5) calibrate custom wheel which is in mode 2
6) check steering to see if it's fixed and dissapointment (rinse and repeat 8 million times)...

what the hell am i doing wrong here?

am i missing more steps? is there something i'm supposed to edit in the .ini file that's generated after running the duranzo exe??

7Dave7
06-07-2015, 21:31
Make sure your deadzone is set to 0 in durazno and project cars. Looks like everything else you did was right. You don't need to keep the durazno .exe in project cars directory after you run it, just the .dll and the .ini it makes.

Make sure you are using the correct .dll for your version of windows, 32 or 64.

gonzo1207
07-07-2015, 18:16
Make sure your deadzone is set to 0 in durazno and project cars. Looks like everything else you did was right. You don't need to keep the durazno .exe in project cars directory after you run it, just the .dll and the .ini it makes.

Make sure you are using the correct .dll for your version of windows, 32 or 64.

Did those things and it still doesn't work. Dedzone in both durazno and game settings is zero. Dll is 64 bit version since I'm on 64 bit Windows 7.

7Dave7
07-07-2015, 18:29
Do you have any other wrappers in your pcars directory? Dwaynes for example? Something may be interfering with it. Make sure only durazno wrapper is installed. Other than that I'm not sure why it wouldn't work. You did everything else the same as I did. I don't know where it saves this info, but maybe you could delete it and restart with the custom wheel setup.

gonzo1207
07-07-2015, 21:24
Do you have any other wrappers in your pcars directory? Dwaynes for example? Something may be interfering with it. Make sure only durazno wrapper is installed. Other than that I'm not sure why it wouldn't work. You did everything else the same as I did. I don't know where it saves this info, but maybe you could delete it and restart with the custom wheel setup.

I tried dwayne's wrapper which also didn't work for me. There were no other wrappers in the folder when I tried durazno. I guess I'll do a complete uninstall and try again at some point... So annoying to go through this bs just to get a race wheel working properly.... In the meantime I'm playing forza 4 which is still a lot of fun with this old wheel. I do miss pcars physics a little bit but the customization in forza is outstanding.

true_scotsman
09-10-2015, 19:57
Sorry to resurrect an old post, but I have a question regarding the MS wheel, I have used the 2 wrappers that are listed in this thread and I still cant get the wheel to work properly. I can navigate the menus but when it comes to calibration I get no signals what so ever. Using the Duranzo I can see that the wheel responds etc, but in game i can only navigate the menus. Any ideas on what I am doing wrong?

lacac
16-07-2016, 12:10
Sorry to resurrect an old post, but I have a question regarding the MS wheel, I have used the 2 wrappers that are listed in this thread and I still cant get the wheel to work properly. I can navigate the menus but when it comes to calibration I get no signals what so ever. Using the Duranzo I can see that the wheel responds etc, but in game i can only navigate the menus. Any ideas on what I am doing wrong?

hey guys,

I've got the same problem, tried both progs, and still just menu control, not in the game.
If i try to calibrate, nothing happens :(
please help

thanks

krztoff
02-08-2016, 21:44
hey guys,

I've got the same problem, tried both progs, and still just menu control, not in the game.
If i try to calibrate, nothing happens :(
please help

thanks


See post #17. This is what fixed it for me ... I forgot to map keys BEFORE trying to calibrate.

krztoff
02-08-2016, 21:47
So I was able to get my MS Wheel detected and working in Pcars using DX Ace ... however, I still have a pretty big deadzone. Right now the deadzone stops at about "30" on the DX Ace graph when I show input. However, even when I adjust the deadzone (I've tried between -30 and -99) there is absolutely no effect at all in game. Is it possible this deadzone adjustment is broken or incompatible with this particular device?

Also, does DX-Ace use the same config file location even if I run in 64 bit? The INI is in the Pcars root folder, but I assume the DLLs I'm using are in the game's "x64" folder. Should I be running DX Ace from within the "x64" folder? When I try to "get input", it tells me that I'm using invalid/wrong DLLs ... is there a seperate build of dx ace for x64?

edit: I just tried the "beep on setup load" ... and there's no beep. What could cause this to fail to load?

Dwayne
05-08-2016, 15:31
So I was able to get my MS Wheel detected and working in Pcars using DX Ace ... however, I still have a pretty big deadzone. Right now the deadzone stops at about "30" on the DX Ace graph when I show input. However, even when I adjust the deadzone (I've tried between -30 and -99) there is absolutely no effect at all in game. Is it possible this deadzone adjustment is broken or incompatible with this particular device?I had a bug with the negative dead zone not working properly in some previous versions but I think I solved it in the last,or previous to last, version, don't recall exactly, so if you tried the latest one it might be another problem.

Anyway, you can get rid of the deadzone by either set negative values under xinput (in this case you'll only need the xinput1_3.dll (tho if both dlls are present it will do no harm) or force the game to use dinput under unknow device (set "disable xinput" and "Dinput change ID" in the editor settings). If you do it under xinput you will get less dead zone but it will still be heavily filtered (limited counter-speed wheel speed - variable dead zone depending of the car speed etc) since it's not possible to get "raw" ouput under that API in Pcars (a problem that exists since NFS Shift 1...).

The downside for xinput wheels of forcing the game to use dinput is that you'll loose ffb. I dunno your wheel but most ffb wheels have an option to force auto centering. If yours have it I think it would be a better idea to enable it and loose ffb than to have full ffb under xinput but with it's heavy filtering always active.

Another way to solve this problem would be to install a 3rd party driver like XBCD or the Japanese xi driver since both drivers provide FFB under dinput, unlike the MS one... But in this case you'll loose compatibility in other games for which you'll have to use a dinput to xinput wrapper like x360ce :p

There's also the Xinput plus wrapper that provides FFB under dinput but I don't think it can change the device ID so you will have the same heavy filter problem. Anyway give it a try and see how it goes if you want.

Of course, I could try to translate dinput FFB commands to xinput by integrating the open source code of the xi or the XBCD driver into my wrapper but it's too much work for a doubtful result since I have my doubts that these drivers correctly translate dinput FFB commands to xinput, which consist of only setting amplitude for left and right motors. Plus I don't have any xinput wheel to do the testing so it would be very hard to debug it.


Also, does DX-Ace use the same config file location even if I run in 64 bit?Yes


The INI is in the Pcars root folder, but I assume the DLLs I'm using are in the game's "x64" folder.No, the dlls, 32 or 64 bits must be present where pcars(64).exe is. Some games might call the dlls from a different folder than the main exe but it's rare and it's certainly not the case for Pcars.


Should I be running DX Ace from within the "x64" folder? When I try to "get input", it tells me that I'm using invalid/wrong DLLs ... is there a seperate build of dx ace for x64?Nothing ot my wrapper's files goes into the x64 folder. The editor needs the 32 bits versions of the dlls for the "get input" to work but it doesn't mean it doesn't work when they are not present since the editor main function is to save changes to the ini file.


edit: I just tried the "beep on setup load" ... and there's no beep. What could cause this to fail to load?If you do not hear a beep when launching the game with the "Beep on setup load" enabled then it's that it didn't load either dll. Again make sure that you have the correct dlls, ini and the editor in the same folder than pcars(64).exe. If you use the 64 bits version of Pcars copy the dlls from the x64 folder instead (nothing to do with the game's x64 folder...)

If you're not sure if the game loaded the dll(s) enable the file log (before launching the game) and see if it created it. If it's the case the game loaded it. Another quick test is to press F1 while in game and see if a beep is produced when you press it meaning it reloaded the settings.

StabYourFace
15-08-2016, 02:37
Hey sorry to dig up old thread, but I've figured out how to make the wheel work correctly without any wrappers or third party software. It's a bit of a hassle the first time setup, but after that it works great with no deadzone, at least in Windows 10.

1.) Once you have 360 wheel installed, go to Windows devices and printers and get game controller settings there. Do the calibration for the wheel in the Windows version first.
2.) Once calibrated, launch PCars and set to Custom Wheel.
3.) Next go to EDIT ASSIGNMENTS and bind all keys and axis's.
4.) Next go to CONFIGURATION and set Controller Input Mode to 2 first.
5.) Next set all deadzones to 0, and I use and like the following settings so far:
-Steering Sensitivity: 33
-All Pedals Sensitivity: 42
-Speed Sensitivity: 0
-Controller Filtering: 0
-Damper Saturation: 0
-Everything under Advanced: Off
6.) Next go to CONTROL SCHEME and set gearing to manual, then calibrate both the wheel and pedals.
7.) Save settings, quit game, and relaunch.

It should now work without a deadzone.

VERY IMPORTANT - After you've EVER run the calibration, you need to relaunch the game otherwise deadzone will come back. Doing the calibration triggers the deadzone for some reason. But relaunching the game will get rid of it.

monko760
06-09-2016, 22:34
Thanks Stab, just got a rift, and about to buy a 360 wheel on CLIST for 50 bux. This guide will definitely help. Will update if its working to confirm for anyone else who stumbles across this thread like I did.

DeadPoolXBL
04-01-2017, 17:17
I just got an oculus over the holidays and was hoping to use my X360 Wirelesss Racing Wheel with Project Cars. When I try to setup the racing wheel Windows 10 is telling me that 360 accessories are not supported. Is there a trick to get it connected to the PC?

kaddigart
04-01-2017, 20:11
Hello all, I joined to let any other poor suckers like me that have been trying to get this wheel working know that there is hope. After hours of poring through forums and trying many things that don't work at all, I found that the solution is already within the game. I am using Windows 10.

Simple as this: choose another wheel. Yep, that's it. Pick a wheel that looks similar (I went with one of the Ferrari ones) and assign the controls, calibrate, play. That's it. Go play. Force feedback and all. I will note that there are some dead zone issues at first, but those can be ironed out with a little tweaking. Once I nail down something I'm completely happy with I'll come back with the exact configuration.


I just got an oculus over the holidays and was hoping to use my X360 Wirelesss Racing Wheel with Project Cars. When I try to setup the racing wheel Windows 10 is telling me that 360 accessories are not supported. Is there a trick to get it connected to the PC?
You have to manually install the driver through device manager. Find the unknown device, choose to update driver, choose let me select from computer, scroll all the way down to XBox peripherals and locate the wireless adapter option. Done.

DeadPoolXBL
05-01-2017, 12:42
Thanks kaddigart! Windows recognizes the wheel now. Now I just need to go into PCars and setup there. Can't wait!

DeadPoolXBL
05-01-2017, 13:24
I got everything working! Thanks everybody. This is amazing.

John24ssj
02-06-2017, 07:49
I've tried everything mentioned in the forum but I am still having issues with the dead zone where for about 20 degrees there is no response in the game, but in calibration screen the wheel is picked up just fine.
Any suggestions?

88Turbo
02-01-2018, 08:20
Bump
I just purchased Project Cars 2 and am trying to get this wheel working with it, posted a new thread about it in the "general" forum.
Any help would be appreciated, it calibrates as "custom wheel" and the game sees the steering input, everything appears to work fine(it works great in Dirt Rally) and was a fun wheel for tons of games, except PC2 it seems.... Dissapointed, Oculus in Project Cars 2 looks great - I just need my wheel to work....
Anyone tried the MS Xbox 360 Wireless Racing Wheel in Project Cars 2 and figured out how to get the steering input to work as "custom wheel"????
Thank you for any help you can provide.

Dwayne
03-01-2018, 15:14
Bump
I just purchased Project Cars 2 and am trying to get this wheel working with it, posted a new thread about it in the "general" forum.
Any help would be appreciated, it calibrates as "custom wheel" and the game sees the steering input, everything appears to work fine(it works great in Dirt Rally) and was a fun wheel for tons of games, except PC2 it seems.... Dissapointed, Oculus in Project Cars 2 looks great - I just need my wheel to work....
Anyone tried the MS Xbox 360 Wireless Racing Wheel in Project Cars 2 and figured out how to get the steering input to work as "custom wheel"????
Thank you for any help you can provide.Select the game's xbox gamepad profile as a simple solution. Custom wheel was buggy at pc2 launch (under xinput that is) but when I retried it when patch 2.0 was released it worked... but it behaved as if it was a gamepad, with heavy steering dampening, which can't be totally disabled, as well as some hidden traction control it seems...

If you're not totally happy with the in game gamepad profile and it's limitations the only way is to force the game to detect your wheel... as a wheel :cool: Downside is that the MS driver does not support FFB under dinput... To overcome this problem I recently added an option to attempt to translate the FFB commands under dinput into xinput. Worked better than expected for the xbox gamepad but since I don't own a xinput wheel I have no idea if it works as intended for those devices :o. Nevertheless there's a profile for those wheels when you fake the FFB but no guarantees that it will work as expected, in theory it should :rolleyes:

EdisLeado
13-08-2018, 01:29
This thread set my hopes high so I picked up an Xbox 360 wireless racing wheel. Unfortunately, my results were disappointing. The wheel, in some way or another, works, sure, but it's certainly not ideal.

I'm on Windows 10 and I already had an Xbox 360 controller wireless adapter and was able to pair the wheel with no issues.

I was able to get this wheel to work with Project Cars 1, however, I can confirm that while the dead zone is gone using Duranzo (with Mode 2 and Custom Wheel config), there is NO actual FFB, despite what previous posts claim. At the most, I can detect some extremely light, barely noticeable rumble, not FFB, and even then, the rumble doesn't seem to occur consistently. Anyway, using Duranzo, there were no issues assigning buttons in the options nor when calibrating the wheel and pedals.

Unfortunately, with Dwayne's dx ACE tool, I wasn't able to get PC1 to allow me to assign buttons after disabling Xinput and faking the device ID.

Project Cars 2 was especially troublesome. Using Custom Wheel and either Duranzo or Dwayne's dx ACE tool (to disable Xinput and fake the device ID), I would be able to calibrate the wheel (either by using Custom Wheel depending on the wrapper setting, or hijacking another wheel's config), but in-game, the wheel failed to register any input. Pedals were okay though. The only way I could play PC2 was to use the Xbox controller mode for the wheel, which is not ideal. Also, FFB did not work - only barely noticeable rumble just like in PC1.

I also tried to use dx ACE in Dirt Rally, but once I disabled Xinput, the game was unable to detect my wheel at all. Normal Xinput with no wrapper was fine though using the Xbox controller config.

Any tips on getting FFB to actually work? I've read previously in this thread that XBCD or the Japanese Xinput driver could be used, but I had no success with those either.

Any help would be appreciated!