PDA

View Full Version : PS4 Thrustmaster T300RS trouble



Stevedue
09-05-2015, 08:43
Help me please.
I play Project Cars on my Playstation 4 with a Thrustmaster T300RS, but when I start a race, the machine 9 times out of 10 do not start, I press the accelerator, shift gears, but the car remains stationary on the starting line.
The same behavior happen also if I'm going to crash and stop against a wall, the car stay stuck, I put into reverse and press the accelerator, but I do not move.
When I can go and do the race is changing the accelerator and the shift work perfectly.
Anyone using the T300RS con help me on this problem?

TWIsM
09-05-2015, 11:27
try turning on automatic engine ignition in the options menu. Also tjek your button mapping. Maybe you need to sign a button for engine start ie. R3. Then hold down the clutch and press the speeder hvile pushing R3 then the engine starts. Note it is possible to stall the engine as in real life.

Stevedue
09-05-2015, 13:51
try turning on automatic engine ignition in the options menu. Also tjek your button mapping. Maybe you need to sign a button for engine start ie. R3. Then hold down the clutch and press the speeder hvile pushing R3 then the engine starts. Note it is possible to stall the engine as in real life.

The machine start and the engine is working right.
I hear the noise of the motore and see on the screen the graphic that show the throttle go up.
I think is not this the problem.

I've joust update the wheel firmware to the new 24 version, hope this resolve some problem....

Siberian Tiger
09-05-2015, 13:54
Have you downloaded the latest Patch? (Day1Patch)
Just to be sure you are running the latest available..

ivan-hoe78
09-05-2015, 14:04
Help me please.
I play Project Cars on my Playstation 4 with a Thrustmaster T300RS, but when I start a race, the machine 9 times out of 10 do not start, I press the accelerator, shift gears, but the car remains stationary on the starting line.
The same behavior happen also if I'm going to crash and stop against a wall, the car stay stuck, I put into reverse and press the accelerator, but I do not move.
When I can go and do the race is changing the accelerator and the shift work perfectly.
Anyone using the T300RS con help me on this problem?

With the manual clutch, like I have, at the start of a race you need to push and maintain it, then shift first gear and when the lights turn green leave the clutch and push the throttle. If you loose the car or crash with walls, you need to push the clutch (and maintain it pushed) before the engine turns off. If you put the shifter in neutral you can leave the clutch. If the engine turns off, you need to ignite it again (mapping a button for ignition needed). Like in real life. The point about this, for me is difficult to run again when the car is stopped, the clutch is very sensitive and the engine turns off a lot of times I'm proving it. I need to push throttle a lot for high revolutions and then slowly and carefully I can run again.

Hope it helps. Regards.

Stevedue
10-05-2015, 07:20
With the manual clutch, like I have, at the start of a race you need to push and maintain it, then shift first gear and when the lights turn green leave the clutch and push the throttle. If you loose the car or crash with walls, you need to push the clutch (and maintain it pushed) before the engine turns off. If you put the shifter in neutral you can leave the clutch. If the engine turns off, you need to ignite it again (mapping a button for ignition needed). Like in real life. The point about this, for me is difficult to run again when the car is stopped, the clutch is very sensitive and the engine turns off a lot of times I'm proving it. I need to push throttle a lot for high revolutions and then slowly and carefully I can run again.

Hope it helps. Regards.

Thanks for the reply, but I've the standard T300 pedals, without the clutch.

But luckily I've resolved all my T300RS problems doing a firmware upgrade.
I've the old firmware version 23. Upgrade to the new 24 version, and now the wheel works perfectly :)

Hope this help other people :)

mccauleycr7
13-05-2015, 13:34
Hi my wheel was working perfectly up until last nite and then it just stop calibrating when I turned on my ps4, I only have it a week and it's doing this, was it hard to update the firmware?