PDA

View Full Version : pc stuttering issues



gibo122
09-05-2015, 12:27
Hi all

I have it running on my pc capd at 60fps. As i have seriously bad stuttering, to the point were the ai cars stutter back and forth its really bad, it seems to happen mainly wen im turning into corners.

I have a gtx970, 4690cpu, 16gb ram i can run it fine on high settings but even on low this stuuter is really bad. Im also using a 360 controller, tried turning ffb off doesnt help. Im stumped! All my drivers are updated etc

Any help please?

BazzaLB
09-05-2015, 12:30
Try turning off detailed grass if you haven't already and report back.

gibo122
09-05-2015, 12:39
Yea tried turning it off still same the stutters are as if lagging when playing online. But im on solo

Morgan Henstridge
09-05-2015, 12:41
Hi gibo122, do you get the same stuttering in Free Practice, or only with other AI cars??

gibo122
09-05-2015, 12:47
yea even wen im on my own this stutter is there. Its unplayable if i dont turn vsync on from my nividia controll panel

BazzaLB
09-05-2015, 12:49
Well, fwiw, I have to use vsync or else I get stutter even at 100+ fps. However, I tend to always use vsync in my games as I hate SLI induced micro stutter. (I realise you are not using SLI but as I say, I see micro-stutter at 100+ fps without vsync, but am butter smooth 60fps with vsync).

I also cannot enable detailed grass without micro stutter.

Morgan Henstridge
09-05-2015, 12:49
yea even wen i'm on my own this stutter is there. Its unplayable if i dont turn vsync on from my nividia controll panel

Might be worth a shot to disconnect the Xbox controller and start the game with just the Keyboard, just to 100% eliminate any possible issue with the Xbox controller and the issues some people are seeing with FFB.

GAT_Montana
09-05-2015, 12:50
I figured out 3 issues on my PC what causing stuttering:

1.) UHD Resolution (45-60fps shown but massive microstutters)
2.) Grass on minimum leads to more stuttering than on high, high seems to work much better
3.) Shadows on Ultra or High causing massive stuttering on normal and high end PC's, for that may be you need SLI system.

I am wondering if the fps (I use the Steam Counter) are shown correctly? Fact is, 45 fps are smoother than 60 using above settings.

Morgan Henstridge
09-05-2015, 12:55
Good tip about the detailed grass, GAT Montana, I will have to give that a try :)

gibo122
09-05-2015, 13:27
I think ive fixed it. so if u go into the options and go to visuals, then hardware. Theres a slider called jitter tweak. Default is 4.0 So i started playing with it. moving it higher i saw less stutter, im now at 20.0 and there nearly gone. I read it may cause input lag, but i havnt noticed any Lag at all from my contoller

Thanks for help guys

Morgan Henstridge
09-05-2015, 13:34
Good to know gibo122.

Can you please edit the title of the thread and add [Resolved] to the start so oher users know to look here for the same issue.

See you on the track :)

jgaganas
10-05-2015, 18:58
hi folks,

i can't confirm the "jitter tweak" (didn't made any difference with my GT970), but i finally got rid off ALL my micro-stuttering issues (while having constant 60+ fps):

launch game with: -skipcrowds -fpscap 63 (seems to "calm down" these hicups)

nvidia driver: vsync on (not adaptive), tripple buffer on

in game: vsync off, prerendered frames 2

game runs finally smooth as silk on 3440x1440 res with stunning visual fidelity.... please give it a try.


ps: as this is my first post in 4 years, the game turned out pretty awesome but with quite some (initial) bugs and config/settings issues (which should be sorted out quickly)... but anyway, it's the best casual sim/racer i've ever played and great fun!

could race these ginettas at oulton park all day long ;)


edit: changed to prerendered frames 1 (which also gives me slightly better controller response)

jasonr71
17-05-2015, 10:46
I get the stuttering only when I watch a replay, and it's to do with the broadcast camera not the cars. As the broadcast camera follows the cars in a replay and it doesn't matter what circuit, it stutters terribly! When the broadcast camera is in a stationary position it doesn't cause any stuttering at all. Will this bug be addressed later on down the track?

jasonr71
20-05-2015, 09:24
In relation to my above post, if other players are experiencing this issue, the easiest fix would be to have static broadcast camera's positioned around the circuits whilst watching replays, or at least add a static broadcast camera. In fact I was watching a replay of one of my races on a circuit (Sorry I can't remember which circuit) and the broadcast cameras were stationary throughout the replay, and the presentation of the replay was more pleasing on the eye to watch without all that stuttering.

Stationary cameras definitely resolve the stuttering issue in replay mode.

It's not a performance issue because I am getting 60fps, and I have tried adjusting every graphics settings and still have the problem with the moving cameras.

jasonr71
20-05-2015, 09:27
I will try this and report back!
Thanks for the heads up!


I think ive fixed it. so if u go into the options and go to visuals, then hardware. Theres a slider called jitter tweak. Default is 4.0 So i started playing with it. moving it higher i saw less stutter, im now at 20.0 and there nearly gone. I read it may cause input lag, but i havnt noticed any Lag at all from my contoller

Thanks for help guys

Osiris
20-05-2015, 12:58
Same here with GTX770 with enough fps available. When i set a fps limiter, e.g. with Afterburner to 59fps with vsync on, the Jitter reduces a bit. But iŽll try the jitter tweak. Thanks

Nignire
20-05-2015, 13:03
Game is running smoothly in races but jerky / Stuttering in Replays its a pity because the replays are very nicely done with good camera angles.

menos
27-05-2015, 07:00
Can someone point to some technical background about how the "Jitter Tweak" function in Graphics / Hardware in PCARS works?

I am really interested in how best to use this feature and under what circumstances better not to use it …

PS: I too have jerky/ jumpy replays in some instances but have gotten my setup tuned so the actual racing is very smooth. It is just the replays that bother me.

Sankyo
27-05-2015, 07:06
Replays are still an issue in some places I think, I don't think that much can be done except turning down graphics details perhaps.

Anyway, the jitter tweak IIRC is a sort of timing pause/interval that allows things in the render engine to catch up or synchronise if necessary. Can't remember whether there were any downsides to using a bigger value.

ex_
02-06-2015, 04:13
was reading this thread, and it helped, Thanks.

I noticed something, that stuttering truly is, as someone else said, mostly tied to that broadcast view. I've seen before that panning in racing games is the hardest thing for the GPU to render. Scenery and cars both moving, but not at the same rate. Many cars and detailed track? Very tough!

What this camera view does which may be the problem with it causing the stutter, is that it itself pans, creating three simultaneously different velocities for the card to render. The scenery moves as the pan occurs, the cars move as the camera pans, but independent so it is not locked to that pan, causing a varience and hence the 2nd motion, and finally, the camera itself is moving as it pans, as if being held by a human. If not simulating beingt held, it appears to simulate being rocked on a panning-rig and zooming as if done by a human controller.

Anyway, I strongly suspect that is why that view is causing stutter...

Edit: In fact, I just went and observed a replay. The stutter seems only to occur when the broadcast view camera moves. If in a position of track where it has a distant view of the cars and is able to hold still while those cars pan, there is never any stutter. It then again returns as soon as the camera man starts panning.

swannyUK88
12-06-2015, 10:32
Just to add to this, I spent a while the other week trying to get rid of micro stutter when driving which was driving me nuts. Every half a second the frames would skip, not loads but enough to tell it wasn't running smoothly.

I tried different graphics settings but the only thing that fixed it was turning vsnc on (fps cap didn't fix it). By contrast I run Assetto Corsa on high settings and get around 120fps with no stutter so I don't think it's down to my sli (unless its a game specific problem). I don't really like having vsync on but have to if I want the frame skipping gone.

xautos
12-06-2015, 11:09
ive also had micro stutters as well, one point the screen froze for about a second but luckily, i was not in anything major. i noticed it online is when someone joins or leaves, and when i am attempting to change the car setup in the garage.

1.3 patch did not have this issue for me. infact, had no graphics issue at all.

Spiderx
12-06-2015, 12:05
Well with this last patch Stuttering ONLINE is absolutely hideous... Graphic cards on 40% and yet it stutters like mad

doneta
12-06-2015, 15:13
I searched the forum for a possible solution to this problem. It seems stuttering in multiplayer is normal, according to a WMD member, and caused by players joining the host. See his post here: http://*******.com/ncgkwh6

Sayjimwoo
27-09-2015, 19:39
The replay stutter issue is not fixed and needs to be re-opened. Why this has been marked as FIXED in "Known issues" I do not know.

Roger Prynne
27-09-2015, 19:49
I have no stuttering in replays.

Is it any car/track, or is there a specific combo that does this.

Sayjimwoo
27-09-2015, 20:42
I have not played since V 2.0 and the stutter at the same certain spots on varied tracks were there then. Since returning to the new vesion on a completely new system W10, Skylake, Titan X at only 1080p (vsync).
On my first race on Mazda Raceway I race a lap and then replay using the broadcast cam. There are several same spot stutters per lap. The first stutter is whilst coming out of the first bend. It is almost like it is missing a couple of frames.
The fps counter still shows a solid vsynced 60fps. I am maxed out on settings and jitter makes no difference no matter what I change it to. The only thing i have not altered it the pre-rendered frames, that is at 1 still.
The race itself is butter smooth I just don't know what is causing the replay stutter. Anymore suggestions?

Kenny
27-09-2015, 20:54
Has anybody had shadowing ghosting in replay mode. You get a graphics glitch around the front and rear of car
On certain views.
Kenny

Djinn
28-09-2015, 11:16
I have this stuttering in replays, too. Have to try upping the Jitter Tweak setting.

Jego
29-10-2015, 19:33
I just experienced exactly this problem. Massiv stuttering in a online race although my frames where at 60 constantly.

It was fine during quali but as the race started it got really bad from times to times, causing me to crash. I was not the host, and no one was leaving.

I have recently noticed short stutters at certain tracks (like Cadwell GP at the top of the hill) but this time at Spa it was very bad.

Bigjet
28-12-2015, 12:14
Ok, searching for this issue and I found this thread.

I have the dreaded micro stutter and have tried everything - all combinations of settings with jitter tweak, detailed grass, AA settings, and the only thing that makes any difference is by turning off VSYNC in the software, and enabling it on the card settings.

It is only at certain points at certain circuits, but sadly is bad enough to make the sim unplayable. Specific points for example are;

Exiting and entering Druids hairpin at Brands hatch, after the Shell hairpin and into the chicane at Oulton Park full circuit, many points around the back end of the Watkins Glen full circuit, over the hill after the first chicane at Zandvoort, a few specific points at Bathurst.

It doesn't seem to do it at all at Nordschleife nor at Cadwell park, both of which are as graphically detailed as any other circuit.

This is on an AMD Eyefinity set up running in 5760x1200. The annoying thing is that with software VSync enabled, it runs really like silk until these specific points, then it suddenly becomes unplayable. If you are close to another car you will probably hit them, if you are on your own then you will usually lose control. Then once you are past these points, it runs silky smooth again.

If you turn off software Vsync and enable it on the hardware settings instead, these micro stutters completely disappear, but it is not as smooth - it's as if you can detect the slight jerkiness as the car turns through a corner, even if it is running at a high FPS and without the sudden short but severe stutters.

If this only occurs at certain circuits and at certain points, surely it is a coding issue with these tracks? What is different at these points on these circuits that is not evident at other stutter free circuits or tracks with no stutter at all, like Nordschleiffe?

I also have Assetto Corsa and R3E installed and they do not suffer from these problems at all, and everything is maxxed out at 5720x1200. So it is obviously a coding issue, not a lack of hardware horsepower... it's a shame because I think it is the best sim, but until this issue is fixed once and for all I no longer play Project Cars...

N0body Of The Goat
28-12-2015, 13:31
Ok, searching for this issue and I found this thread.

I have the dreaded micro stutter and have tried everything - all combinations of settings with jitter tweak, detailed grass, AA settings, and the only thing that makes any difference is by turning off VSYNC in the software, and enabling it on the card settings.

It is only at certain points at certain circuits, but sadly is bad enough to make the sim unplayable. Specific points for example are;

Exiting and entering Druids hairpin at Brands hatch, after the Shell hairpin and into the chicane at Oulton Park full circuit, many points around the back end of the Watkins Glen full circuit, over the hill after the first chicane at Zandvoort, a few specific points at Bathurst.

It doesn't seem to do it at all at Nordschleife nor at Cadwell park, both of which are as graphically detailed as any other circuit.

This is on an AMD Eyefinity set up running in 5760x1200. The annoying thing is that with software VSync enabled, it runs really like silk until these specific points, then it suddenly becomes unplayable. If you are close to another car you will probably hit them, if you are on your own then you will usually lose control. Then once you are past these points, it runs silky smooth again.

If you turn off software Vsync and enable it on the hardware settings instead, these micro stutters completely disappear, but it is not as smooth - it's as if you can detect the slight jerkiness as the car turns through a corner, even if it is running at a high FPS and without the sudden short but severe stutters.

If this only occurs at certain circuits and at certain points, surely it is a coding issue with these tracks? What is different at these points on these circuits that is not evident at other stutter free circuits or tracks with no stutter at all, like Nordschleiffe?

I also have Assetto Corsa and R3E installed and they do not suffer from these problems at all, and everything is maxxed out at 5720x1200. So it is obviously a coding issue, not a lack of hardware horsepower... it's a shame because I think it is the best sim, but until this issue is fixed once and for all I no longer play Project Cars...

PC spec in forum signature?
What in-game settings?

I was having a play with various AA settings this morning and while MSAA no longer has issues when bloom is enabled, fps performance is only a tiny bit better (within ~5fps) than DS4X at 2560x1440 with otherwise identical graphics settings... I get ~33% fps boost by swapping MSAA to DS2X around Spa with the Formula A in Time Trial mode!

The MSAA fix on AMD cards, just before Xmas, seems to have crippled the lowest standard AA mode pCARS has.

I've not looked at "DS2M" AA yet.

MISTER WU
29-12-2015, 00:08
This is why i only use one card because i was getting all the issues described above, it was only in some corners like he stated so i just use one card and its great, i lose around 20-30 fps but im still getting avg around 70-90 fps anyway with everything at ultra.

Bigjet
29-12-2015, 21:02
Evening. I have added my hardware specs in the signature now. The in-game settings make no difference other than V-Sync. That is the only variable that has any effect, and believe my I have tried them all. V-sync enabled in game, severe stuttering at certain corners at certain tracks only. V-sync enabled in the hardware but disabled in the game, no stuttering, but it is nowhere near as smooth...

This is not a dual card setup - it is single card. I had to buy an AMD card as my previous Ge-Force SLI setup caused all my G-Motor based race sims to crash to desktop, e.g. R-Factor 2, R3E, Race 07

As I say, if it only occurs at certain tracks and certain corners, surely it is a bug?

Mahjik
29-12-2015, 21:14
Do you have Motion Blur enabled?

Bigjet
29-12-2015, 21:49
On or off, no difference...

DTracing420
11-01-2016, 21:14
Hi I hope you can help me I have a AMD 5800 redeom HD 16g ram 120harddrive GTX960 graphics card and I downloaded project cars on steam for the PC y does it slow down and speed up when I play

Jonathan Newsam
12-01-2016, 07:44
if you have an AMD cpu turn off the turbo feature in the bios this seems to stop the slow down and speed up of the game.

VFX Pro
31-05-2016, 05:21
I found the fix, make sure you had a -fps 52 to cap the frame rate when you launched the game. I have 10K x 1400 resolution on 3 monitors and once I forced the fPS to be capped, now iti's nice and smooth.

missy455
03-06-2016, 06:14
How do you do that? I have a triple monitor setup as well running 3 way SLI (PCars utilizes high end hardware wonderfully btw..gd job SMS)

Anyways, I still get bad stuttering in replays. Is there anyone in SMS working on this? Or is this something that we will have to live with, as I have tried most of the tips in this thread (other than VFX Pro's suggestion (but I don't understand what he means, or how to implement this) and I still have bad stuttering :(

missy455
03-06-2016, 06:16
I found the fix, make sure you had a -fps 52 to cap the frame rate when you launched the game. I have 10K x 1400 resolution on 3 monitors and once I forced the fPS to be capped, now iti's nice and smooth.

How do you do this -fps 52 to cap?
Thx.

chris99
03-06-2016, 06:45
Before starting Pcars, in Steam library, right click on Project Cars - select "Properties". Click on "Set Launch Options" and type -fps 52 in the box - OK

234007

Edit Oops - As pointed out it below it should read -fpscap 52 :yes: Sorry for the confusion
I used to use -fpscap 63, as recommended elsewhere, but I've found Vsync ON in the settings gives a smoother race display - not sure about replay though.

missy455
03-06-2016, 07:23
Before starting Pcars, in Steam library, right click on Project Cars - select "Properties". Click on "Set Launch Options" and type -fps 52 in the box - OK

234007

Oh cool, Thanks dude.

Sankyo
03-06-2016, 08:05
Before starting Pcars, in Steam library, right click on Project Cars - select "Properties". Click on "Set Launch Options" and type -fps 52 in the box - OK

234007
Shouldn't that be -fpscap 52?

missy455
03-06-2016, 12:48
Shouldn't that be -fpscap 52?

Not sure, as I just tried the fix as shown and it works! Awesome, because that stutter problem by itself put a HUGE damper on the game for me personally. Let's be honest, if your not racing, your watching yourself racing lol. ( A form of mental masturbation)

Anyways, I would consider this solved if there's nothing that could be done on the developer side of things. Heck, if the London crew could fine tune the ffb and tyre model for better realism, I would say that Pcars could re-take the crown imo.

A big shout out to chris99 for the screenshot how-to. Thanks brosif.

Mad Al
03-06-2016, 13:09
Not sure, as I just tried the fix as shown and it works! Awesome, because that stutter problem by itself put a HUGE damper on the game for me personally. Let's be honest, if your not racing, your watching yourself racing lol. ( A form of mental masturbation)

Anyways, I would consider this solved if there's nothing that could be done on the developer side of things. Heck, if the London crew could fine tune the ffb and tyre model for better realism, I would say that Pcars could re-take the crown imo.

A big shout out to chris99 for the screenshot how-to. Thanks brosif.

http://forum.projectcarsgame.com/showthread.php?23045-Command-Line-Launch-Options&p=892188&viewfull=1#post892188

-fpscap nn

where nn is the required frame rate cap....

-fps does NOT cap frame rates

missy455
03-06-2016, 13:17
http://forum.projectcarsgame.com/showthread.php?23045-Command-Line-Launch-Options&p=892188&viewfull=1#post892188

-fpscap nn

where nn is the required frame rate cap....

-fps does NOT cap frame rates

Weird. So the sudden fix in the replay stutter is all in my head or coincidence? I'll try this method as well though, as I want to make sure I'm doing it properly. Just to make sure, the proper way to fill it in is -fpscap nn or -fpscap? Thanks guys.

Mahjik
03-06-2016, 13:19
Weird. So the sudden fix in the replay stutter is all in my head or coincidence? I'll try this method as well though, as I want to make sure I'm doing it properly. Just to make sure, the proper way to fill it in is -fpscap nn or -fpscap? Thanks guys.

-fpscap 52

Roger Prynne
03-06-2016, 13:19
If you want to cap it at 60 FPS for example, then it would be -fpscap 60

Nija'd by the man above.

missy455
03-06-2016, 13:33
If you want to cap it at 60 FPS for example, then it would be -fpscap 60

Nija'd by the man above.

I will definitely take a look.

missy455
03-06-2016, 21:30
Before starting Pcars, in Steam library, right click on Project Cars - select "Properties". Click on "Set Launch Options" and type -fps 52 in the box - OK

234007

This is the method that will fix the terrible replay stutter. I'm not a nerd so I don't know why it works, it just works. Thanks again to "VFX Pro" and "chris99"

PS: I know that when you insert -fpscap 52 into launch options it works as it should in regards to capping the fps in game however, it's basically unplayable by doing that of course because of the stuttering from low frame rates before you even get to a replay lol..

Mad Al
03-06-2016, 21:33
This is the method that will fix the terrible replay stutter. I'm not a nerd so I don't know why it works, it just works. Thanks again to "VFX Pro" and "chris99"

PS: I know that when you insert -fpscap 52 into launch options it works as it should in regards to capping the fps in game however, it's basically unplayable by doing that of course because of the stuttering from low frame rates before you even get to a replay lol..

Well in that case someone better asks the devs just what -fps may be doing...

Sankyo
04-06-2016, 07:32
Well in that case someone better asks the devs just what -fps may be doing...

Maybe the devs included more than one startup option for frame rate capping :)

Mad Al
04-06-2016, 09:04
Maybe the devs included more than one startup option for frame rate capping :)

except -fps doesn't cap framerate (yes I have tried it;))

Mahjik
04-06-2016, 13:30
Should be easy to test:

Start up pCARS without any command line arguments.
Go straight to playing one specific reply.
Check for stuttering when/where.
Repeat the above (exiting out of pCARS and going back in) at least two more times to make sure you see stuttering in the same time/place in the replay.

Add the -fps command to the command argument
Start up pCARS with the -fps command line argument
Go directly to the same replay
Check for stuttering in the exact same locations as noted before.
Repeat the above (exiting out of pCARS and going back in) at least two more times to make sure you see stuttering in the same time/place in the replay.


I'd do it if I was home (out of town) but this would be the way to check for variance with replays with the -fps (not -fpscap) command.

Mad Al
04-06-2016, 14:39
Should be easy to test:

Start up pCARS without any command line arguments.
Go straight to playing one specific reply.
Check for stuttering when/where.
Repeat the above (exiting out of pCARS and going back in) at least two more times to make sure you see stuttering in the same time/place in the replay.

Add the -fps command to the command argument
Start up pCARS with the -fps command line argument
Go directly to the same replay
Check for stuttering in the exact same locations as noted before.
Repeat the above (exiting out of pCARS and going back in) at least two more times to make sure you see stuttering in the same time/place in the replay.


I'd do it if I was home (out of town) but this would be the way to check for variance with replays with the -fps (not -fpscap) command.

The point is to find out if this is a specific option, what is it supposed to do.. if may cure one problem and introduce another

there are several undocumented command options, most do something obvious
-forcenovsync and -forcevsync (does what it says)
-dummyrenderer (have fun with that one and know how to kill a running task, as it will run with no graphical output)
-no3DScene (disables the 3D garage scene)

all those are easy enough to find by just looking for the strings in the exe...

DanyGee
09-11-2016, 11:09
After trying all "solutions" (none worked, tried Watkins Glenn) posted in this thread I can only come to one simple conclusion:
This game is badly programmed and optimized.
This kind of problem should be fixed by the devs, nut by us creating multi-paged threads in the forum!
But, it seems that devs have more fun preparing PC2 for us (pls, ppl, don't you dare preorder it!)
I will not play this shitty game until stuttering gets fixed.
Assetto Corsa with V-sync on runs smooth as butter at constant 60fps and does not stutter in any conditions.
As mentioned...conclusion is simple.


i7-6700K
Asus GTX 1080 ROG OC

Bealdor
09-11-2016, 11:23
...As mentioned...conclusion is simple...

Since many players don't have any stuttering issues at all (including myself) the conclusion is anything but simple.

DanyGee
09-11-2016, 11:29
Since many players don't have any stuttering issues at all (including myself) the conclusion is anything but simple.

Really? Lucky you!

Can you please help me by sending a screenshot (text will also do) of your graphic settings in the game?
If you have any other magic tricks enabled (nvidia panel, launch options etc.) please let me know.
I will set the same settigns and try to isolate the issue.

Bealdor
09-11-2016, 11:40
Really? Lucky you!

Can you please help me by sending a screenshot (text will also do) of your graphic settings in the game?
If you have any other magic tricks enabled (nvidia panel, launch options etc.) please let me know.
I will set the same settigns and try to isolate the issue.

Resolution: 1620p (DSR 2.25)
VSYNC: Ingame OFF, NV CC: Adaptive

Anti aliasing OFF
FXAA MIN
SMAA OFF

everything on max, except:

Environment Map High
Shadows High
Reflections High
Motion Blur OFF/Medium (I change this from time to time)
Render Frames Ahead 1
Detailed Grass OFF
Particles (both settings) Medium

McClusky
09-11-2016, 12:02
If it helps mine are below. Also, if I don't have -fpscap 63 or -skipcrowds as launch options I get stutters (had to do this to maintain 60FPS when I got the Titan Pascal)

Texture Res Ultra = AF 16
V Sync = Yes (in Nvida CP)
AA = DSX4 for evening and night - DSX6 for day time
Reflections Med
EnvMap High
Car = Ultra
Track = Med
Shadow = High
Motion Blur = Off
Render Frames = Ahead 1
Grass = Off
Particle = Level High
Particle Density = Ultra
Stretched Headlights Reflection = Yes

Launch Options -skipcrowds -fpscap 63

DanyGee
09-11-2016, 12:08
THX for a quick reply!

I must be more precise on this.
The gameplay runs smooth. The jitter occurs only on replays.
Is this some kind of a known issue?
If yes, will it be fixed?

GrimeyDog
09-11-2016, 12:13
FWIW... use SLI and V-sync... i run Settings at High and Ultra Even the Grass and Shadws are on High... I get a Constant 60FPS with No Stuttering issues with 20 car Grid... I havent tested over 20 cars yet.

Tyr turning Down Reflections and Environment Map... Those seem to be GPU Hogs.

Bealdor
09-11-2016, 12:21
THX for a quick reply!

I must be more precise on this.
The gameplay runs smooth. The jitter occurs only on replays.
Is this some kind of a known issue?
If yes, will it be fixed?

Ah, that makes more sense now. Yes that's a known issue.
It's high on the list for PCARS 2 (http://forum.projectcarsgame.com/showthread.php?43205-Another-thread-opened-Ian-is-listening&p=1197599&viewfull=1#post1197599) but will very likely not patched for this game.

Roger Prynne
09-11-2016, 13:19
I get the odd stutter in replays, but nothing game breaking.

Fanapryde
09-11-2016, 20:32
I also have Assetto Corsa and R3E installed and they do not suffer from these problems at all, and everything is maxxed out at 5720x1200. So it is obviously a coding issue, not a lack of hardware horsepower... it's a shame because I think it is the best sim, but until this issue is fixed once and for all I no longer play Project Cars...
Well, in my case pCars and AC are fine, but since a couple of weeks I have the stuttering issue in R3E. And I am not alone.
Running Nvidia GTX980TI - triple 27" 144hz - 1ms monitors.
My FPS count in R3E is about 150, between 60 and 80 in both other sims.
Going to try some of the tips here, because I am out of ideas and the Sector 3 guys can't find a solution either. The stuttering (while racing) drives me nuts.

GrimeyDog
09-11-2016, 23:11
Well, in my case pCars and AC are fine, but since a couple of weeks I have the stuttering issue in R3E. And I am not alone.
Running Nvidia GTX980TI - triple 27" 144hz - 1ms monitors.
My FPS count in R3E is about 150, between 60 and 80 in both other sims.
Going to try some of the tips here, because I am out of ideas and the Sector 3 guys can't find a solution either. The stuttering (while racing) drives me nuts.

I had the same problem with R3E when i got the Windows Anniversary update...did you update to the Windows Anniversary update??? I uninstalled it because the update was causing the micro stuttering.

Also if you updated to Windows anniversary are you using Nividia GeForce Experience??? try turning it Off and see if the stuttering goes away...I Read windows Anniversary has a game Recorder built in it too Find it disable it...check to see if the stutter goes away... both of them running at the same time is a No Go...The Article aslo said to leave the Windows game capture disabled because it is a CPU hog... They said its better to use Geforce Experience instead for game capture because its less demanding and runs smoother.

hope this helps...i have not updated to windows anniversary again yet.

Fanapryde
10-11-2016, 07:42
I had the same problem with R3E when i got the Windows Anniversary update...did you update to the Windows Anniversary update??? I uninstalled it because the update was causing the micro stuttering.

Also if you updated to Windows anniversary are you using Nividia GeForce Experience??? try turning it Off and see if the stuttering goes away...I Read windows Anniversary has a game Recorder built in it too Find it disable it...check to see if the stutter goes away... both of them running at the same time is a No Go...The Article aslo said to leave the Windows game capture disabled because it is a CPU hog... They said its better to use Geforce Experience instead for game capture because its less demanding and runs smoother.

hope this helps...i have not updated to windows anniversary again yet.
Thanks for thinking along :o
I have Win10 version 1607, build #14393.447 running since a few weeks.
When it updated, I wasted about two days getting all working again:
- only one out of three screens worked
- DSD button box was not recognized
- JoyToKey did not work,
- AC would not start
- Creative sound Blaster was completely messed up (only my two back speakers worked, whatever I tried)
- Fanaleds did not work
- Fanatec property page was gone
- .... I can go on for a while...

After finally succeeding in getting it all working again, I am a bit reluctant about uninstalling the Win version...:cold:
For the moment I uninstalled Nvidia G-force experience (I had the broadcast thingy disabled last week), I also disabled the Windows game recorder, but I still have stuttering in R3E.
There is nothing running in the background (as far as I can see on task manager)...
As it seems some developers in R3E had the same issue, but "it went away after a while"... ?
I now hope it will go away too...

Fanapryde
10-11-2016, 10:18
@GrimeyDog
Problem solved:
In NVIDIA control panel, I set vsync to FAST and enabled vsync in R3E: no more stuttering !

Gregfox
16-11-2016, 16:43
Try reinstalling graphics drivers... It got fixed for me.

Fanapryde
16-11-2016, 17:41
Try reinstalling graphics drivers... It got fixed for me.
Sounds logical, it was the first thing I tried (several times even) but no solution in my case.

VFX Pro
20-11-2016, 22:25
I run 3 - 3400x1400 Predator GSYNC monitors with dual Nvidia 108 SLI. I had micro stuttering until I changed the in-game settings to frame ahead to 3, and forced the NVIDIA settings to triple buffer and GSYNC on. I also capped my game FPS to 58 by adding -fpscap 58 to my SimCommander 4 launch mode. I noticed the stuttering was only happening each time the game FPS would go above the limit of 60fps for surround running at 10k resolution.

Sayjimwoo
11-06-2017, 19:50
Well after being away from this game for 18 months or so and now trying it again with a complete brand new system (GTX 1080ti, i7 7700k, 32gb ram, SSD). The game runs butter smooth vsync'd at 120fps......but yet again, the replay stutter rears its ugly head occasionally on certain corners when the TV camera is panning round.
This obviously clearly couldn't be fixed, so why are we to believe it will be resolved in PC2?

Mahjik
11-06-2017, 20:49
This obviously clearly couldn't be fixed, so why are we to believe it will be resolved in PC2?

Simple, don't buy PC2. We'll be having fun without you. ;)

Sankyo
13-06-2017, 12:57
Well after being away from this game for 18 months or so and now trying it again with a complete brand new system (GTX 1080ti, i7 7700k, 32gb ram, SSD). The game runs butter smooth vsync'd at 120fps......but yet again, the replay stutter rears its ugly head occasionally on certain corners when the TV camera is panning round.
This obviously clearly couldn't be fixed, so why are we to believe it will be resolved in PC2?
Just wait for reviews and sim racing friends to confirm it has been resolved, and then buy the game. But besides that, would you really not enjoy the whole game just for an occasional graphics stutter in a replay?