PDA

View Full Version : Disabling Crepuscular rays has no effect on XBO



Fanatest
15-05-2015, 13:48
Hi,

Just a quick Sample test I was doing today re: differences between PS4 and XBO.

During testing I noticed that the option for "Crepuscular Rays - ON/OFF" on PS4 will indeed enable/disable the sun rays from coming through the trees.

However, this option has absolutely no effect on the XBO version? Even when disabled the Rays still appear.

I tested under the following conditions.
Both versions (XBO/PS4) side by side:
7:00am
Brandshatch
Light Cloud (and Clear)
All options were equal in both consoles running side by side.

When I disabled the effect on PS4 the Rays disappeared as expected and returned when I re enabled the effect.

On XBO when I disabled the effect, the Rays were still present and when I re enabled it, nothing had changed as they were still enabled.

Plato99
15-05-2015, 15:53
The rays are so bad that it becomes impossible to see the tip in and exit points on the corners when in cockpit view.
Had to change to bonnet cam just to get around the track.

z3r0cool77
15-05-2015, 16:39
Interesting, will see if I can confirm it later today. I haven't messed with crep rays, just turned off the in-cockpit lens flares as my eyes don't have camera lenses.

Elmo
15-05-2015, 20:41
Interesting, will see if I can confirm it later today. I haven't messed with crep rays, just turned off the in-cockpit lens flares as my eyes don't have camera lenses.

Yeah, please give feedback if you can reproduce the issue.

Thanks.

z3r0cool77
16-05-2015, 05:32
Can NOT confirm. Same track, brandshatch, I turned them off and they went off. Some bloom effect from the sun is still there ofc but the god rays are gone.

Fanatest
16-05-2015, 07:41
Interesting...
I'll post a picture of ON vs OFF fir XBO (I'll throw up ps4 too just for comparison)

Would you be so kind as to post an image of yours too?

Fanatest
16-05-2015, 09:14
Update:
Here is a video of this bug in action.
Excuse potato phone quality (filmed this way because "reasons") my iPad Mini Retina Sucks!

Here you can see 2 bugs in action:
1 - The horrendous Save times.
2 - Disabeling Crepuscular Rays has no effect on my LTD. Edition Digital Fully Patched version of the PCars on XBO.

https://vid.me/MPxe

z3r0cool77
16-05-2015, 15:33
Hmm, Not certain if those are full Crep rays or just some effect of bloom and lens flare. It does look a lot like it though. Usually when I see the Crep rays they are full rays passing through the tree's and coming across the track. I'll mess with it today and see if I can get something to compare. Have you tried turning the lens flare off? I run with lens flare on Chroma or off. The save time bug is annoying. Sometimes you can exit the menu's instantly and other times you sit there for a full minute waiting on it.

Fanatest
16-05-2015, 17:41
Hi,

That's definitely the full effect of the Ray ;)
There is absolutely 0 difference between both on/off (as you can see) displayed in the video.

Disabling other options works as expected, but crepuscular rays won't disable.

I already recorded a PS4 video under the exact same settings and NO god rays penetrate the trees when the option is disabled. So unless the PS4/PC versions are coded entirely differently, I suspect this is a bug.

By definition the god rays should NOT penetrate the tree when the option is disabled.
This is further enforce by the fact that the XBO platform is the only platform that behaves in this manner when crepuscular rays are disabled (it acts like they are still enabled)

I'll post my PS4 video (and PC) so you can see exactly how the effect should look when disabled ;)

z3r0cool77
16-05-2015, 18:24
Has to have some connection to time of day, game mode or something. Thus far I've had no trouble turning them off. Can you post the exact settings for that session so I can test under identical conditions?

Fanatest
16-05-2015, 18:35
Has to have some connection to time of day, game mode or something. Thus far I've had no trouble turning them off. Can you post the exact settings for that session so I can test under identical conditions?

Unfortunately it's not track or time specific.
Any track, any time of day (day time of course) disable God Rays, however they will not disable and will still be present.

Here's how it should look:
PS4:
God Rays disabled... then enabled...
https://vid.me/SQfY

As you can see.
When disabled there is absolutely NO Ray penetrating the tree.
You can see initially a slight lens flare, but this is NOT a crepuscular Ray.

In the second part of the video, you can see the same lens flare, followed by lots of golden God rays poking through the trees.

Can you post a video of the same track and conditions:
Same section of BrandsH GP with God RAYs ON
THEN
Go into the menu
Turn them OFF
And now display absolutely no god rays coming through the trees in the same section as it should be (like PS4/PC)

Basically recreate my XBOX ONE video here https://vid.me/MPxe
That would be very useful.

I'm using brandsH GP (God Rays on)
06:00
Light cloud
All other visual settings are in video ;)
Drive to trees and check God rays are visible...

Now...
Enter menu,
"Disable" God Rays
Drive Back to same section of the track...
See if God rays have gone.

I'm very interested in seeing quick video if possible.

Edit:
Phoned my brother who is now installing the game. His results will be posted as soon as it's installed ;)

z3r0cool77
16-05-2015, 18:57
A video would be a pain as I'll have to start with setting up a place to upload them. Should be able to take a quick pic on my camera though.

Fanatest
16-05-2015, 19:09
A video would be a pain as I'll have to start with setting up a place to upload them. Should be able to take a quick pic on my camera though.

Just use vid.me
No account required, no login require, no special app required, any device supported.

Just go to web page
https://vid.me

Point phone at screen, and it's asks if you want to record directly from the phone (and auto uploads for free without logon) or uploads a video you already have on your device.

Super fast, super simple, free, no login, no app, x platform ;)

Edit:
My brothers results should be up tonight. However for additional confirmation I'm going to Get one of the other testers at Fanatec to check for me on Monday too ;)

z3r0cool77
16-05-2015, 19:46
Well. In the process of trying to setup an example. My system has started getting increasingly sluggish. I found a replay that I saved which may be if the race when I initially tested turning them on and off. First off my replays only seem to show up when they want to. Sometimes I'll go to the highlights screen and there they'll be. Other times I sit at the screen with nothing on it then a minute or 2 later they'll show up. Now when I try to play them it loads up a black screen. You can hear the race about to start then it just crashes my xbox back to home screen. :( getting annoyed. Def some sort of memory or disk access issue going on w pcars and it needs sorted asap.

Fanatest
16-05-2015, 19:58
Well. In the process of trying to setup an example. My system has started getting increasingly sluggish. I found a replay that I saved which may be if the race when I initially tested turning them on and off. First off my replays only seem to show up when they want to. Sometimes I'll go to the highlights screen and there they'll be. Other times I sit at the screen with nothing on it then a minute or 2 later they'll show up. Now when I try to play them it loads up a black screen. You can hear the race about to start then it just crashes my xbox back to home screen. :( getting annoyed. Def some sort of memory or disk access issue going on w pcars and it needs sorted asap.

That's why I currently use the "point phone at screen" method with PCars at the moment (I have other bugs I'm currently investigating and dealing with)

If you load up a free practice, and point your phone at the screen (and set it to record) drive to turn 2 (a few seconds in) you can check the rays out there, then just pause, turn them off, and drive back to turn 2.

Should be about 2 mins tops and vid.me does all the work ;)

The video will then auto upload :)
No replay required,
No login required,
No special app,
No special hardware requirements,
No editing,
no worries about stuttering etc

It can be a life saver at times that little site ;)

z3r0cool77
16-05-2015, 19:58
Hate to double post but its a seperate update. I CAN confirm now that in solo and free practice crep rays are not turning off. When I tested it before and it worked it was in a career race so as soon as I hit another career race with appropriate conditions I will test again and take some images/video. ATM I'm really started to think theres some sort of underlying memory or disk access or write issue going on and it may be the root of more than one bug we're experiencing. Randomly long save times, tune settings not saving in the pits, pit strategies and tunes getting corrupted and spitting out crazy numbers, frame rate stuttering after prolonged sessions and audio distortions. Oh, and replay access.

Fanatest
16-05-2015, 20:18
So...
Second conformation above and 2 more incoming.

I'll check career mode tomorrow, but overall once enabled, I can not disable them system wide.
Thanks for testing and confirming.

z3r0cool77
16-05-2015, 21:32
Noticed from your video that the PS4 also doesn't seem to suffer from the menu screen hangups when backing out. Must be nice :)

Fanatest
17-05-2015, 08:39
Noticed from your video that the PS4 also doesn't seem to suffer from the menu screen hangups when backing out. Must be nice :)

Yea it's instant with the PS4, which is very nice. Over a full day of testing it can save me up to apx 40 mins by my own calculations :)

One interesting difference that I noticed about the PS4 version vs XBO during testing, was that artistic choices made by each build team. For example, the PS4 designers appear to have opted to use less (but more detailed) track side details vs the XBO.
Which is a beautiful design choice and makes for a much more aesthetically pleasing and immersive experience.

For example, this can even be seen in the videos above.
Look at the XBO trees (lots of last gen "+" style tress)
Now look at the PS4 version.
Just a handful of trees, but they predominantly feature fully 3D modeled trees.

It's a wise design choice, and I'd really like to see the XBO adopt this approach.
Less object, higher quality (which could potentially positively affect/improve frame rate too)

And on closing:
I can confirm that once enabled, the Rays can not be disabled during a session in any game mode on my system.
I can also confirm this happens on my family members console (tested today) and on z3r0cool77 console tested above.

Hopefully this will be investigated.

z3r0cool77
17-05-2015, 17:02
I know that it did work the first time I did now none of the visual settings seem to change. I haven't once noticed a change with vignette. Much like tuning setups not saving properly visual settings seem to be hit or miss. Mostly miss.

Fanatest
22-05-2015, 22:38
As an update to this:
Digital Foundry have confirmed that this is the case.

The game requires a full restart to "disable" crepuscular rays ;)

Elmo
27-05-2015, 19:01
As an update to this:
Digital Foundry have confirmed that this is the case.

The game requires a full restart to "disable" crepuscular rays ;)

Thanks. Will add it to the list

EMW Grogan
28-05-2015, 03:09
Update:
Here is a video of this bug in action.
Excuse potato phone quality (filmed this way because "reasons") my iPad Mini Retina Sucks!

Here you can see 2 bugs in action:
1 - The horrendous Save times.
2 - Disabeling Crepuscular Rays has no effect on my LTD. Edition Digital Fully Patched version of the PCars on XBO.

https://vid.me/MPxe

A workround for the long save time hang up is to dashboard the game with the XBOX button, it will then magically save your settings, then press B button to return to the game.

My team mate EMW Distant pointed this out day 1 (USA launch ) i didnt beleive him and said it was a coincidence, apologies and thanks to
him :)