PDA

View Full Version : [RESOLVED] Issues using Thrustmaster T80



joaoximenes92
25-05-2015, 16:49
Hey guys.
So, I bought the game and felt it's amazing, but I was missing a Racing Wheel. Since I am on the budget, I picked the T80, hoping to improve it later.
Then, I got home, connected the wheel, it was recognized and everything else, but I can't calibrate it. When I press the square button on the Controls Config menu, it tells me to turn the Wheel to the top, but nothing is recognized. It's like I'm doing nothing.
When I get into races, the wheel is always fully turned in one direction and rapidly coming back to the center, althought not naturally. It's more like a blinking bug.

Has it already happened to anyone?
Thanks.

thegt500
25-05-2015, 18:22
AFAIK, its only the T100, T300 and T500 that will calibrate as they are FFB wheels. The T80 doesn't have FFB, it uses a 'bungie cord' for resistance, not a motor so there's nothing to calibrate. Also, this is the reason for it springing back to centre and oscillating (rocking) when released from turning as there's nothing inside the wheel housing to dampen the 'springiness' as opposed to the FFB wheels.

kingfuzz
25-05-2015, 20:16
Might have wheel in gamepad mode, you need to put it in the wheel mode, red light on wheel should be solid, not blinking.....I can calibrate my wheel just fine, no problems here.

joaoximenes92
25-05-2015, 22:21
It's solid, the red light. What blinks is the on-screen wheel, once in a position, once in another. Maybe blinking isn't the right word, english is my second language. But the on-screen wheel pops once in a position, once in another.
Maybe I'll just have to return it :(

Johnny-Bee69
26-05-2015, 04:34
this is from thrustmaster facebook page.....

Tips: Project CARS-PS4 (CALIBRATE WHEEL)
On the PS4™ version of the game, you can calibrate your wheel in the game’s options in order to improve the gameplay (and match same ratio as the cockpit view).
1) Go to OPTIONS / CONTROLS tab.
2) Press the SQUARE button on your wheel to launch the calibration.
3) Follow the instructions. Steering Lock:
- T300: put your wheel in the 900° position.
- T500: put your wheel in the 1080° position.
- T100: put your wheel in the 240° position.
- T80: put your wheel in the 240° position.
4) Press the X button on your wheel to save your calibration.
Once the process is completed, the Steering Lock will be automatically adjusted to your cars.
YOU ARE READY TO PLAY!

joaoximenes92
26-05-2015, 18:54
this is from thrustmaster facebook page.....

Tips: Project CARS-PS4 (CALIBRATE WHEEL)
On the PS4™ version of the game, you can calibrate your wheel in the game’s options in order to improve the gameplay (and match same ratio as the cockpit view).
1) Go to OPTIONS / CONTROLS tab.
2) Press the SQUARE button on your wheel to launch the calibration.
3) Follow the instructions. Steering Lock:
- T300: put your wheel in the 900° position.
- T500: put your wheel in the 1080° position.
- T100: put your wheel in the 240° position.
- T80: put your wheel in the 240° position.
4) Press the X button on your wheel to save your calibration.
Once the process is completed, the Steering Lock will be automatically adjusted to your cars.
YOU ARE READY TO PLAY!

I've tried this but couldn't get it to work. It seems it's just the steering wheel that is malfunctioning. All the buttons and pedals work just fine. I'll try one more time before returning it. Sadly :(

Verruckt
27-05-2015, 03:34
Try connecting it to a PC and see if it will calibrate. Maybe you have a bad potentiometer or a wiring issue. I haven't tried it, but according to some videos on youtube (https://www.youtube.com/watch?v=yqqTLR2z5aE) the T100 drivers will work for the T80. This should help you troubleshoot the device...

Forbiddenracer
27-05-2015, 04:34
You can calibrate the T80 it sets up steering throw and pedals movement...not just for ffb.
Have you got it in ps4 mode?
Mine calibrates...only annoying thing is have to do it every time as game is not saving it.

Johnny-Bee69
29-05-2015, 14:49
Hey guys just found this from Thrustmaster
TWO IMPORTANT REMARKS ABOUT STEERING WHEELS ON PS4™
Two important remarks to avoid some Force Feedback or calibration issues in PlayStation®4 games

# REMARK No.1: On your PS4™ system, DISABLE the KEEP APPLICATION SUSPENDED functionality for the REST MODE.
For this, go to Settings / Power Saving Settings / Set Functions Available in Rest Mode.
Here we highly recommend to disable the Keep Application Suspended box, mostly if you use the REST MODE to turn off your PS4™.

# REMARK No.2: The steering wheel must ALWAYS be connected to the console before starting the game.
Furthermore, NEVER disconnect and reconnect the USB plug of the wheel when your game is launched and opened. This can be done only when the game is completely exited!
For this, press the PS button for 2 seconds and select Close Application then Ok.

J00N10R
12-03-2016, 23:15
So I've waited a while to see if it was a fluke but it seems that with the T80 if you turn Force Feedback to 0 the connection doesn't drop on the wheel. Mine used to just stop working mid race every 3 or 4 races (Mostly with open wheel cars). I wanted to be 100% sure before posting but it's been about 3 months since I did this and haven't had the issue.

choppermeir
27-06-2016, 18:37
Sorry to resurrect an older thread but I just cannot get my t80 to work. I have it plugged into the USB port before turning on my PS4 it works for around 30 seconds to navigate the menus then it doesn't work, I have tried it in controller mode and racing wheel mode. The light is on but it just does not work at all. Even the PS button does nothing at all. It was fine a slew months a go but all of a sudden it seems to have quit it's job. Any ideas?

choppermeir
27-06-2016, 19:17
Just tried it again, I did nothing different and got half a lap of Oulton park in before it went full throttle and didn't respond at all. I feel the hammer may be coming out soon

wyldanimal
28-06-2016, 02:42
Just tried it again, I did nothing different and got half a lap of Oulton park in before it went full throttle and didn't respond at all. I feel the hammer may be coming out soon

My only Idea's are:
Make sure it's Plugged Directly into the PS4's USB 2.0 port..
Not The 1st USB 3.0 and Not Via a USB HUB.

choppermeir
28-06-2016, 06:17
Yup I don't have a USB hub it is always directly plugged in to the PS4

choppermeir
28-06-2016, 06:19
Yup I don't have a USB hub it is always directly plugged in to the PS4, sorry what do you mean by 2.0 port and 3.0 port?

wyldanimal
28-06-2016, 19:11
Yup I don't have a USB hub it is always directly plugged in to the PS4, sorry what do you mean by 2.0 port and 3.0 port?

The PS4 has Two USB ports, the One with BLUE coloring is USB 3.0, and the Other Port is USB 2.0
I always use the USB 2.0 port for my Wheel..

I've had Many Disconnections using the 3.0 port or a HUB with my T300 wheel.
But when it's Direct in the 2.0 port, never a disconnection..

I actually Now Use One of these NON-Powered HUBS..

https://www.amazon.com/Expansion-Charger-Controller-Connector-Playstation-4/dp/B00ZWWMMRU

Notice the Single Blue USB 3.0 port.. DON'T use that one for the Wheel...
234710

on the Back Side where it Fits into the PS4, you can See One is Blue ( USB 3.0 ) and One is Not Blue, ( USB 2.0 )
use the USB 2.0 port for your Wheel.
234711

choppermeir
30-06-2016, 09:53
I must admit I have never noticed a blue colouring on my USB ports I will check tonight. Every day is a school day. Going to get in touch with Game and get it swapped if that doesn't help matters. The K you for replying

Crisis Nine
30-06-2016, 10:37
As far as I can tell, both ports on the PS4 are USB 3.0. I can;t find anything that says otherwise. And both my ports are the same colour. Black.

choppermeir
13-07-2016, 11:34
Turned out to be a faulty wheel in the end. Thanks for your replies though.

wyldanimal
13-07-2016, 20:29
As far as I can tell, both ports on the PS4 are USB 3.0. I can;t find anything that says otherwise. And both my ports are the same colour. Black.

Yes, on the PS4, both are black. On the Hub I use, One is Blue ( USB 3.0 ) and the Other 4 are White USB 2.0
My Wheel does not stay Connected on the USB 3.0 port...
And the TWO on the PS4 are not Enough for all the other USB items I need to use.

Danlaw
21-07-2016, 21:55
how to do I put the wheel in to wheel mode