PDA

View Full Version : Stutter jitter when close to other cars and in TV camera view



SpeedLimitUnknown
02-06-2015, 05:18
I'm getting occasional stuttering jitter of other vehicles when my vehicle gets close to them (that's the best way I can describe it). While it happens I'm getting rock solid 60 fps and framerate is very smooth. It's only some of the other vehicles that skip jitter back and forth quickly. It's also visible in TV camera view during races as the camera pans. I've tried the ' frames ahead' setting at 1 all the way to 4 and it doesn't seem to fix the issue. I'm also using vsync. Is this a fixable issue?

MAILERS
02-06-2015, 06:36
Yep getting the same problem with juddering AI cars in single player, also at a solid 60fps. Apart from that I must admit I am loving the game.

MAILERS
02-06-2015, 06:48
These are my settings for a solid 60fps come rain or shine & a full grid of cars. Everything on ultra apart from environmental map, reflections, particle density & shadows on high. Motion blur & grass off. AA = MSAA & SMAA on ultra. V-SYNC off in game but on in nvidia control panel & also triple buffering on in control panel. Plus I use -FPSCAP 63 in steam properties. Hope this helps the devs in some way to work out where the jittering is coming from.

Kitt
02-06-2015, 10:33
Is this jittering/stuttering in single player and game problem or hardwear problem?

MAILERS
02-06-2015, 10:42
I would say it's a problem with the game as I've tried all sorts of settings & it's still there. It seems to be more obvious on tracks with long straights, Road America, Spa etc. Its just a little strange as we are managing to run the game at a solid 60fps even in a storm with full grid of cars but the AI cars still jump, jitter, stutter whilst you overtake them on a straight.

BullWinkle
02-06-2015, 11:53
Incase you haven't checked here yet.,It could offer some advice for you.
http://forum.projectcarsgame.com/showthread.php?22757-pc-stuttering-issues&p=889793&viewfull=1#post889793

ex_
02-06-2015, 13:33
http://forum.projectcarsgame.com/showthread.php?22757-pc-stuttering-issues&p=895298#post895298

this is the one stickied in the "known issues" thread...

This guy's recommendation to use -skipcrowds fixed some stutter in Broadcast Camera view, but there are still inherent bugs iwth that particular broadcast view. I believe it is introducing more complex motions than the game can handle. Car moving, camera panning, and camera actually moving as if held or controlled by a human. It is ONLY when the camera moves as if moved by a human that the stuttering appears. Otherwise, while camera is still and cars are panning = no stutter.

But -Skipcrowds definitely helped. I am at almost Ultra settings with an AMD card. The solution... don't watch replays. You should be spending your time driving ;)

MAILERS
02-06-2015, 14:15
Thanks for the info but yes I have read that thread & is where I managed to get some good solid settings from. The problem here is that even though we are managing to run the game at a silky smooth frame rate, the AI cars are still stuttering but the track & scenery are rock solid 60fps. This is whilst driving & not watching replays.

ex_
02-06-2015, 17:13
weird, because your GPU isn't AMD like mine, which is certainly causing some problems...

What I've done the past day or so is take every graphics/visual setting and minimized it. I then turned them up one setting at a time to see what the change was. I did not use a benchmarking tool but only visually watched the FPS indicator and visually watched for hickups in the picture. I eventually found something that works very well and is a lot closer to Ultra settings than I thought I could do. When the new AMD drivers come out, I may be able to truly go to ultra, which is very exciting!

Also, cars are the hardest thing for the game to render, apparently form the tests above...

At race starts, when you can simultaneously see many of them while also viewing scenery and parts of your own car, it strains it very hard. However, if you can deal wit ha slight drop in FPS and it still looks relatively smooth, the ndon't worry too much that you are below 60. 90% of your race will be had wit honly a couple cars in visual sight, so decide on settings somewhere in the medium-ground of that spectrum...

SpeedLimitUnknown
02-06-2015, 17:22
It's definitely a problem with the game engine and I don't have issues with any other game. You can minimize the car skipping stutter issue vsync and fpscap but it doesn't fix the problem completely. It happens when following another car very closely in a race but as mentioned it's much worse on replay TV cam on certain tracks like the front straight at road America. Start a quick race and watch the cars from TV camera view in a replay and you'll see how some of the cars will skip stutter as the camera pans to follow.

MAILERS
02-06-2015, 17:48
Agreed, both our rigs are quite capable of running this game at a solid 60fps, just can't understand why the AI is jittering like you say. The replays don't really bother me but it does in game!

jgaganas
02-06-2015, 18:07
Can you post your ingame-settings, as I don't experience AI jittering with a 970 and a much slower I5 quad at 3440x1440?

Maybe Car/Reflection quality too high?

Replay-Jittering is of course another story...

MAILERS
02-06-2015, 19:31
Hi, I've just tried reflections on low in a race at Road America x35 AI, overcast at 1pm but the jittering is still present. My in game settings are in post #3 of this thread.

MAILERS
02-06-2015, 19:51
I've just run the race again with x56 AI & there is real obvious jittering but then run the same race with only 23 AI & no jittering present. Looks like we need to lower the number of AI & find a sweet spot to get them to run smooth.

SpeedLimitUnknown
03-06-2015, 00:00
Just saw that Ian is aware of the stuttering issue on replay cameras and replied to this post in another topic thread. The vehicle jitter/stutter when very close to other cars during a race (not while in TV cam view) is less common but I'll try to get it on short video clip.


Quote Originally Posted by ex_ View Post
this broadcast cam is creating massive stutter for many, so I really hope they fix it and introduce other external camera views that are not tied to the car, as in other views similar to the broadcast cam, but without the "human-like" movement seen in that cam, which seems IMO to be causing the stuttering...


IAN REPLIED " Agreed, this needs a 'fix'. It's on the list for future patches."

jgaganas
03-06-2015, 05:05
Hi, I've just tried reflections on low in a race at Road America x35 AI, overcast at 1pm but the jittering is still present. My in game settings are in post #3 of this thread.

Well, ULTRA is for (strong) SLI configurations, not for running with a single card (unless it's a TITAN).

I would go for MID/HIGH settings on 1080p with a 970/980. Particles probably on LOW (for smooth racing in the rain).

Of course it's a fidelity VS smoothness trade off.

Personally i take smoothness every day, especially as this game looks amazing even on MID settings.

MAILERS
03-06-2015, 11:19
Thanks for the reply. Here is a link to a video showing the AI stutter & this guy is running 980's in sli, notice the red car to right at the beginning of race. https://www.youtube.com/watch?v=Exz4TubkYCw

Sayjimwoo
27-06-2015, 15:52
I am running with a Titan X at a mere 1080p and I also see the car jitter whilst driving close to the AI on long straights etc. The game is running at a smooth 60fps and nothing else stutters/jitters apart from the AI cars. It is definitely a fault with the game. Pleas fix this asap. It is ruining the gaming play experience.

Umer Ahmad
27-06-2015, 18:09
It is being fixed ASAP. It's already on the Known Issues list (see the list from the link in my signature)

Sayjimwoo
27-06-2015, 21:04
It is being fixed ASAP. It's already on the Known Issues list (see the list from the link in my signature)

Thanks for the quick response :) I am glad it has a high priority, I will keep a look out for the fix and jump back into this great game as soon as it has been resolved.

Schumi-
27-09-2015, 13:35
Sorry to bump this up, but did it ever get fixed ? Suffering the same problem myself, when getting close to cars, a slight bit of jitter, not much. Everything else is silky smooth, more of an annoyance than a major problem to be honest.

Thanks

Roger Prynne
27-09-2015, 14:32
Try raising the 'Jitter Tweak' as that's what it's for.
Mines at 5 and stopped the problem.

Schumi-
27-09-2015, 14:55
Try raising the 'Jitter Tweak' as that's what it's for.
Mines at 5 and stopped the problem.

Thanks Roger, will give that a go, i always wondered what the Jitter Tweak was for.

Thanks

EDIT, problem solved, tried 5, still present but not as much, went to 6, perfect, not jitter at all now.

Thanks again Roger.

Sayjimwoo
27-09-2015, 19:38
I am getting stutter on broadcast cams at the same spots on certain tracks. (Running at 1080p with a Titan X and vsync) It is a problem with the game and nothing resolves it.
On the known issues thread it shows as "FIXED" and it clearly is not fixed and needs re-opening again.

KimKom
30-09-2015, 12:05
I've been seeing the AI flicker in replays since WMD days. Last night I tried increasing the number of AI from 25 to 29 AI and didn't see it again. Can't say for sure that it fixed it for me though.

KimKom
30-09-2015, 18:37
So this is weird. I'm definitely not seeing those AI flickers in replay anymore.

As well as increasing from 25 to 29 AI, I have also done the following over the past couple of days:

1. Decreased my OC.
2. Added crowds back in.

Would be good to know for sure if this issue has indeed been resolved.

Sampo
30-09-2015, 18:45
So why don't you try increasing your OC back to what it was?

KimKom
30-09-2015, 19:02
Some progress...

Dropped back to 25 AI and the flicker re-appears! :confused:

flymar
30-09-2015, 19:06
Try raising the 'Jitter Tweak' as that's what it's for.
Mines at 5 and stopped the problem.Isn't the jitter tweak for turn stuttering (all screen ones)?
I believe the thread is about AI stutter (hiccup)

KimKom
30-09-2015, 19:11
Isn't the jitter tweak for turn stuttering (all screen ones)?
I believe the thread is about AI stutter (hiccup)

I believe so too. I've never had any success eliminating AI flicker using the jitter tweak. It certainly helps with smoothing frames though.

flymar
30-09-2015, 19:13
I believe so too. I've never had any success eliminating AI flicker using the jitter tweak. It certainly helps with smoothing frames though.
For me the best job at smoothing frames was triple buffering in control panel. Now even in 30-40 areas it feels fluid.

KimKom
30-09-2015, 19:21
Yeah, that's something I usually have on too.

You should get yourself a g-sync display mate, I was blown away with the difference it made to pCARS.

flymar
30-09-2015, 19:56
Yeah, that's something I usually have on too.

You should get yourself a g-sync display mate, I was blown away with the difference it made to pCARS.
Nah. I'd miss 46'':)