PDA

View Full Version : Screen flicker at 1080p 59hz



EndGame
03-06-2015, 07:16
Hi all i have an Alienware 17 running an i7 4700MQ @ 2.40ghz and a gtx770m 16gb ram etc
when i run the game on my built in display everything is fine, but when i try to use my Samsung 23"SA950 monitor everything flickers a little (only @ 1080 and 59HZ other setting or in windowd mode its fine) and my monitor detects 33.7Khz 59Hz instead of my desktop refresh rate of 67.4kHZ and 60Hz

Any one have any ideas? Im stumped :(

tokyo_jay
24-06-2015, 21:02
Hi, Sorry, I do not have a solution but I am experiencing the same problem, Lenovo Gaming Laptop, i74710 HQ and Geforce GTX 860M.
Internal screen fine but if I switch to my Samsung monitor, I get flicker, if I change to a resolution below 1080, e.g. 1680 x 1050 game works great also works in windowed mode.
Just wondered if you had managed to fix the issue ?

Thanks

Jay.

Kf1Robi
23-10-2015, 18:12
I' ve got the same porblem. :( Any solution since then?

tokyo_jay
23-10-2015, 18:50
Hi,

Yes, I did find a solution, you have to create a custom resolution 1920 x 1080 @ 60p in the Intel HD control panel.

I have included a screenshot below.

Open the Intel HD control panel, select Display, then Custom Resolution.

Select the monitor you want to create the resolution for first under the 'Select Display' drop-down, once you have entered the values as in the screenshot, just click on ADD. It will then list the new custom resolution. If you get a warning that the resolution already exists, just click yes to overwrite. Next time you go into the control panel custom resolution menu, again select the monitor your playing PCars on and you will be able to see the custom resolution listed.

Now start the game and you should be able to select 1920 x 1080 @ 60p. Works for me and no more flicker.

Hope this helps.

Jay.

220739

Kf1Robi
24-10-2015, 09:31
I'll try. Thanks a lot! :)

BullWinkle
24-10-2015, 14:45
Your i7 has a integrated Intel HD Graphics 4600 gpu, you don't want to use that since you have gtx770m nvidia graphics. Are you connecting the cable from your monitor to the gtx gpu to the right connector on your laptop? I think you want the gtx770m connection/port. You should be able to disable the intel HD graphics in the bios I believe.

tokyo_jay
25-10-2015, 11:45
Hi

Just a little more info. On the Lenovo Y50 laptop ( my spec is Intel HD 4600 and Nvidia GTX 860M 4GB ) you cannot disable the Intel card in the BIOS, you can only disable the Nvidia. All you have to do is to make sure that you have Project Cars set to run with the Nvidia card, which you select from the Nvidia control panel under 'Manage 3D Settings'
You will probably know that if you run PCars at 1920 x 1080 @ 60 to your laptop display you get no flicker, it just happens when using your external display. I personally set Windows to output to my external monitor only and then run PCars, since creating the custom resolution everything works great.

Hope this helps.

Jay.

tokyo_jay
27-11-2015, 11:28
Hi

Screen shot of config settings.

222736

could_do_better
27-11-2015, 11:49
I have the same problem with Crossfire 5870's the 60Hz setting disappeared at some point in the last 3 months. Thanks for the idea to try creating a custom resolution I'll try it when i get home.