PDA

View Full Version : All input ignored in an online event



David Semperger
09-06-2015, 12:13
Today was my first foray into the online scene and managed to run into a quite serious issue right off the bat. I joined a GT3 event at Bathurst with a 15 min qualifying and 7 lap race session. The problem was that in quali when the AI was driving me out of the pits and at the end gave me control over my car I had no steering. The sim didn't react to any button on my wheel either. I tried to retire from the session and join again, but my keyboard didn't work either, so I had to close pCARS from the task manager.

When I restarted it I verified my control settings, but everything looked fine and the when I rejoined the online event an this time everything worked properly. Before the first try I did a quick solo Time Trial session and there I had no issues at all. I noticed in the known issues thread that Fanatec wheels tend to stop working sometimes, but I think my case was different, because I didn't have to recalibrate my wheel, its settings didn't change at all, and I also lost keyboard control.

David Semperger
09-06-2015, 12:16
Forgot to add my config to my signature. Hopefully it will show up below this post.

x107
11-06-2015, 13:39
Hey David, I also had this problem for quite a while too. What fixed it for me was not using the Steam overlay during any online session. Since doing this I haven't had the problem again. You could also disable the overlay, but then you can't see message/invite notifications while in game. To solve that problem I leave the overlay on so I can see notifications, but use the Steam app on a phone for all messages and alt tab out of the game to accept invites. By doing this I never have to use the overlay, which avoids the loss of input problem.

May not be perfect, but it's a good solution for now. Hope this helps.

David Semperger
11-06-2015, 13:44
Since I wrote my OP it didn't happen again, but if does I'll start doing online races without the overlay and see if the issue pops up again after that. Thanks for the tip!

doneta
11-06-2015, 16:36
This has happened to me many times. It's very frustrating.

AERODANCE
14-07-2015, 15:27
This happening often with me when playing PCars.
Seems it's game engine bug. When game is starting to load race session or loading back to menu after session end - you should never use steam overlay in this moments. Looks like game engine loosing focus when it loading anything, because steam overlay laying on top of it (i.e. overlay have more priority).

And then game can't see your controller (G25 wheel in my situation).
Only game restart helps, after that.

This bug exists since PCars release.
It's so cute when steam game is not compatible with steam.

Hope this weird bug will be fixed sometime.

OnyxD
20-07-2015, 19:38
This has happened loads of times for me too. Always from steam overlay. Still hapenning in 2.5