PDA

View Full Version : Driving Force GT centering problem.



fallte
10-06-2015, 06:23
I have this weird issue with my DFGT and project cars PC. The wheel calibrates itself properly in Windows but when I launch the game it centers itself 7 degrees to the right. I have installed and uninstalled the drivers on all USB ports, reinstalled the game but the problem persists. If I remove logitech profiler the issue goes away, but I cannot use 900 degree steering. I've tries logitech's clear calibration tool but it just says it could find no calibration. Currently I am at a loss and any input would be appreciated. I am using a Lenovo y580 laptop.

konnos
10-06-2015, 10:52
Sometimes my DFGT does that as well, but it is easily fixed for me. I take out the USB and the power cable and re-insert them, then the calibration works again correctly.

fallte
10-06-2015, 11:10
Doesn't work for me. Mind you, it centers itself properly when I plug it into my PS3. It seems that Project Cars itself has some sort of problem with it.

Bruno Alexandre
10-06-2015, 14:06
We have a lot of members with the DFGT but i cannot recall any of them reporting a similar issue. Can you try to launch the logitech profiler first and only then start our game? See if it alters anything in terms of the behavior of the wheel.

caxyh
10-06-2015, 14:14
Same problem. Start today. But 7 degree to the left.
In windows it's centered, after launch pCARS it's turn to left for around 7 degree. Reinstall, calbrating not helped.

Video:
https://www.youtube.com/watch?v=mYDNjBf9KOE

DragonSyr
10-06-2015, 14:14
have the same wheel...not problems at all.......

Bruno Alexandre
10-06-2015, 14:39
Have you tried some older logitech profiler to see if the issue was present as well, what about other games does it happen also ?

caxyh
10-06-2015, 15:03
I think I solved. disconnet DFGT>Uninstall profiler>reboot>install profiler 510 x86 (not x64)> connect to other USB port >install profiler 510 x64

UPD no, it's not installed to win x64+)
UPD2 after istall x64 , its work properly.
Just uninstall and install x64 not worked before as and change port too.

fallte
10-06-2015, 16:20
As long as the profiler is installed it does that. If I remove it, then remove the driver and reinstall just the driver via windows it works as a generic wheel and I lose 900 degree steering which is not ideal. Gonna try the above workaround now.

beezley
10-06-2015, 17:20
have you tried;

1. Stopping the profiler (don't uninstall just stop it)
2. Rename LWEMon.exe to something like LWEMon.exebackup. (The location is C:/Program Files/Logitech/Gaming Software/LWEMon.exe)
3. Then goto Control panel/hardware and sound/devices and printers right click dfgt, game controller and settings, set 900 degrees there with properties.

hope it helps :-)

I had this same problem and uninstalled logitech drivers completely, recalibrated my wheel in windows, reinstalled logitech drivers and started a fresh with pcars, which sorted it for me......

fallte
10-06-2015, 20:17
I did what caxyh said and it worked. The x86 version of profiler does not really install but when you install the x64 vrsion immediately after that it fixes this issue. Logitech software seems really horrendous so I blame them.

Zincau
10-12-2016, 14:33
I think I solved. disconnet DFGT>Uninstall profiler>reboot>install profiler 510 x86 (not x64)> connect to other USB port >install profiler 510 x64

UPD no, it's not installed to win x64+)
UPD2 after istall x64 , its work properly.
Just uninstall and install x64 not worked before as and change port too.

it really worked for me.. thanks