PDA

View Full Version : Sound Stuttering



tarbat
25-06-2015, 13:54
So, pCARS on XB1 still suffers from random episodes of sound stuttering. I've tried all the following to see if anything can help eliminate the problem, but to no avail.
- Disconnected Kinect.
- Network offline.
- Disconnected network cable.
- Put XB1 in Power Saving Mode.
- Full Power Off Reset.
- Re-install of pCARS.

Here's an example, with Kinect and network disconnected, in Power Save mode soon after a full power off reset. It's during a career quali session in the Palmer Jaguar on the Azure Circuit.


http://youtu.be/NjRqZWbkCB8

No matter what I try, still sound stuttering. There seems to be no pattern as to what parts of the circuit it happens on, and it seems to happen on all circuits.

I just want to make sure SMS are aware of this problem, and ask whether they are any nearer to establishing the cause, and potential solutions.

BMWE87
25-06-2015, 15:18
I get random stuttering as well on random tracks, random cars after random play times, the only difference between my setup and yours is, my sound comes through a 5.1 cinema surround sound setup (only this game has the issue), I am on a wireless network, with my Xbox online AND I have Kinect connected.

I4G0tMyGamertag
25-06-2015, 15:21
I know that if I ever say "Xbox Record That", that triggers a sound drop EVERYTIME. Sound drops like this are pretty frequent for me. I'm not a technical expert, but this is a game issue, not an Xbox issue. I have a 7.1 wireless surround headset that I use and I get this as well. Saying "Xbox Record That" isn't the only time the sound drop occurs, it's just the only condition I can confirm will trigger the sound drop.

BMWE87
25-06-2015, 15:38
I know that if I ever say "Xbox Record That", that triggers a sound drop EVERYTIME. Sound drops like this are pretty frequent for me. I'm not a technical expert, but this is a game issue, not an Xbox issue. I have a 7.1 wireless surround headset that I use and I get this as well. Saying "Xbox Record That" isn't the only time the sound drop occurs, it's just the only condition I can confirm will trigger the sound drop.

I just play the game with nothing running in the background and it will still stutter sometimes. Not a biggie. Just an annoyance.

cplzell
25-06-2015, 15:53
before this bug lasted 5-6 seconds, after the 1.4 patch lasts only 1-2 seconds and is less frequent. I think that with the patch 2.0 will be solved

tarbat
25-06-2015, 16:15
I think that with the patch 2.0 will be solved

Has anyone from SMS actually said they're addressing this problem in v2.0?

Dynomight Motorsports
25-06-2015, 18:01
I have this problem as well. Seems like its at every circuit sometimes its in the same place on the track and sometimes not. Good thing is there doesn't seem to be any frame rate issues accompanying it. But yeah it sounds like my engine is in a 55 gallon drum of water for about 5 seconds. It's a little annoying and distracting, but not a game breaker.

makeurownluck87
26-06-2015, 01:41
Also have this problem. Happens at random, very frustrating when I'm on a hot lap with headphones on and the volume up.

mkstatto
26-06-2015, 10:58
Here's to hoping the associated frame rate boost improves this issue, but i'm not too hopeful.

coopersport
26-06-2015, 13:29
I get this happen at least once in every race. Since patch 1.4 it doesn't seem to last as long as it did, but it is still happening. I use a Sony 5.1 AV receiver, and have also tested turning off the Kinect and doing some of the other steps taken by Tarbat.

paulogr66
27-06-2015, 22:14
I´ve got the same issue here and did not find any topic telling that the Developers are working on this issue.

Im Sorry
27-06-2015, 22:22
Think most people on Xbox have had this happen.At least once in every race or event for me.

cplzell
28-06-2015, 01:57
Has anyone from SMS actually said they're addressing this problem in v2.0?

even they did not say this problem improve with patch 1.4 but it did....many weeks for patch 2.0, be patient

ford8584
28-06-2015, 01:57
^thus, surely, they should fix it no? Or at least bloody say they are working on it.

tarbat
17-07-2015, 16:59
Just checking, was this meant to be fixed in v2.0, as its still happening.

Ian Bell
17-07-2015, 17:09
Here guys.
http://forum.projectcarsgame.com/showthread.php?35173-Patch-2-0-out-now-Opinions&p=1051353&viewfull=1#post1051353

lmp4 24
18-07-2015, 02:30
After an hour of tt on new track sound started the stuttering crap again. Was driving zed4

PeoplesChampion
18-07-2015, 02:36
Every single game I own on my X1 - And I own over 45 games - has audio lag from time to time.

These guys work hard, man.

You think you could show some respect before bold-facing your complaint? Also, why didn't you post this in an existing post?

lmp4 24
18-07-2015, 03:12
Easy bro, just letting them know that's there still a sound glitch. My post wasn't for u. Trying to post so they know about. Why is their always some fan boy gotta start crap all the all time.

TheReaper GT
18-07-2015, 03:13
Easy bro, just letting them know that's there still a sound glitch. My post wasn't for u. Trying to post so they know about. Why is their always some fan boy gotta start crap all the all time.

Why there's always one prone to offend others instead of use the damn search button?

Stag
18-07-2015, 03:19
Ban him for negativity

lmp4 24
18-07-2015, 03:20
Yah...i did search it. Nothing came up

TheReaper GT
18-07-2015, 03:23
Yah...i did search it. Nothing came up

Strange, I just did a search and found an Ian post saying that they are working to optimize the use of the seventh xbox one core, the one used to audio tasks, the one shared with system tasks.

lmp4 24
18-07-2015, 03:30
Then I guess that should have been your reply to my post. You know trying to help, instead of defacing my legitimate post. Love the game, best game racing game ever. Just giving them info so it can b sorted

Psychomatrix
18-07-2015, 03:33
When people report here bugs that help the game to get better. if the post not important it disappear very soon. It's the job of the mods to look at this things. They done they job here very well so there's need to blame or ban people. some here not every day so it's no prob to give a quick info and not starts arguments. The sound issues needs time to fix because it sharing a core with the operation system. So they work on it. It's known.

Lukeymonster
18-07-2015, 03:35
I was looking into that post as well where Ian said that the 7th core is being used for the audio. Also The Witcher 3 uses the same method for audio and I get the very same effect in that game as well. I am confident that SMS will get the 7th core under control as the audio glitch is improving for me with each patch. Still not perfect but improving.

TheReaper GT
18-07-2015, 03:36
I was looking into that post as well where Ian said that the 7th core is being used for the audio. Also The Witcher 3 uses the same method for audio and I get the very same effect in that game as well. I am confident that SMS will get the 7th core under control as the audio glitch is improving for me with each patch. Still not perfect but improving.

I think the next xbox sdk will bring better tools to manage that core.

General_RIMT
18-07-2015, 07:03
Yes from what I heard it will allow them to better know exactly how much power is available at all times. Baby steps. But let's face it, the next Gen consoles are a complete new learning curve. And what SMS was able to put out even with the bugs was impressive. I know pCars 2 will benefit because of their experience with the new consoles.

PeoplesChampion
18-07-2015, 11:39
Easy bro, just letting them know that's there still a sound glitch. My post wasn't for u. Trying to post so they know about. Why is their always some fan boy gotta start crap all the all time.

Fan boy? I am the furthest from an ass kisser you will ever see.

It's called respect and I will give respect where it is due.

Nickname85
18-07-2015, 14:24
Fan boy? I am the furthest from an ass kisser you will ever see.

It's called respect and I will give respect where it is due.

Oké, but they way you react to somebody that complains about an issue (not wyning or calling names, but an honest complaint about an issue that a lot of people have had) makes you look like a fanboy (I am not saying you are one)

I don't think that sms needs you to "fight their battles" ore something like that... Ian and his team are very capable of doing that themselves.

A lot of people that post something negative about the game are "shot down" immediately by some people(like you)...
It shouldn't be a crime to be critical about something.

When you stop being critical, you stop moving forward!

nissan4ever
18-07-2015, 15:17
This should be merged with other sound stuttering thread or closed.

Roger Prynne
18-07-2015, 15:30
Guys please calm it down or I will close this thread.

Merged threads.

tarbat
19-07-2015, 10:22
It's not (easier) unfortunately. We're running our audio tech on the newly 'opened' extra core which is shared with the OS. It will improve.

Is this dependent on getting an updated SDK from Microsoft, and if so, do you know any timescales on this?

giulianbu
19-07-2015, 13:44
stuttering are giving really annoyed, I hope will resolve

WRA NotSo
27-08-2015, 18:28
Ok i have this issue as well and im wondering did you change any visual effect options because i did. And in chatting with a teammate on the phone he says nobody else on the team has changed visuals and none of them is have this issue so im wondering if this is why. I turned off sun flares and a few others for obvious reasons. Could this be our problem????

WRA NotSo
27-08-2015, 19:12
has nothing to do with xbox record that. I rarely ever use that feature.

WRA NotSo
27-08-2015, 19:19
so after some testing with the visual setting set to factory or stock im having 0 sound lags even after about 12 laps at laguna with the Nissan lmp which was doing this glitch constantly even on the first lap. there is no option to reset the visual settings so here is a pic216410

Bealdor
27-08-2015, 19:22
Just to get this right, that image is showing your settings when you do have the stuttering issue or when you don't have it?

WRA NotSo
27-08-2015, 19:41
100% fix with the default visual settings, your welcome guys. only took 4 months for me to figure that out.

Bealdor
27-08-2015, 19:54
Thanks mate, reported to the devs.

WRA NotSo
27-08-2015, 20:13
that's the default setting that is not causing the issue. I was having a massive stuttering issue when the settings where changed. these are default which FIXED the issue. im guessing that people suffering from stutter issues have changed something in visual settings

WRA NotSo
27-08-2015, 20:17
im not sure which setting it was because I had several that I had changed. but off memory it was both sun flares off, dirt on windshield off, and a few others

Raven403
27-08-2015, 22:50
http://xboxclips.com/Raven403/89083807-5e6c-4278-a513-9d210c3901d6

http://xboxclips.com/Raven403/b0b6c23e-2b17-47b7-8988-5ce074fed8de

Both these clips are from today. As you can see, there is no VISUAL stutter, just audio. It happens Most times either in a braking zone, as in video 1, or right AS or After the Stig comes on the radio. Just thought id share these incase they differ from other reports

WRA NotSo
27-08-2015, 23:25
lol I know this but like I said it worked. and by the way during this audio glitch there is a lot of visual as well. but its cool you don't have to try it

Raven403
27-08-2015, 23:26
lol I know this but like I said it worked. and by the way during this audio glitch there is a lot of visual as well. but its cool you don't have to try it

No I am gonna try it, I wasn't directing that at u bud lol

WRA NotSo
28-08-2015, 14:04
u was right that didn't work all the but it lhelped a bit. so I tried deleteing my game save which by the way I had tunes for every track on about half the cars saved. and its not glitching so far fingers are crossed. I was really frustrated after the 3.0 patch released this morning and my first lap at rapuna got a horrible sound bug so I went back here to the forum to investigate and vent some about it and seen where afew have deleted game saves and that it fixed the issue. im glad I love to tune because they are all gone now

tarbat
28-08-2015, 14:33
Is this dependent on getting an updated SDK from Microsoft, and if so, do you know any timescales on this?

Could someone from SMS please give us all a status update on the sound stuttering issue. Is it dependent on getting an updated SDK from Microsoft, and what timescales can you put on finally getting this fixed. It's far and away the most annoying bug in pCARS. Thanks.

If it helps, I've noticed that it often happens when AI cars are using the pits.

madmax2069
28-08-2015, 15:09
Could someone from SMS please give us all a status update on the sound stuttering issue. Is it dependent on getting an updated SDK from Microsoft, and what timescales can you put on finally getting this fixed. It's far and away the most annoying bug in pCARS. Thanks.

If it helps, I've noticed that it often happens when AI cars are using the pits.

Ian and the devs already confirmed what the issue is and it would require a new SDK software before they can fix it (the SDK they had out allowed access to the 7th core, but lacked task scheduling which is what they are waiting on with the new SDK software), as for a timeframe SMS wouldn't really know, thats something only Microsoft would know.

tarbat
28-08-2015, 15:19
Okay, I hadn't seen anything from Ian that actually said they needed the new SDK to fix it. Do you have a link?

I gues they could always move the sound processing off the 7th core and take a performance hit elsewhere.

bluesky0870
28-08-2015, 16:30
u was right that didn't work all the but it lhelped a bit. so I tried deleteing my game save which by the way I had tunes for every track on about half the cars saved. and its not glitching so far fingers are crossed. I was really frustrated after the 3.0 patch released this morning and my first lap at rapuna got a horrible sound bug so I went back here to the forum to investigate and vent some about it and seen where afew have deleted game saves and that it fixed the issue. im glad I love to tune because they are all gone now

I feel with you, honestly. Read your venting earlier and experienced the same issues like you. Just wanted to tell you that a reinstallation of the game (without save game delete) did it for me. Glad to see you solved it on your own.

Lukeymonster
25-09-2015, 02:26
More insight into the glitch. I was having issues with MGS 5 and audio stuttering.very similar to pcars but it was so bad the controller would lock up and snake would continue on moving until the glitch stopped. Obviously not ideal. I got the new patch today to fix another big bug and it made the issue much much worse. I also get the same pcars audio stutter I. The witcher 3.

These games pushing into the realm of the 7th core are definitely having issues.

MajorEpidemic
29-09-2015, 20:17
that's the default setting that is not causing the issue. I was having a massive stuttering issue when the settings where changed. these are default which FIXED the issue. im guessing that people suffering from stutter issues have changed something in visual settings

I can also confirm that I was having major audio stuttering. I then reset my visual setting to the default as discussed here and that cured the problem. Nothing since.

KkDrummer
30-09-2015, 14:40
something else you can try is disabling ALL notifications on Xbox settings....it has helped quite a lot...