PDA

View Full Version : [SOLVED] MadCatz MC2 wheel and pedals setup - How to get them to work on a PC?



Gladfelder
29-06-2015, 17:45
If anyone has these working, how did you do it?

I initially plugged them in, let Windows search and install drivers then tested the set-up using joy.cpl. X axis shows raw data from 0 (full Left) to 65535 (full Right). All the buttons and paddles show a response.

In game I tried the obvious 'Custom' option along with 'Custom Low Fidelity'. While going through the calibration of wheel and pedals the numeric values below each graphic never changed from 0.

Oddly, If my mouse is pointing at the device selection pane and I turn the wheel it scrolls through the available devices. How the heck?

So, My question is - How did you get yours to work?

PC Spec Produced by Belarc Advisor

Operating System

Windows 7 Ultimate (x64) Service Pack 1 (build 7601)

Processor
3.40 gigahertz Intel Core i7-2600K
256 kilobyte primary memory cache
1024 kilobyte secondary memory cache
8192 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total)
Hyper-threaded (8 total)

Main Circuit Board
Board: ASUSTeK Computer INC. P8P67 PRO REV 3.1 Rev 1.xx
Bus Clock: 100 megahertz
BIOS: American Megatrends Inc. 3602 11/01/2012

Memory Modules
Slot 'ChannelA-DIMM0' is Empty
Slot 'ChannelA-DIMM1' has 4096 MB
Slot 'ChannelB-DIMM0' is Empty
Slot 'ChannelB-DIMM1' has 4096 MB

Display
AMD Radeon HD 6700 Series

Mahjik
29-06-2015, 17:53
You'll likely need to go into "Edit Assignments" first and assign the steering and pedal inputs first, then go into calibration.

Gladfelder
29-06-2015, 18:17
As a complete NooB I never thought of that. 2 minutes and IT WORKS!!!!

SO many options that I think some will need to be assigned to the keyboard but off to fiddle.

THANK YOU for ending 2 days of frustration.

Mahjik
29-06-2015, 18:24
No problem! Enjoy!

PrismarineGamer
15-12-2016, 22:19
PLEASE HELP!!!!
I have the Mad Catz MC2 Universal Steering wheel and I have the pc adaptor plugged into the Xbox plug but when I plug it into my computer (Windows XP x32 Bit) it comes up as unknown device and when I try to update driver, nothing comes up. I have looked online for a driver but I have had no luck. If anyone else has had this problem please help.