PDA

View Full Version : Fed up with this stuttering !!



Rht54
29-06-2015, 18:49
Half the time I am really enjoying this game more than AC , but this bloody stuttering is getting on my tits , it totally spoils the experiance to the point where I want to switch off and play another sim ...

Has anybody got any tips to get rid of the stutters ???

I`m running two AMD R9 290`s and 16gb of ram , 60fps in crossfire and 34 using one card but the game can`t be played using just one card ...

Umer Ahmad
29-06-2015, 19:12
Graphical settings?

Is the stuttering predictable? Like a certain corner of a certain track?

thepharcyde
29-06-2015, 19:36
You have tits?

Solution get a Nvidia GPU

Dan Britton
29-06-2015, 19:37
RHT54, If you don't already have it installed, try MSI afterburner. Create a profile and set the frame limiter to 59fps then in game disable v-sync. Fixed the crossfire stutters for me.

Edit : - in Sudbury, just up the road, small world init !

Rht54
29-06-2015, 19:40
And you don`t ? .........

Rht54
29-06-2015, 19:42
Cheers Dan , I do have MSI afterburner on my pc, but I`ve never created profiles before but I`ll have a go now fella , the stuttering is really spoiling a good game ...
Thamks for the tip mate ...

Dan Britton
29-06-2015, 19:44
good luck, if I remember rightly the profiles are set up within the rivatuner statistics server.

E_Luckow
29-06-2015, 19:51
Graphical settings?

Is the stuttering predictable? Like a certain corner of a certain track?

What would be the solution for that Umer?

Mahjik
29-06-2015, 19:59
What would be the solution for that Umer?

Some settings like "Motion Blur" can cause stuttering during heavy graphical sections on tracks.

E_Luckow
29-06-2015, 20:02
Thanks Mahjik. I'm well aware that motion blur is very demanding. I have it off.

I think my system is just not enough to deal with PCars. I hope for some track optimizations too, for mid-end machines.

Bealdor
29-06-2015, 20:05
Thanks Mahjik. I'm well aware that motion blur is very demanding. I have it off.

I think my system is just not enough to deal with PCars. I hope for some track optimizations too, for mid-end machines.

It should be good enough for 60fps in almost all conditions. What are your exact ingame graphics settings (screenshot of your settings would be the optimum)?

Rht54
29-06-2015, 20:06
Alo Dan , yeah mate it is a small world , lol ....

Rht54
29-06-2015, 20:07
No it happens all over the place , nit in one area or situation ...

Umer Ahmad
29-06-2015, 20:33
Pro-tip: DO NOT use ULTRA/ULTRA/ULTRA

Rht54
29-06-2015, 21:28
Dan , I `ve had a look and to be honest I can`t find a way to create a profile , how do you do it ?

E_Luckow
30-06-2015, 13:57
No ULTRA here.

No matter the settings, after a couple of laps the microstutters beggins, always at the same spot (s). This with 18 AI on track, or alone.

The same happens as soon the AI's start to pit.

Bealdor
30-06-2015, 14:00
No ULTRA here.

No matter the settings, after a couple of laps the microstutters beggins, always at the same spot (s). This with 18 AI on track, or alone.

The same happens as soon the AI's start to pit.

This sounds like a thermal issue to me. This could lead to throttling resulting in inconsistent performance. Could you check your CPU and GPU temps while playing please?

Edit: Sorry, just reread your PM and saw that you already did that. That's a strange issue indeed.

E_Luckow
30-06-2015, 14:03
This sounds like a thermal issue to me. This could lead to throttling resulting in inconsistent performance. Could you check your CPU and GPU temps while playing please?

Thats the problem. I would be "very happy", if this was the case. But not. All the temps are ok, both GPU (maximum 62-63) and CPU. (maximum 60)

Bealdor
30-06-2015, 14:06
Thats the problem. I would be "very happy", if this was the case. But not. All the temps are ok, both GPU (maximum 62-63) and CPU. (maximum 60)

The last thing I can think of is some kind of memory issue.
Maybe it's some Windows memory management issue or something with your RAM (which is unlikely because it would most likely lead to crashes instead of stuttering) or your HDD.

E_Luckow
30-06-2015, 14:10
My OS is in a SSD. PCars is installed in the HDD.

Saloei
30-06-2015, 18:46
I've been able to rid myself of stuttering in some games by setting FRAME PACING=OFF and using and AMD Crossfire Mode=OPTIMIZE 1X1 in my target game preset profile Located in CCC settings. You can always try it for Pcars.

njexit16e
30-06-2015, 19:19
Half the time I am really enjoying this game more than AC , but this bloody stuttering is getting on my tits , it totally spoils the experiance to the point where I want to switch off and play another sim ...

Has anybody got any tips to get rid of the stutters ???

I`m running two AMD R9 290`s and 16gb of ram , 60fps in crossfire and 34 using one card but the game can`t be played using just one card ...

What is the refresh rate of those crappy Dell DELL Ultrasharp 24" monitors?

Flihp
01-07-2015, 05:38
Just a quick note, the other day whilst fiddling around with graphic settings and decided to use someone's recommendations, I found myself getting some micro stutters here and there, and I could almost predict when it would happen, anyway, I turned off vignette and heat haze, aswell as returning rendered frames ahead back to 1 from 2( i was using 1 before), problem gone. I never tried to identify which of those three was the exact cause, but I suspect render frames ahead. My main suspicion for this is the micro stutter usually occured very close to applying or releasing brake and my understanding is that this setting is used to deal with device input lag, although not in that way,( sluggish response was my belief), but could be linked. Just a thought, :)

Phil

Rht54
01-07-2015, 13:22
Crappy , you taking the piss ? , its nothing to do with the monitors moron ....

jgaganas
01-07-2015, 14:02
Did you try the "-fpscap 63" thingy (and vsync via driver, not ingame)? I also need this for the current pcars2 build to run it smoothly.

Best to try out the whole fpscap-range from 59 to 63.

E_Luckow
01-07-2015, 14:02
Just a quick note, the other day whilst fiddling around with graphic settings and decided to use someone's recommendations, I found myself getting some micro stutters here and there, and I could almost predict when it would happen, anyway, I turned off vignette and heat haze, aswell as returning rendered frames ahead back to 1 from 2( i was using 1 before), problem gone. I never tried to identify which of those three was the exact cause, but I suspect render frames ahead. My main suspicion for this is the micro stutter usually occured very close to applying or releasing brake and my understanding is that this setting is used to deal with device input lag, although not in that way,( sluggish response was my belief), but could be linked. Just a thought, :)

Phil

Exactly that. I can predict as well the "hotspots".

Thanks for the tip. Will give a try.


By the way, have performed test toward memories, HDD and SDD. Everything ok.

Bealdor
01-07-2015, 14:04
Exactly that. I can predict as well the "hotspots".

Thanks for the tip. Will give a try.


By the way, have performed test toward memories, HDD and SDD. Everything ok.

I totally forgot one question: What wheel/controller are you using?

E_Luckow
01-07-2015, 14:08
I totally forgot one question: What wheel/controller are you using?

Hi Bealdor

A G27. Yes. The kind of problems I have remembers the case of one guy using a XBox controler (i have read that somewhere... )

Bealdor
01-07-2015, 14:10
Hi Bealdor

A G27. Yes. The kind of problems I have remembers the case of one guy using a XBox controler (i have read that somewhere... )

Yeah, that's why I asked. :)

Since we're getting a bit desperate here, could you do me a favour and test again with ingame FFB set to 0? Just to eliminate that as a possible cause.

E_Luckow
01-07-2015, 14:21
Yeah, that's why I asked. :)

Since we're getting a bit desperate here, could you do me a favour and test again with ingame FFB set to 0? Just to eliminate that as a possible cause.

heheheh

I will give a try.

Don't tell me about desperation. ;) I want to play it so badly. I have a hammer right now, to bring my damn rig to pieces :frown-new:

E_Luckow
01-07-2015, 14:22
By the way. Thank you for you help!

Rht54
01-07-2015, 14:33
Where do you adjust the Fps cap in Pcars ? , I can`t see it ??
Cheers

Mahjik
01-07-2015, 14:43
Where do you adjust the Fps cap in Pcars ? , I can`t see it ??
Cheers

You have to add it to your launch parameters in Steam (-fpscap ##).

Umer Ahmad
01-07-2015, 14:45
Where do you adjust the Fps cap in Pcars ? , I can`t see it ??
Cheers

Right Click Project CARS > Properties > Set Launch Options

210231

edit: ninja'd but mine is better ;)

Rht54
01-07-2015, 14:50
Many thanks guys I`ll try that and let you know ......

Cheers

njexit16e
01-07-2015, 17:24
Crappy , you taking the piss ? , its nothing to do with the monitors moron ....

nothing to do with monitors .... hmmmmm?

well you keep using those 60 hz crappy monitors dickhead ... and let me know if you ever get to play the game the way it suppose to be played.

Everybody thinks they can cure all the stuttering and lag issues with better video cards or more physical memory or faster CPUs'

the fact is ITS THE CRAPPY MONITOR you are using.

get a real gaming monitor that runs at 144 hz with a 1 ms response time and gsync and then let me know.


Geeezzee use your brain thats what its there for.

Its common sense MORON!

Umer Ahmad
01-07-2015, 17:26
Can we relax with the insults please? If you cannot help, just move on to another thread. Thanks.

Flihp
01-07-2015, 22:32
I also have a dell 24" ultra sharp, as my secondary screen, a few weeks back i was using it as my main before I got myself a cheap ass 27"., there was absolutely nothing wrong with it, it ran and more than likely still runs the game smoothly without stutter. It's actually a very good screen,it's 8 years old now, was originaly purchased for photographic work due to be one of very few 8 bit screen in its day.

Phil

E_Luckow
02-07-2015, 14:01
Definitely, there is something wrong with my system.

The microstutters seemed to be "almost" gone after disabling heat haze - in fact, I disabled every effect, and PPF.

But some tests latter, they were back.

I used to have the same results - stutters gone for a while - running the game in 32 bits.

Tried with FFB off, but this had no effect.

Anyway, thank you guys for trying to help! :encouragement:

I will give up for now. Wait for Windows 10, and later a GPU upgrade.

Bealdor
02-07-2015, 14:07
Nah, we're not even 5 pages in. We're not giving up so fast.

Did you try to disable your antivirus program while playing?

Install PCARS on your SSD and see if that helps.

E_Luckow
02-07-2015, 14:30
Nah, we're not even 5 pages in. We're not giving up so fast.

Did you try to disable your antivirus program while playing?

Install PCARS on your SSD and see if that helps.

Hi Bealdor, hehehe, thanks!


I have first disabled my AV, while playing (always do that)... then, after a moment of fury, i uninstalled it. Nothing.

Have performed full check for viruses, malwares, etc. Nothing detected.

Nothing "unusual" is running in the background. (this PC is used just for games). Checking the task manager (alt-tab), as soon the stuttering beggins, shows 99,9% of general CPU activity for PCars.


But Bealdor, how can I install Pcars in the SSD? I have the steam version of the game (installed in the HDD).

Thanks again for your attention!

Bealdor
02-07-2015, 14:35
But Bealdor, how can I install Pcars in the SSD? I have the steam version of the game (installed in the HDD).

Thanks again for your attention!

You can tell Steam to install it in a different location. It's not forcing you anymore to install your games in the Steam folder AFAIK.

E_Luckow
02-07-2015, 14:41
You can tell Steam to install it in a different location. It's not forcing you anymore to install your games in the Steam folder AFAIK.

Thanks again Bealdor

I will give a try!

BLUEmako
03-07-2015, 01:49
Try setting texture resolution lower in game. Fixed my stutter issues. Texture loading in the game would make it stutter and it got worse the longer I was in a race.

E_Luckow
03-07-2015, 03:02
Try setting texture resolution lower in game. Fixed my stutter issues. Texture loading in the game would make it stutter and it got worse the longer I was in a race.

Humm, I will give a try as well, thanks!

I installed my game on the SSD drive. Nothing has changed.

I have observed, however, that my CPU - only the core 1 - was working hard. But the strangest thing is, the load is lower with 17 AI´s (Formula Gulf - Nürburgring), than alone with a DLC car - (Mercedes-Benz CLK LM).

During the race, the CPU load is around 85-90 - I think it reaches the limit during the pits - maybe this causes the stutters?

But, alone? One single car? The Core one was almost all the time around 99-100%, from the start.

The core 3 is working, always, around 30% only :(

Thanks again mates!

Stones
03-07-2015, 03:15
Sounds like some of your cores are parked.

Flihp
03-07-2015, 03:35
Interesting, I will check mine tonight, I looked once before and had something like 5 cores in use all running pretty low and then another came into play with AI. I7 3770. Back in my days of flight simming we used to edit the config as well as setting processor affinity to multiple cores to increase performance, but I can't see this been the case here.

Phil

E_Luckow
03-07-2015, 03:40
Sounds like some of your cores are parked.

I will check again. But I'm almost sure that they are not. The truth is, I'm not sure about anything :p

Thanks anyway!

Bealdor
03-07-2015, 06:13
Humm, I will give a try as well, thanks!

I installed my game on the SSD drive. Nothing has changed.

I have observed, however, that my CPU - only the core 1 - was working hard. But the strangest thing is, the load is lower with 17 AI´s (Formula Gulf - Nürburgring), than alone with a DLC car - (Mercedes-Benz CLK LM).

During the race, the CPU load is around 85-90 - I think it reaches the limit during the pits - maybe this causes the stutters?

But, alone? One single car? The Core one was almost all the time around 99-100%, from the start.

The core 3 is working, always, around 30% only :(

Thanks again mates!

Are you using VSYNC? If not, try it. I'm forcing "adaptive" VSYNC from NVIDIA Control Panel and it works fine.

Alternatively you can set up a framecap through Steam start commands: -fpscap xx (xx = desired fps)

maxzig
03-07-2015, 09:19
with my old pc I use Anisotropic 4x and I do not have this stuttering anymore

MartinMWWebb
03-07-2015, 09:46
how can I install Pcars in the SSD? I have the steam version of the game (installed in the HDD).

Try this tool, i get steam to install everything to D:\ but i move current played games to the C:\ SSD with this. then if i'm not going to play for a while ill move it back to D: steam is none the wiser as it creates a junction point on the D:
http://www.traynier.com/software/steammover

E_Luckow
03-07-2015, 14:35
Hi!

Yes, I use v-sync and -fpscap 63

Thanks for the tip Martin, but I performed a clean install.

About the anisotropic filtering, I have tried even trilinear, and the stutters were the same.

Thanks!

DayGlow
03-07-2015, 23:45
Try this tool, i get steam to install everything to D:\ but i move current played games to the C:\ SSD with this. then if i'm not going to play for a while ill move it back to D: steam is none the wiser as it creates a junction point on the D:
http://www.traynier.com/software/steammover

Was about to suggest this. Great little app. Use it to manage all my game installs between my large data drive and gaming SSD.

DayGlow
03-07-2015, 23:47
I use x2 290x in crossfire with 3 1080p monitors and haven't noticed any stutter. As suggested I use Afterburner to limit 60fps and play with vsync off.

E_Luckow
04-07-2015, 01:55
After the analysis of the CPU activity - core by core, with afterburner -, I guess there is something wrong there. Only one core with high activity.

By the way, I have unparked the cores.

Flihp
04-07-2015, 02:11
here's mine
single
210588

race with 25 Ai
210589

I7 3770,

phil

E_Luckow
04-07-2015, 03:46
This with mine, with 17 AI cars. I will post later the reading from afterburner.

210591