View Full Version : Th8a shifter problem

11-08-2015, 12:28
can anyone tell me how to get the th8a shifter to work in sequential works fine in h pattern but changed over to sequential does nothing ... I have checked its all lined up properly with the little notch and still nothing what am I doing wrong ?

11-08-2015, 14:22
Did you assign the bindings in the menu correctly? They have to be mapped to "shift up" and "shift down" manually, as these are two separate buttons not used in H-mode (unlike the G25 shifter).

12-08-2015, 03:27
Good video on shifter.

27-09-2015, 21:11
Yesterday the TH8a was plugged into the base of my T300RS (din). All worked as it should...
Today however, I started Project CARS, waited for the loading screen to disappear for my first race. When it did, instantly my wheel was disconnected. Dead! No light ON at the base, no nothing. Restarting my ps4, Project CARS, wheel, in whatever order. Nothing, checked all the wiring, all ok. No fysical changes since yesterday.
Finally I could get the wheel to power up when I disconnected the TH8A. Twice, thereafter again nothing, weird....
Restarting my ps4, Project CARS, wheel, in whatever order, with or without the TH8A connected, nothing.
While checking the internet I read several problems could be solved with updating the TH8A aswell as the T300 to the latest firmware.
Done both.
T300 works again as it should.
TH8A, works perfect on the pc.
Plugged the TH8A into the din connector at the back of the T300 and started the whole thing again on the ps4.
It all worked, until exiting the pit for the first time. The shifter does not work..... Grrrr, annoying.
When I plug the TH8A, with usb, in my ps4, instantly I have a working shifter again.
So, the shifter works. But only with the usb connector and not with the din connector in the base of the T300.
It worked yesterday, but now for one reason or another it doesn't anymore.
Has anybody had something similar, or maybe even better, have a solution for it.
The fault must be in or the din cable or the din connector at the base....
(I don't want to use the usb cable as a permanent solution. My setup is too far away from the ps4 and I preferably don't want to use a usbhub)

28-09-2015, 00:48
try cleaning the connections on the TH8A ps2 din ,,,,,maybe the pins are a little dirty ..

28-09-2015, 20:36
Thanks for the tip. No luck though.
I have been scouting the web today.
Rarely the DIN/DIN cable seems to be broken.
Most of the time it is the wiring inside the wheelbase. There seems to be a possibility for it to shortcircuit.
Or even within the shifter itself http://youtu.be/AUMwWTLBYEg
And a short circuit would explain my sudden problems.

30-09-2015, 16:20
Update 1:
After a phonecall with the Thrustmaster helpdesk and a few emails with required info a new DIN/DIN cable is on its way.

15-10-2015, 19:52
Update 2:
Yesterday I received a new DIN/DIN cable from Thrustmaster.
Unfortunately it does not work either.
Still, via USB ok. Via DIN not working.

16-10-2015, 06:01
Maybe it s a wrong contact in the wheel base.

16-10-2015, 06:29
All this talk about Din/Din makes me Hungry.

16-10-2015, 10:23
Maybe it s a wrong contact in the wheel base.

That is what I am thinking aswell...

Haha, SubG. Everybody got their own fantasies.... Lol

23-10-2015, 16:10
Update 3:
As the new cable did not work, I contacted Thrustmaster again.
I had to do a new troubleshoot.
-hook up my T300rs to my pc and put the shifter in sequential mode while connected to the base of the T300.
When shifting the paddles, button 1 and 2 light up. The same was supposed to happen when shifting sequential.
But no, unfortunatly, nothing happened.
Therefor I have to pack my T300 base and TH8A shifter and send them to Thrustmaster.
They will troubleshoot and fix the issue, yeay...
Meaning, ofcourse, that I will have to miss my beloved Wheel for some time, buuu...

In general a big thank you to the Thrustmaster helpdesk (by phone)
Awaiting update 4 ;)

23-10-2015, 21:18
Did you try to connect the shifter directly on the ps4 using the usb cable?

28-10-2015, 19:11
Did you try to connect the shifter directly on the ps4 using the usb cable?

Yes, I have. And that works. It is just the din-din connection that does not work.
In the manual of the shifter it says that connecting the shifter via a USB-hub is not recommended, due to possible input errors. Plus, that both are still in their warranty period.
The base and the shifter are now on their way back to Thrustmaster for inspection and repair.

28-10-2015, 19:18
My TH8A works perfectly using usb (I have a T 500 and the din connection is not possible).

28-10-2015, 22:42
My TH8A works perfectly using usb (I have a T 500 and the din connection is not possible).

+ 1 same here

29-10-2015, 18:15
My TH8A works perfectly using usb (I have a T 500 and the din connection is not possible).

Thanks, that is good to know.

13-11-2015, 12:40
Update 4: hopefully last and final update
I received my wheel and shifter yesterday after I send it off to Thrustmaster about 2 weeks ago.
The connector on the wheelbase was the problem. A new connector is installed.
My wheel is up and running again, with the shifter connected to the wheelbase.