PDA

View Full Version : Irregular crossfire usage



LooneyJuice
17-08-2015, 04:44
Hello guys

Tried searching for a bit through the forum, didn't find anything describing my issue, so here goes.

First, specs:

CPU: i5 3570k @ 4.0
GPU: Sapphire HD7850 OC + Gigabyte HD7850 OC (Synced clocks)
RAM: 8GB HyperX Genesis @ 1600Mhz
Game drive: WD 1TB Caviar...something something
OS: Windows 10 Pro (Clean Installation)
Drivers: CAT 15.7.1

So, basically the issue is this. There's this incredibly lopsided GPU usage with GPU 2 showing more usage than GPU 1 (approx 20-30% when solo, or when there's few cars around) which doesn't hurt the framerate, in fact, under those conditions, there's enough overhead to maintain 60 fps even in a storm with a couple of cars around. The problem starts when on a starting grid though, or with a lot of cars around. GPU 2 usage immediately hits 99%, whilst GPU 1 is still hovering in the ~30% range, with severely deteriorating framerate (~25-35) and really choppy at that, with all sorts of hops and skips in frames as well, while GPU 1 is refusing to budge.

Meanwhile, disabling crossfire, may in some cases, especially in the wet chop off some of the performance in the previous solo/few car instances, but it drastically improves the overall experience, with even full grid starts rarely dipping below the 40s in pretty poor weather. So TL;DR, around few cars xfire gives me a slight bit of overhead to maintain 60 under all conditions, around a lot of cars, GPU 2 immediately hits 99%, GPU1 still at 30%, massive stuttering, skipping, and poorer performance than even the framerate would dictate.

Tried the following:

Reinstalled DX11 in case of corruption, no change
Reinstalled drivers like 3 times due to an unrelated issue, but still no change
Deleted graphics config, nothing
Tweaked different settings from low to high, only difference is that it stops the second card from hitting max usage, thereby stopping the stutters, still lopsided usage by about 40%
Reset GPUs to stock clocks, no difference
Tried different CF modes (AFR Friendly, Optimize 1x1), no difference, AFR friendly also had some awful flickering

Extra info:

It does not appear to be a CPU bottleneck, since usage rarely peaks over 80% even in really crowded situations
Framerate is capped at 63
No overheating on any component, everything running below stock clock/stock configuration temps.
No background processes running
CPU cores unparked

Thanks in advance to anyone who takes the time to go through this, and for any possible suggestions.

ProDoctoR1987
17-08-2015, 11:24
Hello guys

Tried searching for a bit through the forum, didn't find anything describing my issue, so here goes.

First, specs:

CPU: i5 3570k @ 4.0
GPU: Sapphire HD7850 OC + Gigabyte HD7850 OC (Synced clocks)
RAM: 8GB HyperX Genesis @ 1600Mhz
Game drive: WD 1TB Caviar...something something
OS: Windows 10 Pro (Clean Installation)
Drivers: CAT 15.7.1

So, basically the issue is this. There's this incredibly lopsided GPU usage with GPU 2 showing more usage than GPU 1 (approx 20-30% when solo, or when there's few cars around) which doesn't hurt the framerate, in fact, under those conditions, there's enough overhead to maintain 60 fps even in a storm with a couple of cars around. The problem starts when on a starting grid though, or with a lot of cars around. GPU 2 usage immediately hits 99%, whilst GPU 1 is still hovering in the ~30% range, with severely deteriorating framerate (~25-35) and really choppy at that, with all sorts of hops and skips in frames as well, while GPU 1 is refusing to budge.

Meanwhile, disabling crossfire, may in some cases, especially in the wet chop off some of the performance in the previous solo/few car instances, but it drastically improves the overall experience, with even full grid starts rarely dipping below the 40s in pretty poor weather. So TL;DR, around few cars xfire gives me a slight bit of overhead to maintain 60 under all conditions, around a lot of cars, GPU 2 immediately hits 99%, GPU1 still at 30%, massive stuttering, skipping, and poorer performance than even the framerate would dictate.

Tried the following:

Reinstalled DX11 in case of corruption, no change
Reinstalled drivers like 3 times due to an unrelated issue, but still no change
Deleted graphics config, nothing
Tweaked different settings from low to high, only difference is that it stops the second card from hitting max usage, thereby stopping the stutters, still lopsided usage by about 40%
Reset GPUs to stock clocks, no difference
Tried different CF modes (AFR Friendly, Optimize 1x1), no difference, AFR friendly also had some awful flickering

Extra info:

It does not appear to be a CPU bottleneck, since usage rarely peaks over 80% even in really crowded situations
Framerate is capped at 63
No overheating on any component, everything running below stock clock/stock configuration temps.
No background processes running
CPU cores unparked

Thanks in advance to anyone who takes the time to go through this, and for any possible suggestions.


It's what they call multiple GPU support :) A optimized game !

See my thread :

http://forum.projectcarsgame.com/showthread.php?36677-Bad-SLI-usage-when-it-s-raining

LooneyJuice
18-08-2015, 02:00
Probably a combo of multi-gpu optimization and drivers I guess, yes.

spyshagg
18-08-2015, 18:35
You are hitting a Cpu bottleneck my friend :) The gpus can only render what the cpu is able feed them.

drop track and vehicle details to low and see the cpu usage go down while the GPU usages and framerates go up.


well, this is the behavior on my rig anyway.

2600k @ 5ghz
2x r9 290x
triple fhd screens.

LooneyJuice
19-08-2015, 09:26
Mentioned that in the extra info section, ~80% is the worst case scenario for CPU. Mostly it's down in the 60s. Even tried a race at low settings, still had incredibly lopsided GPU usage. I even tried to limit the GPU 1 pcie slot speed so as to mitigate saturating GPU2's pcie slot so fast, since my motherboard is well...bit of a piece of excrement, still nothing, in fact, not even noticing a performance difference in synthetic benchmarks. Those still hover between 95-99% on both GPUs. Thanks for the input though.

spyshagg
19-08-2015, 09:43
~80% is near the max cpu you will get from pcars. It means you are bottlenecked.

The crossfire GPU usage is loadbalanced and as such the usage percentage will flip flop between cards. One second you have gpu1 at 5% gpu2 at 80%, and the next second its 100% on gpu 1 and 0% on gpu 2. It is normal.


Do a test for me. keep crossfire enabled. Chose:

nurbugring gp
24 cars
Full rain
16h

check the framerate while you are standing waiting for the green lights.

now overclock your CPU by 500mhz and do the same test. Check the framerate.
now downclock your cpu to 2.5ghz or so and do the same test. Check the framerate.

You will see that your minimal framerates are CPU bound

LooneyJuice
19-08-2015, 10:45
Welp, back from testing. Didn't really want to get into the hassle of going up another 500mhz checking voltages and all (temps are fine but the cooling isn't superb for anything above 4.2-4.3ish) but i did go down 1GHz, and it genuinely surprised me as well, no change in framerate whatsoever. 28-29 on the grid at 4.0Ghz 28-29 at 3.0Ghz, meanwhile, it does show up as a pretty big dive in cinebench, so...yeah. Something's up.

And again, there's no 100% GPU 1 and 0% GPU 2 or vise versa, it is always saturating the second gpu, while the first one remains at 30-40%, regardless of conditions, as long as there's more than a few cars around, while solo the usage is still lopsided, but doesn't saturate either card. It is always that relation in usage between cards.

spyshagg
19-08-2015, 16:25
Yep gpu bottleneck in that situation for sure. But 2x 7850's will bottleneck very easily.

But what you seem to be experiencing is poor framepacing with lots of juddering. This is typical of crossfire to be honest. I have also experienced this issue with my crossfire on ALL games. The crossfire provides higher framerates but poor smoothness. One card is always be smother to my eyes.

Fortunately, there is a solution. You may have heard of capping the framerates to the monitor refresh rate, but this wont work.
To have perfect smoothness, I had to enable Vsync. The reduce the input lag of Vsync, i capped the framerate to 60fps (this prevents vsync from storing older frames on the buffer).

Its either Vsync or the use of an Adaptive-sync monitor

LooneyJuice
19-08-2015, 16:38
Yeah I'd rather go beefier single gpu any day, unfortunately I'm running them out of chance/necessity. I've tried all the capping and whatnot too, kind of helps, but not a whole lot. I'm sure there's also quite a bit of poor optimization for multi-gpu (as is the case with a multitude of games), because if they scaled properly 2x7850s (albeit mediocre) should be more than enough to maintain decent framerate with my settings regardless of conditions (a single one on the grid is actually in the 40s, ~10-15 fps better than running both). On the other hand, something like Assetto Corsa, doesn't even have a crossfire profile, I stick it on AFR manually, and the usage is more or less even, and the crossfire scaling is sublime. Same settings, 47fps on 1 GPU, right on my 60fps cap with 2 and with a bucketload of overhead for opponents, maxed out, granted it's not as demanding, but still a bit odd.

Originally I thought that it just didn't like the slower PCIE 2 slot because of the saturation, but programs that are pretty sorted for multi-gpu are running fine regardless of the slower PCIE slot. Guess we'll have to wait for another update from AMD or SMS. Thanks for taking the time though.

spyshagg
19-08-2015, 18:47
I don't believe the issue is the PCI-E 2.0. My heavily overclocked 290x's perform great on Pcars and they are far more bandwidth hungry than yours (and they use the PCI-E for the crossfire comunication!)

The only problem I find in Pcars is the cpu usage. anything above normal in Tracks-Cars-Enviromentmao put my 5Ghz i7 at 80% and it slows down my Gpu's. I can run triple screens with everything almost maxed out, FXAA, DS-2X, ultra textures etc. Just not track-cars-enviroment details above normal (or low)

TrevorAustin
19-08-2015, 21:48
~80% is near the max cpu you will get from pcars. It means you are bottlenecked.

The crossfire GPU usage is loadbalanced and as such the usage percentage will flip flop between cards. One second you have gpu1 at 5% gpu2 at 80%, and the next second its 100% on gpu 1 and 0% on gpu 2. It is normal.


Do a test for me. keep crossfire enabled. Chose:

nurbugring gp
24 cars
Full rain
16h

check the framerate while you are standing waiting for the green lights.

now overclock your CPU by 500mhz and do the same test. Check the framerate.
now downclock your cpu to 2.5ghz or so and do the same test. Check the framerate.

You will see that your minimal framerates are CPU bound

100% agree with this, done these tests so many times witt loads of different hardware, cpu overclock gives a massively disproportionate framerate increase compared to any other game I've played.

TrevorAustin
19-08-2015, 21:50
I don't believe the issue is the PCI-E 2.0. My heavily overclocked 290x's perform great on Pcars and they are far more bandwidth hungry than yours (and they use the PCI-E for the crossfire comunication!)

The only problem I find in Pcars is the cpu usage. anything above normal in Tracks-Cars-Enviromentmao put my 5Ghz i7 at 80% and it slows down my Gpu's. I can run triple screens with everything almost maxed out, FXAA, DS-2X, ultra textures etc. Just not track-cars-enviroment details above normal (or low)

I uograded to a 4.6 5820 for some extra cores, made a huge difference in 2d/triples, unfortunately the oculus crappy runtime still messes up in the rift. That bangs core 1 up to 80% as soon as i get a few ai ecen at medium settings. 80% is a definite limit for some reason.

But in 2d the 5820 can easily max my card, looks amazinvwin triples.

Saloei
20-08-2015, 00:30
Try turning Frame Pacing off in CatalystControlCenter\Gaming. Add pcars.exe to the list, select it, slide down towards the bottom of the page, and turn off Frame Pacing. I also get better performance with vsync on.

I was getting good framerates but gameplay was rough. Turning that setting off smoothened game play for me.