PDA

View Full Version : Massive FPS drop at Le Mans



TMoney
20-09-2015, 06:47
Not sure if this is new to 4.0 but while doing the 24 Hr Le Mans race in career (and even practice session alone) I'm getting a massive framerate drop in certain parts of the track. It seems to happen only in the daylight and in the heavily wooded areas, after the 2nd long straight. I usually get 60-70 FPS but in these areas it's dropping into the 30's if not less. Anyone else getting this?

N0body Of The Goat
20-09-2015, 06:54
Is this due to the 3D trees? I believe Le Mans has some, but I could not tell you where they are.;)

flymar
20-09-2015, 08:06
Not sure if this is new to 4.0 but while doing the 24 Hr Le Mans race in career (and even practice session alone) I'm getting a massive framerate drop in certain parts of the track. It seems to happen only in the daylight and in the heavily wooded areas, after the 2nd long straight. I usually get 60-70 FPS but in these areas it's dropping into the 30's if not less. Anyone else getting this?Can you post the setting of the race? (I wish to check it in quick race).
EDIT: Big track with enhanced mirrors maybe?

Kroegtijgertje
20-09-2015, 08:29
No problems here!

http://i281.photobucket.com/albums/kk225/Bulletje0113/2015-09-20_00001_zpsra9i0r9v.jpg


https://www.youtube.com/watch?v=HAvtJJPC7WM

Schumi-
20-09-2015, 08:37
No problems here either, dropped just 1 frame using cockpit view, but i do have my game capped to 60fps though, I did notice coming over the brow of the hill that i had problems with my mirrors, but then the problem disappeared, as you can see from the image, bottom half of the mirrors are just plain.
218545

N0body Of The Goat
20-09-2015, 08:41
Schumi-, was that with enhanced mirrors on, by any chance?

Schumi-
20-09-2015, 08:45
Schumi-, was that with enhanced mirrors on, by any chance?

Yes it is, will try again a bit later, with the standard mirrors just to confirm the problem.

EDIT, confirmed problem happens only with Enhanced mirrors turned on.

Roger Prynne
20-09-2015, 12:22
Reported..... thanks for the info guys.

TMoney
20-09-2015, 18:23
Yea I forgot to mention about the lower half of the mirrors going blank which only happens at a specific part of the track which you can also see in my video.


Here's a quick video of me doing a lap (hope you can read the FPS monitor in the top left). Normally my fps is a bit higher when I'm not recording but even then I can still feel the lag. While recording with Afterburner you can see the framerate drop to the low 30's. It seems worse coming up to and right after the Rolex sign coming out of the right hand turn after the main straight.


https://www.youtube.com/watch?v=V7uOAb9HEC0&feature=youtu.be


Here's my settings for Free Practice:

218570


Here's my graphic settings:

218572

1920x1200 59Hz , Windowed = No
218573


Can someone else try my settings to see if you can reproduce the issue? This is the only track I have this problem as far as I know.

Tastakrad
22-09-2015, 12:17
Reduce the Environment Map to low and Detailed Grass too low/off. With Environment Map on low I gained a lot of frames, especially in the rain!

(MSI Geforce 980, Intel i7 4770k)

flymar
25-09-2015, 06:33
With my standard settings env-medium, reflection-high, details-ultra, enhanced mirror-On, grass-low with full grid and rain I havent seen any particular drop on the track.

Invincible
25-09-2015, 06:49
I have noticed a significant drop on Mulsanne straight. But not only since 4.0. It has been there before too.
I always thought it was only a not so greatly optimized area of the track.

My settings are:
1920x1200
Texture: High
AA: High
FXAA: high
rest is everything on Medium except for: Grass (low) Vehicle and track (ultra)

On the rest of the course I have 61 fps with ~ 65 - 80 % GPU load (sunny conditions). On Mulsanne it drops to 50 -55 fps with 100% load.

IJerichoI
25-09-2015, 07:25
I can second that, I get the really visible drop after the Mulsanne corner, the rest of the track is fine. I believe some weird geometry causes this, as there are no problems on the Hunaudieres. Having 55+ FPS throughout the track it drops to ~28-30 in this part. coming to the last right before Indianapolis everything is fine.

enhanced mirrors off, at least I didn't check after the update, but I think the default ist off. However, drop was there since before release.

Bruno Alexandre
28-09-2015, 11:17
We have a fix incoming for this when using the enhance rear view mirror, thanks for the reports :)

Invincible
28-09-2015, 11:42
We have a fix incoming for this when using the enhance rear view mirror, thanks for the reports :)

Thank you for your reply! :D
Any news on the drop IJerichoI and I reported? Because we both didn't use the new enhanced rear view mirror ad were still experiencing some significant drops...

CreamyDischarge
25-11-2015, 01:45
I have this in this location too. Along with Zolder and Brands. Only in heavily wooded areas.

The start finish line is above 120fps but the Wooded tight chicane at zolder drops to 35
A reduction of nearly 100fps ?
Same at brands
Same at Le Mans

No enhanced mirrors.
970
4770
16GB RAM
SSD
Version 6.1

As an example, I can run Donnington with ever setting on ultra, enhanced mirrors and AA DS2M + SMAA ultra and still get above 60fps.

But driving in wooded areas requires me to drop to high settings, no enhanced mirrors, no Only msaa and still nearly hitting 60fps.

Any chance there is a spare artist willing to remove and optimise those trees for the next patch?

Thomas Sikora
15-06-2016, 07:53
At Lemans i have still fragedrops in the bottom part of the Track from 2nd chichane up to indianapolis.
234414
Here it goes down to 30, normaly i have everywhere stable 60. In this part of the track the trees looks also much better, more details, more sharp. It is a render bug in game or in the grafik driver?
Is there some workaround?
I have most settings very low, it works on every track, also Nordschleife, everywhere 55 to 60 fps. Only in Lemans, in the bottom part of the track it drops suddely to half frames.
Drivingconditions 14:00 and clear in oreca nissan. Current radeon version 16.5.3
234411234412234413

wolowizzard
15-06-2016, 16:47
Same here, only Le Mans after the Mulsanne to corner #10.

Mahjik
15-06-2016, 16:56
http://forum.projectcarsgame.com/showthread.php?43313-Questions-and-answers-in-here&p=1198971&viewfull=1#post1198971

Thomas Sikora
15-06-2016, 17:17
to bad...
hope there will be a solution for pcars2

Edit: but why it is only in this part of the track?
Are there an other kind of trees?
As i said, everywhere else i have no problems and there are also trees.

Mahjik
15-06-2016, 17:58
Are there an other kind of trees?

Yes. If you look back at the WMD forums, you can see where they use different types of trees. The main ones that are visible are 3D which is where the performance hit comes into play. That's what Ian was saying that visible forest areas will use highly populated 3D trees which will have an impact on performance. If they optimized in those areas, the trees will look terrible.

Thomas Sikora
15-06-2016, 18:20
hmmmm
:confused:
234441

Nighttiger
26-06-2016, 16:59
I had the same issue, I fixed it by disabling and not limiting the framerate. You notice this stuttering because you are using V-Sync and the graphic cards cannot keep up with the 60 fps.

When V-sync is enabled on the video card drivers and the settings of the 3D game you play, the graphics card ensures that the last full rendered image is in the frame buffer at any time. In order to obtain a smooth image with V-sync enabled there should be, in the case of a 60 Hz monitor, a new image every 16.7 ms. That can not be guaranteed ...

The speed at which a GPU in games may calculate new images, is very variable and depends on the quantity: each image has a different processing time, and the fps of a video card can be very diverse. If it is not possible to calculate the next image in 16.7 ms, for example during an intense scene, the previous image in the frame buffer is drawn to the monitor and the monitor will show the same image for the second time. The result is that where you normally have a new image every 16.7 ms, sometimes after 2 x 16.7 ms = 33.3 ms a new image is shown. This corresponds to the performance thus fall back momentarily from 60 fps to 30 fps. You notice that as a hickup in gameplay, stuttering.

234653

234654

During that difficult scene in LeMan your FPS hops between 60 and 30, maybe even 20 (3 x 16.7), and you see that as stuttering. If you turn off V-sync the problem is gone, however you might experience way more tearing (unless you have a FreeSync or Gsync screen). So you must choose between two evils sometimes. Do you want tearing or do you want stuttering during your 2.4h of LeMans ;)

Thomas Sikora
27-06-2016, 15:13
i will check...but the problem is that i/and few others have permanent low frames in the bottom track part.

havocc
27-06-2016, 15:18
I have quite bad fps with in-game vsync, with nvidia adaptive v-sync i am on stable 60, without vsync up to 120-130