PDA

View Full Version : Using external monitor causes heavy flickering (no 60hz option available)



CHRiTTeR
25-09-2015, 01:46
Hi, when I use my external monitor it causes severe flickering. I think it might be a refresh rate issue since my monitor runs at 1920*1080@60hz but i can only select 50hz or 59hz in project cars??

If i run the game in windowed mode it look fine though even with the 59hz mode selected in the game, I suspect the windows refresh rate is used in windowed mode?

I tried setting my refresh rate at 59hz in windows, but that didnt help. But thats probably normal since i can only adjust my intel GPU's refresh rate and not the one for my nvidia gpu...



I never had this issue before with my other games so im pretty sure this is a project cars issue.

Roger Prynne
25-09-2015, 11:25
I run my 50" TV @ 1920*1080@59hz and have no probs at all.

CHRiTTeR
25-09-2015, 11:47
I run my 50" TV @ 1920*1080@59hz and have no probs at all.

The game runs fine on my laptop's build in screen aswell.
My brother has the game aswell and no problems with his external monitor..


I'll try connecting my laptop to another external screen later this week (hopefully) and report back.

After trying to fix it for several days now im pretty sure something is going wrong from pCars's side.

chilyb
27-09-2015, 00:34
I run PCars with NVIDIA GPU with 60inch HDTV via HDMI on Denon AVR with no issues. I use 1920X1080/60Hz resolution for my GPU which is GTX645.
If you have not already, I would suggest you download the NVIDIA GeForce Experience utility. Between that and the NVIDIA Control Pannell utility you should be able to get you resolution issue solved. Also note that the GeForce Experience software tells me that my optimal resolution for PCars with my GPU is 1280X720/60Hz.
The Experience software will allow you to optimize the game settings to your GPU.

teazr
27-09-2015, 06:25
Try turning vertical sync off.

Ryzza5
28-09-2015, 04:07
You might also try modifying the graphics option file directly in Documents\Project CARS (make a backup first)

CHRiTTeR
28-09-2015, 23:29
Ok, first of all thanks for the replies and trying to help me with this...

I have experimented some more trying to find the 'source' of this problem.

- I tried switching to another external screen (my brother's). This worked fine.
Reattached mine without changing settings and again i got the problem... This, at first sight would tell me that my monitor is the source of the problem, but I can tell you it isnt since i never had this problem before with other games/software/apps running at 1080p60

- I reninstalled my screen's drivers. Didnt help

- Updated to the latest nvidia drivers... didnt help

- Diasabling vsync (tried it before a few time but tried it again, you never know)... doesnt work

- Played around with several anti aliasing settings... didnt work

- I set my screen to 60hz but in interlaced mode in the intel driver and it gave similar flickering in windows but even more severe. This reinforces my suspicion that something is going wrong with the refresh rate.
Turning on the fps indicator in steam confirms the game runs at 60fps with vsync on

- When I turn on the fps information in starcraft 2 (which runs fine) with vsync on it shows me the fps is switching really fast between 59 and 60.
I Googled a bit and found that some screens actually work at 59.94hz (this could explain why starcraft is showing a fps that is switching fast between 59 and 60hz because of rounding errors)... maybe its because of this and the game cant handle that refresh rate well?

I tried adjusting the config file in the "Documents\Project CARS" folder but some weird number is filled in where suspect the refresh rate should be set.

<prop name="Mode" adapter="0" width="1920" height="1080" refresh_num="148351648" refresh_dem="2475000" />

I also noticed when i change the values in the config file the game resets them back to the original values (and thus my input gets ingored i guess)?
I suspect i have to adjust the "refresh_num" value and set it to the desired refresh rate, right? If so, what is the "refresh_dem" for then?
*UPDATE: so i updated the config file and then set it to read only which prevents the game from overwriting it, but it doesnt fix the problem (still flickering).

Also noteworthy is that its especially noticable on thin lines (like the ones around the boxes in the main menu screen where you have to select racing modes or config).
Almost like its being interlaced... but im not 100% sure.

The graphics also look slightly blurry (agains especially noticable in the menus) but that could simply be because the menu graphics are made in lower res and they get interpolated to a higher res? (which i find a bit weird for a modern game running at 1080p btw).
*UPDATE: Ok, so when i get the small update box from steam in the lower right corner (when a friend comes online etc...) the tekst in that box is also much blurrier and flickering (which doesnt happen in other games). I think the blurry look might be a side effect of some form of (bad) interlacing (forced?)? even though my monitor is set to progressive...

Anyone know where i can set the game to interlaced or progressive (if need be in some config file)?
And how can is force a refresh rate in my nvidia control panel? I seem to have verry few settings available in my nvidia control panel, I remember a few years ago there used to be much more options exposed (like screen scaling, custom resolutions, rotation, etc...) those are all gone now?

I tried filming the problem with my phone but it doesnt have high enough framerate to capture the flickering...
I tried to capture it with nvidia's shadowplay but the problem isn't there when i play the recorded footage in full screen using media player classic (everything looks sharp and no flickering...)

Maybe its because I'm running windows 10?!

CHRiTTeR
29-09-2015, 01:00
BTW, arent there any developers active on these forums? Might be nice to get some feedback from them aswell...

Or any way to contact their tech support would be geat?

CHRiTTeR
29-09-2015, 03:25
Ok, so I got an update...

I found out that setting my multiple screen settings to "duplicate" in windows fixes the problem (no more flickering and everything looks crisp!).
But this way I can't use multiple monitors? :dread:

Also comparing my graphics to some of the video's from other player it looks like my graphics dont look as good, even though they are maxed out (except for motion blur is turned off and the aa is at high + smaa@ultra)
but thats something for a different topic probably...

CHRiTTeR
03-10-2015, 11:34
Ok so they dont have any tech support?

Do I really have to return the game for something like this?

konnos
03-10-2015, 11:53
All these things you have given us are implying there is nothing actually wrong, except for your TV/monitor. It works on your brother's and so it should work for you too. So that means your monitor is not giving out a 60Hz signal and sounds like it also is not giving you the resolution you think either. Is this a TV or a PC monitor and what model? Look in the TV menu settings and see the signals, most of them have option of what to show, there you will most likely see the problem. If the problem continued with your brother's monitor then it would be your PC problem, but that is not the case and so you must look at the screen for the fix.

Oh by the way, it doesn't matter what steam or other programs say your fps is. If your monitor is outputting at 24Hz you re not gonna be able to see 60fps even if steam is telling you so.

KAMPFBIBER81
06-10-2015, 08:09
I do have the same problem with my triple screens. I can only select 50 or 59 HZ while it works for every other game. No vsync, latest AMD drivers. I've deleted the graphics config file and profile.sav, still the same problem.

Morgan Henstridge
07-10-2015, 06:36
I believe the 59hz is a windows thing. I believe Windows 7 reports 60hz as 59.94, this is why a lot of games on newer OS show 59 instead of 60 in the good old days, as they are not rounding 59.94 up to show as 60hz. And easier to just show the reported value as a whole number so they dont show the .94 when displaying 59hz in the menus to select. Some games will detect 59 and show you the option for 60 though, but its really the same thing.

edit - usually it is games that are capped at 30fps or 60fps (Batman Arkham knight for example) that will show the 60hz option, but games detecting it from Windows show 59.

I know on the exact same hardware on my PC, some games show 59 and some show 60. I dont have any issues with either.

KAMPFBIBER81
08-10-2015, 10:35
I don't think so (but I can be wrong ofc). I had the 59HZ issue also with Win8.1, now with Win10. Actually, during WMD it worked (with 60HZ) but I think that changed sometimes during the AMD optimizations phase.

KAMPFBIBER81
09-10-2015, 07:43
I had some free time yesterday and I decided to completely reset my Win10 installation and I've reinstalled all my drivers & games from scratch. Oh wonder... the 60HZ option is back.

I really don't know, but in the end I suspect it must be something with AMD Triple Screen configuration. I don't think it's (monitor) hardware-dependent. But this is just a wild guess.

konnos
09-10-2015, 13:00
That is very weird indeed.

CHRiTTeR
09-10-2015, 15:46
All these things you have given us are implying there is nothing actually wrong, except for your TV/monitor.

You must've missed the part where i say I have absolutely no problem with any other game on my setup... So project cars is doing something really wonky in terms of the vsync.


It works on your brother's and so it should work for you too. So that means your monitor is not giving out a 60Hz signal and sounds like it also is not giving you the resolution you think either. Is this a TV or a PC monitor and what model? Look in the TV menu settings and see the signals, most of them have option of what to show, there you will most likely see the problem. If the problem continued with your brother's monitor then it would be your PC problem, but that is not the case and so you must look at the screen for the fix.

It's a PC monitor which supports 1080p @ 60hz
Like I stayed no problem with any other game/app
Its a Illama ProLite x2483HSU look it up.


Oh by the way, it doesn't matter what steam or other programs say your fps is. If your monitor is outputting at 24Hz you re not gonna be able to see 60fps even if steam is telling you so.
I know, (i work allot with video for my work so I know what i'm talking about).

I dont care if im' getting 59, 59.94 or 60hz (no one can notice the difference between them anyway) but its the image quality thats all bad because there's something wonky going on

Its not stuttering or anything... It looks like my monitor is getting a interlaced signal and it's getting de-interlaced really bad or something.
Which is verry weid because nowhere i have set up any output to be interlaced (i hate that ancient crap).
And yes my monitor does support full HD progressive...

It makes absolutely no sense that the problem would be my monitor. Since it seems to work just fine when i set the multiple display mode (in windows to) duplicate.
And, again, I only have this problem with project cars