PDA

View Full Version : Fanatec CSR won't connect to PS4



elie774
10-12-2015, 03:49
Hello, I am in dire need to get my Fanatec CSR wheel connected to my PS4. I have updated the firmware and followed all the youtube videos I can find. Can someone give me baby step instruction on how to do this. I had it connected to an Xbox360 and it worked without any problems. What I have done so far: updated firmware, turn on wheel and set in to PS3 mode, turn on PS4, load game, try to enter game by hitting X on wheel, no response. Tried the previous in the PC mode (still didn't work) What am I missing?

Thank You

Sum Dixon-Ear
10-12-2015, 12:04
You need to launch the game from the dashboard with the controller, then wait for the actual Project CARS 'Start' screen to load. Then switch the wheel to PC mode and start the game with the corresponding 'X' button on the wheel rim.

That should work, good luck!

2stains
10-12-2015, 12:49
I turn on ps4 , turn on wheel , start game from ps dash with contoller put wheel into pc mode ( Project cars mode )the wheel does 2 little vibration noises and the lights on my rim illuminate . Game loads to pcars start screen and i press x on the wheel .
Oingo boingo ready to race.

elie774
10-12-2015, 15:29
I have tried that sequence and no luck. Are there any other tests I can do? Like try it with another game? I appreciate any little bit of advice like "did you plug in the USB cable?"

Thank you

Sankyo
10-12-2015, 15:40
Are you sure it's in PS3 mode (dot on the LCD showing)?

elie774
10-12-2015, 15:47
yes the dot is showing on the LCD. Keep the questions coming I appreciate them.

Sum Dixon-Ear
10-12-2015, 17:17
Remco, do you put the CSR into PS3 or PC mode for PCARS on PS4?

I thought the other Fanatec wheels needed to be in PC mode to operate, I may well be mistaken though... I often am!

elie774
10-12-2015, 17:29
I have tried both PC and PS3 modes neither one works.

Sum Dixon-Ear
10-12-2015, 17:42
Can you connect it to a PC and test the wheel via the Fanatec drivers?

elie774
10-12-2015, 17:49
I updated the firmware and that needed a driver to connect so I guess the answer would be yes ????? Correct me if I am wrong

Sum Dixon-Ear
10-12-2015, 18:01
Can you test to see whether the wheel is functioning properly via the drivers? There is a test tab which will show whether everything is working as it should be.

elie774
10-12-2015, 19:50
I will give that a try when I get home from work. Can you give me a brief description of how its done. Thank you.

Sum Dixon-Ear
10-12-2015, 21:41
With the drivers installed, plug your wheel in with the USB cable, power it on and connect it in PC mode. Then double click the Fanatec 'F' icon on your desktop, select your wheel, and then 'Properties' (I think, it's been a while since I last did it) and that will open the driver interface window, the first tab on the window is 'Function Test' and that will let you see if all/any functions (wheel rotation, buttons, D-pad, tuning display, FFB & vibration motors) are working correctly via USB.

elie774
10-12-2015, 22:45
I downloaded the driver and the wheel connects without a problem. I turn the wheel and it shows up on my laptop, the buttons work and the peddles work. The PS4 is brand new I have never owned one before so I think I am missing something simple.

elie774
10-12-2015, 23:10
I just turned to PS4 to test the setup again and when I ran Project Cars it went into Application Update. I think it is updating the game maybe it will work after that is done (37 hours left)

elie774
11-12-2015, 00:55
got it working !!!!!!! thank you everyone for your help. I had to update the game to version 6 then it connected no problem. I knew it would be a stupid fix. Thats what i get for being old and out of touch . Thanks again