PDA

View Full Version : GTX 1080 Throttling to Base Clock in Project Cars VR



MuddyPaws73
09-07-2016, 00:06
Is anyone else experiencing their GTX 1080 throttled back to base clock setting when running PCars in Steam VR?

I've read a few similar cases on the steam discussion boards and one person had success going back to driver 368.39. I reverted back to 368.39, but that did not solve the issue for me. Also, this is not an issue when running PCars outside of VR (at least for me).

Any suggestions?

(I'm using the Vive Headset)

Sampo
09-07-2016, 01:41
Have you tried to set the Power Management Mode in the driver to 'Adaptive' or 'Prefer maximum performance' ?

The new default setting 'Optimal power' in the drivers seems to cause some hiccups.

MuddyPaws73
09-07-2016, 11:46
So, a little more testing suggests that in order to get 90 FPS, the visual settings have to be pretty much at low. These settings appear to be not very demanding on the gtx 1080 and it throttle backs to base clock settings.

If you raise the visual settings, it appears it puts more of a demand on the gpu and the clock timing raises above base. However, it also lowers the fps to 45 (reprojection).

mr_belowski
09-07-2016, 13:07
What are you using to measure the clock speed? And does using the high performance power management option make any difference? How about adding the "renderTargetMultiplier" : 2 to the steamvr.settings file to force super sampling?

MuddyPaws73
09-07-2016, 16:11
I'm using Afterburner and sending everything to a log file. There are so many variables its almost unmanageable, with the variations in visual settings, tracks, number of cars, weather, etc.

Seelenkrank
09-07-2016, 17:16
try to optimise your fans in the case.
maybe the heat cant come out and heating up the inside, then the GPU clocks down really fast.
i got an 140mm fan on the side blowing inside and 2x 120mm on he top blowing outside.
so the GPU can run all the time with its max clockspeed.

mr_belowski
09-07-2016, 17:55
Hmm... I'll try that log thing too, see what mischief my 1080 is up to. I have an almost identical setup to yours, but an i5 4690k instead of an i7

MuddyPaws73
09-07-2016, 20:32
The GPU never gets above 60 C, even during OC operation.

I would be very interested in your results.

Ramjet
10-07-2016, 08:37
My Gpu is running 68 to 72 deg C when boosting @ upto 2126mhz - Giga 1080 G1 Gaming - but I think the Optimal power setting does throttle it back. Seems to be only the latest Nvidia driver update since it started to do this as it has run for hours at those temps before with no issues. Measured using GPU-Z.

QUESTION @mrbelowski What is the file to edit to get the pixel density to stay at 2.0 ? I have been manually setting it using the Oculus Debug Tool but would be nice to set it permanently... actually I have it set to 1.7 and force SMAA on at medium.

mr_belowski
10-07-2016, 09:11
Righty, just tested and with the 368.39 driver it all works as it should - boost clock activates in game and stays active. I didn't install the newer driver, perhaps it's done something weird.

The render target multiplier is in some steam folder, in text file steamvr.settings, but it only applies to vive

mr_belowski
10-07-2016, 11:23
Bit more info from my testing.. using the renderTargetMultiplier hack set to 2 gives horrible judder even with low settings and no AA. Removing this entirely allows me to use either low settings with no AA and always 90fps (looks crap) or med - high settings with 4x AA and constant reprojection (but no stuttering).

I think the latter is better, as reprojection doesn't really bother me. Still, seems like pcars doesn't play particularly nicely with vive and never looks as crisp as assetto corsa.

My card's clock speed is correctly set to boost speed in all cases.

I know the devs were looking into supporting nvidia SMP which might give 1080/1070 owners a nice boost - any know if there's been an progress on this?

MuddyPaws73
11-07-2016, 20:23
So, I've been doing some more testing and the latest driver from Nvidia does appear to cause the GPU to drop to base clock speed at times on my system. I reverted back to version 368.39 and haven't had the issue since.


Bit more info from my testing.. using the renderTargetMultiplier hack set to 2 gives horrible judder even with low settings and no AA. Removing this entirely allows me to use either low settings with no AA and always 90fps (looks crap) or med - high settings with 4x AA and constant reprojection (but no stuttering).

I pretty much have the same settings and I'm "happy" with using reprojection too.


I have added two additional setting based on the "Optimal Settings" for Project Cars VR in the Nvidia GeForce Experience app. They are FXAA and Multi-Frame Sampled Anti-aliasing accessed through the 3D settings in the Nvidia Control panel (see below).

I'll have to say, the graphics are pretty good. Certainly not as good as regular PCars, but so much better than the default. Very playable to me...

234967

mr_belowski
11-07-2016, 20:50
do those two AA settings actually make a difference to the VR graphics then?

Starting to get accustomed to the VR graphics now. Running with shadows 'off' makes things a lot smoother - a worthwhile trade off IMO, cos I can now race in the rain. Which is, of course, awesome :).

Very poor show from Nvidia on this latest driver :(

MuddyPaws73
11-07-2016, 21:46
do those two AA settings actually make a difference to the VR graphics then? :(

Very good question. The short answer is I don't really know. I've got the graphics where I'm really enjoying it right now and I just want to play ;).

I'll try to determine at some point if they are doing any good. I was wondering how they reacted with the AA setting of DS2X in the game, which I'm also using.

MuddyPaws73
12-07-2016, 23:41
Just an update for others who may be experiencing the same issue...

Tom's Hardware reported the following...

"Nvidia released GeForce Game Ready Driver 368.69 on July 6 in preparation for the impending release of Codemasters’ Dirt Rally VR update. Though this driver is meant to prepare your system for a VR game, the update (rather ironically) broke the ability for the GTX 1080 to put its impressive boost clock to work. We tested the driver to see if the Vive display port issue was corrected, but we had no reason to monitor boost clocks at the time.

The Heaven benchmark test demonstrated that the boost clock for both cards worked as it should, but as soon as we started SteamVR, things changed. The clock speed of the 1080 immediately jumped from its idle clock (close to 250 MHz) to the base clock of 1,696 MHz. The Oculus Home software had a similar reaction, but this happened only when the Rift was off. When the proximity sensor detects something and the displays turn on, the boost jumps to 1,696MHz and remains there."

Here's a link to the article Nvidia GeForce GTX 1080 Doesn’t Boost In VR With The Latest Game Ready Driver (Update) (http://www.tomshardware.com/news/nvidia-gtx-1080-vr-boost,32235.html)

Nvidia is suppose to release an update soon...

mr_belowski
13-07-2016, 05:46
I wonder what they'll break this time. "VR ready" indeed...

MrPix
13-07-2016, 09:21
Wow, I noticed this yesterday and wondered what had happened. Great to hear it's not just me. Looking forward to an updated driver ASAP.

jimortality
26-07-2016, 18:27
You know the ingame fXAA and SMAA settings, mine are locked for some reason so I can only use the dsx settings. Anyone know about this please? thanks

Schadows
26-07-2016, 19:26
it's the same for everyone. not sure if fiddling with the configuration files is helping or not.

MuddyPaws73
26-07-2016, 21:09
You know the ingame fXAA and SMAA settings, mine are locked for some reason so I can only use the dsx settings. Anyone know about this please? thanks

This is from a previous post I made...

"I been continuing to experiment with the settings in hopes of getting better resolution with the Vive in PCars VR. It appears setting the FXAA and SMAA option in the Nvidia Control Panel under 3D Settings didn't have any noticeable effect.

In the file graphicsconfigopenvrdx11.xml changing <prop name="FXAA" fxaa="3"> and <prop name="SMAA" smaa="1"> sets the in game locked properties FXAA and SMAA"


You may want to make a backup of the graphicsconfigopenvrdx11.xml file before making any changes.

I would be interested in what you think of the difference, if you decide to change those settings.

jimortality
26-07-2016, 21:52
This is from a previous post I made...

"I been continuing to experiment with the settings in hopes of getting better resolution with the Vive in PCars VR. It appears setting the FXAA and SMAA option in the Nvidia Control Panel under 3D Settings didn't have any noticeable effect.

In the file graphicsconfigopenvrdx11.xml changing <prop name="FXAA" fxaa="3"> and <prop name="SMAA" smaa="1"> sets the in game locked properties FXAA and SMAA"


You may want to make a backup of the graphicsconfigopenvrdx11.xml file before making any changes.

I would be interested in what you think of the difference, if you decide to change those settings.

What would I change them to? What's the highest fxaa setting is it 5?

jimortality
26-07-2016, 22:19
Yeah it only goes to 3 which is in game high. I noticed a difference though. I'm struggling with Brno as that seems one of the worse tracks and it was blurry as hell but with debug at 1.6 as aa dsm and fxaa at high, it made this track much better.