PDA

View Full Version : [ANSWERED] GPU capped in Rift VR Mode?



PCDriver
14-12-2016, 16:59
I can't get over 60% GPU (980ti SC) usage/utilization in pCARS VR Mode with the Rift CV1. Anybody else? Does pCARS have the GPU capped in VR Mode? Fix?

I can hit 99% usage with all other VR games including DiRT Rally and outside of VR mode with pCARS. I'm using MSI Afterburner to monitor rates. CPU(s) stays mostly in the 70%'s so I don't see a bottleneck there.

Mahjik
14-12-2016, 17:46
What are your in-game graphic settings?

PCDriver
14-12-2016, 18:46
What are your in-game graphic settings?

I have tried many settings with little change in GPU usage. Ultimately I settled on settings that keep me at 90 FPS with close to zero Performance Headroom in the Oculus Debug Tool HUD.

Do you recommend I try something specific? Anything over 1 in the Display Pixel Overide tanks my headroom.

Mahjik
15-12-2016, 03:07
Do you have settings on "Ultra" currently?

PCDriver
15-12-2016, 08:34
I have since set to Ultra and 1.3 Display Pixels and was able to keep the GPU in the 80%'s. So that answers the capped question. This, however, lowered my FPS to 45 and -100 overhead.

The problem as I see it now is that I can't increase my settings to take advantage of the GPU before it starts dropping frames. In other words, I start dropping frames at 60% GPU utilization.

Ultimately, what I've learned is that it isn't the resolution that's bothering me, it is the SDE which is far worse than the pCARS YouTube video's portray. I guess they aren't looking directly through the Oculus lens. I can count pixels on car bumpers in the distance no matter the resolution/settings. I don't think I'll return it at this point but it is disappointing and I would caution anyone about to buy a HMD to try it first or search YouTube videos for "Oculus screen door effect".

Reiche
15-12-2016, 09:34
Seems like ASW is hitting in. Try to press the left CTRL button + 1 on the numpad to disable it. Should give you back a bigger GPU load ;)
How many fps do you get? I assume 45 instead of 90..

I was confused by this some time ago, check here: http://forum.projectcarsgame.com/showthread.php?43740-Oculus-Rift-CV1-Discussion&p=1313577&viewfull=1#post1313577 and following

Another thread with a similiar issue (to me) was here: http://forum.projectcarsgame.com/showthread.php?49432-Help-only-45-fps-oculus-rift



To mods: Would it be possible to make some information about that behaviour sticky? From what I read, ASW is really confusing a lot of users claiming they can no longer hit ~90 fps but are locked to 45fps / are no longer getting heavy GPU load?

PCDriver
15-12-2016, 10:09
Thanks Reiche, it does look like that is what is happening even though I have ASW set to disabled in the debug tool. I'll have to do some testing but my first thought was, how does this affect debug "Application Frames Dropped" and the "Performance Headroom" calculation. Perhaps the dropped frames at 45 are actually being added back in but not counted thus allowing for higher detail settings for many.

Unfortunately, I don't think this will help most of us who are spending hours tweaking settings in the futile attempt to improve the inescapable SDE.

PCDriver
15-12-2016, 12:48
Here's what I experienced:

AWS OFF - High/Medium settings. 80 FPS in traffic, 90 FPS solo. GPU 99% usage
AWS Auto - Ultra/High settings with 1.2 Pixel Override. A steady 45 FPS. GPU 85% usage

I couldn't see much difference between them other than AWS spared my GPU a 15% workload. So for now, I'm ignoring frames dropped and going with AWS Auto getting 45 FPS. I think that's a good place for people to start and adjust settings upward until their GPU hits 85% (or whatever they are comfortable with). The irony is that that is about where pCars sets you up when you first start the game.

Thanks for your help guys. Now I've got to go figure out how to drive :)