PDA

View Full Version : (PC) Xbox 360 controller stops working



Frotang
26-06-2017, 22:30
Hello,

I've been using Xbox 360 controllers to play many PC games for the past 7 years without any issues. I have all the updated drivers and have read any and all previous information for anything even remotely close to the problem I'm having and attempted to implement the fixes with no success. Here is my exact issue.

When starting the game I can use my controller fine and go around the menu and even race in single player modes without problems. My issue occurs when I choose the online server browse menu option, this is when my controller fails and will not work again until I restart the game. If I join a server with my mouse I am still not able to use the controller in the game lobby, nor will my controller work to control the car if I join the race. I have tried alt+tabbing, plug and unplug, activate / deactivate steam overlay as methods to try and get the controller to work in game again when this occurs, none of that works. Now this doesn't happen every time, sometimes I can start the game and actually select servers with the controller, join a game and race no problem. But eventually the controller will stop working on the server browser screen when I'm finding a new game or it will stop working after a race finishes and I'm sent back to the game lobby. The only way to get it to work again is to restart the game.

I have tried both my Wireless Xbox 360 adapter with controller and my wired Xbox 360 controller, each with the most up to date drivers. Both experience the exact same issues with nothing solving it but a restart. I know for a fact my controller is still connected and working when this problem occurs as I have done a test and launched other games simultaneously with PCars and my controller will work in my other game (Rocket League, GTA, Dirt 3) but will not work in PCars. I'm 100% certain everything on my end is in order and that there is something wrong with the game and that it's specifically tied with the online / multiplayer option.

This is becoming increasingly frustrating as I've just purchased this game and have loved every moment I've been able to play but this persisting issue is really having an impact on the amount of time I get to enjoy the game. I hope somebody can help me.


Thanks.

Frotang
28-06-2017, 13:07
Damn, nobody with any possible solutions out there? This is so frustrating.

Mahjik
28-06-2017, 13:12
You might list your specs (i.e. what you are using to play)... Are you doing anything like using Steam's Big Picture mode? Details like these may be able to give people some ideas to suggest. I can't say it's anything I've ever experienced.

Frotang
28-06-2017, 22:47
Specs:
i7-2600 - 3.4GHz
AMD Radeon R9 200 series - 4gb
8gb Ram
1920x1080 (144Hz)
Windows 7 64-bit


Additional things I've tried:
Changing control setting from Xbox one to Custom controller - made no difference
After controller stops working I've tried going into controller settings and attempted to change controller type or change controller mappings - still will not register controller inputs

BullWinkle
29-06-2017, 11:05
Have you tried going into Steam's Big Picture Mode, >settings >controllers and remove any controllers listed?
Something else to try is deleting or renaming the default.sav file located here:
C:\Program Files (x86)\Steam\userdata\YourID\234630\local\project cars\profiles (you will loose your career/vehicle setups etc doing this,,like a fresh install.
And what do you use for Anti Virus? Try putting the Steam folder and Project Cars folder in Your Documents in the exception list of your AV.

Frotang
29-06-2017, 16:29
I've never even launched big picture mode before but I'll check that out after work. This problem started from the first time I launched the game, I mean I can rename the file but I'm not sure what that's actually accomplishing, I'll give it a shot though. I don't use any Anti Virus.

I've found another person on my reddit post about this who experiences the exact same problem with their Xbox 360 controller and they've also not found a solution yet.

Frotang
14-07-2017, 19:35
UPDATE: I bought an Xbox one controller and thought that had solved the issue, however after applying a custom tuning setup to my car today (not sure if related) the issue is happening again. controller works fine in menus and in single player but will stop working once I enter the online server browser screen. This is beyond infuriating......

Mahjik
14-07-2017, 19:39
Are you suggesting that the controller worked online without a custom tune?

Mahjik
14-07-2017, 21:40
Might not be a bad idea to check this out:

http://forum.projectcarsgame.com/showthread.php?50793-Thrustmaster-TX-not-working-in-game&p=1344723&viewfull=1#post1344723

Frotang
19-07-2017, 17:07
It seems like I have good days and bad. So the first day I used the new controller I never had an issue. But the next time I tried to play it happened. Had it happen 4 times yesterday where I had to restart to get it to work. It's so weird. Again, only stops working in online server select screen and then it won't work for anything anymore until I restart.