PDA

View Full Version : G29 not working [PC]



fallam
13-07-2017, 11:59
It won't calibrate at all, when I go into calibration on seperate pedals + combined they just won't work. I've updated drivers, integrified game cache, everything. What's going on? Tried both in PS3 and pS4 settings. This is for PC btw

Invincible
13-07-2017, 12:03
Which Windows? Have you installed the Logitech profiler?

Majestic121
13-07-2017, 18:32
I have the same issue, I'm running Win10 and no Logitech Profiler installed.
Device Manager shows all OK, the Logitech Gaming Software is version LGS_8.94.104_x64_Logitech.
Reinstalled Project Cars and still nothing. The LGS does show input on the Test dialog and also tried both PS3 and PS4 version. Nvidia drivers are up to date.

Neither the buttons or steering is being recognised.

Invincible
13-07-2017, 19:33
Weird. If my G29 acts up, it doesn't work in Windows eiter. Tried a different USB Port?

dault3883
13-07-2017, 20:11
windows just did a major update try reprogramming all the functions on wheel and pedals even if they are already assigned where they should be that usually works for me and re calibrate the wheel and i use Logitech profiler

fallam
14-07-2017, 06:03
Still not working :( Pedals work but steering wheel is dud. Might request a refund, very disappointed!

Invincible
14-07-2017, 06:20
Does the center spring work under windows? I mean, is there a noticeable resistance from the motor if you try to turn the wheel in windows (which means you can't easily turn it easily with one finger)? If not, something's iffy with your wheel and you might try to reinstall the gaming software. Make sure you also delete the drivers in the device management.
If it resists in windows, see if it looses that resistance once you fire up pcars.

Willie2Wacker
14-07-2017, 08:53
I have the same problem with the G29. After first installation it worked fine as expected. The last weeks I was to busy to play however all w10 updates has been installed.
In the startup register, HW & printer, the G29 is listed and it is possible to test the wheel (wheel axis 0 -65356 and pedals ( 0 -255) and to calibrate including all function buttons. That means the USB controller has a proper connection to the G29.

After starting project cars, the G29 wheel itself is still alive (force feedback, green light for the PS4 button is on). But I can't calibrate it in the setup display, neither the wheel nor the pedals.
:(:mad:
The LGS software is the latest version 8.94.108, just downloaded and installed.

Thanks for help

Invincible
14-07-2017, 09:00
nor the pedals.
The LGS software is the latest version 8.94.108, just downloaded and installed.

Thanks for help



Have you properly deinstalled the old G29 drivers before re-installing the LGS software? Also, please make sure to reboot between de- and reinstallation with the wheel NOT plugged in.
Always worked for me. W10 updates with the G29 are a huge PITA. But when it happens, it does affect all games, not only Project Cars. At least on my side.

Willie2Wacker
14-07-2017, 10:49
Thanks for the quick answer.

I have repeated very carefully the steps to to de- and to re-install the LGS. Now I'm pretty sure to have it proper installed. But no success at all !

Next step:
To check the proper installation of project CARS I used my USB connected keyboard, worked properly. Both, keyboard and G29 are using the internal USB hub, that means there should be no difference between the USB keyboard signals and the the USB G29 signals.

At the moment, I have no idea how to fix it.

Invincible
14-07-2017, 11:23
Thanks for the quick answer.

I have repeated very carefully the steps to to de- and to re-install the LGS. Now I'm pretty sure to have it proper installed. But no success at all !

Next step:
To check the proper installation of project CARS I used my USB connected keyboard, worked properly. Both, keyboard and G29 are using the internal USB hub, that means there should be no difference between the USB keyboard signals and the the USB G29 signals.

At the moment, I have no idea how to fix it.

What port is it? USB 3.0 or even 3.1? If so, please use a 2.0 port as the G29 is known to act up with anything higher than 2.0.

Willie2Wacker
14-07-2017, 19:24
Yes, I'm using definitely a 2.0 port, because of the known incompatibility of the G29 with higher versions.

Willie2Wacker
15-07-2017, 23:46
After complete new download of project cars from steam, took more then 2 hours :( arggh and considering the advice that the wheel was NOT plugged until the game was started,it worked all of a sudden.

To be honest, I can't really something about the reason, but let's wait and see if the installation is now stable.

Thank you for your answers and advices, because it helps to discuss a problem with other people.

doncarlos
20-07-2017, 21:17
Just did a couple of laps at Nordschleife with my G29 to test it for you. I'm on win10 with latest updates, also with the latest Logitech gaming software, latest PCars version. The wheel plugged in the USB3 port on my mobo. Everything worked fine, calibration, FFB. Some months ago I had problems with the wheel and PCars communication, I had to re-calibrate, and re-assign the buttons every time I started PCars, but it went away...

dault3883
20-07-2017, 21:31
Just did a couple of laps at Nordschleife with my G29 to test it for you. I'm on win10 with latest updates, also with the latest Logitech gaming software, latest PCars version. The wheel plugged in the USB3 port on my mobo. Everything worked fine, calibration, FFB. Some months ago I had problems with the wheel and PCars communication, I had to re-calibrate, and re-assign the buttons every time I started PCars, but it went away...

it was probably when windows was doing a series of major updates i had the same problem every time a major update on windows happens i have to recalibrate and re assign all buttons its annoying but what you gonna do...at least it promotes button memorization LOL