PDA

View Full Version : Game crash - Exception Access Violation



sten308
16-07-2017, 13:21
Hi

For some time ago. I start getting these "Exception Access Violation" errors when driving free practice and online.
I have tested HW performance of graphic and RAM. All OK.
I then reinstalled Windows 10, graphic driver, Steam and PCars. And nothing more
Still getting the error.
It appear at random spots. Navigating in menu, during load of game, during load of track, during driving free practice

The message is always:
Unhandled exception trapped. EXCEPTION_ACCESS_VIOLATION at 0x40dfa67b. Reading from Address 0x00000000. Thread 0x000022d8
Build SMSARI.20161118.1246.BLDA000

The Thread address changes from crash to crash, but the remaining are always the same. The above address is a crash during load of track.

I have tried a lot of things regarding version of graphic driver, Logitech driver, disable Steam overlay, settings in game on very low, 32bit or 64bit versions etc, but nothing helps.
I hope that the log files (a crash during load of track) and below HW configuration can give some hints to get the game running stable again.
I dont know how to attach the log file - Please advice

Appriciate any help to get this wonderfull game running again.

PC spec:
WHEEL: Logitech G25 Racing Wheel USB
SSD: Samsung 840 EVO 250G
OS: Windows 10 Pro 64-bit
Processor: Intel(R) Core(TM) i5-4440 CPU 3.10GHz (4 CPUs), ~3.1GHz
Memory: 8192MB RAM
Available OS Memory: 8132MB RAM
DirectX Version: DirectX 12
GPU: NVIDIA GeForce GTX 750 Ti

Mad Al
16-07-2017, 14:02
If you are still getting them after a complete clean install of windows, then the most likely issue is something slightly marginal in your hardware.. (especially if it appears to happen at completely random times)

If you didn't do a complete wipe and install of everything so you started a clean profile, then it might be worth renaming the profile and seeing if that helps (it resets everything to how it was when you first fire up the game)

<Steam install folder>\userdata\<Your Steam ID>\234630\local\project cars\profiles\default.sav

just try renaming that file to default.old

If that doesn't help a few logs my throw some light on things

sten308
16-07-2017, 15:56
If you are still getting them after a complete clean install of windows, then the most likely issue is something slightly marginal in your hardware.. (especially if it appears to happen at completely random times)

If you didn't do a complete wipe and install of everything so you started a clean profile, then it might be worth renaming the profile and seeing if that helps (it resets everything to how it was when you first fire up the game)

<Steam install folder>\userdata\<Your Steam ID>\234630\local\project cars\profiles\default.sav

just try renaming that file to default.old

If that doesn't help a few logs my throw some light on things

Thanks for swift reply!
I did a complete wipe and install of everything.
When now repeating making a new profile, the game did crash during the audible introduction of options...
Can I submit some log files?

Mad Al
16-07-2017, 20:26
Thanks for swift reply!
I did a complete wipe and install of everything.
When now repeating making a new profile, the game did crash during the audible introduction of options...
Can I submit some log files?

Throw them onto dropbox, googledrive or onedrive and post a link here (you will have to be a little creative with the link, as until you have 5 posts, you can't add attachments here or post links)
You just need to zip up some of the folders from "This PC\Documents\Project CARS\dbgSession"
They are date and time stamped.. just make sure to include ones where you actually crashed out

sten308
16-07-2017, 22:18
Okay

sten308
16-07-2017, 22:20
Log of a crash during load of track:
https:BACKSLASHBACKSLASHdrive.google.com/file/d/0BxG3Mwxd42gYSHhZbFV1anVZUjA/view?usp=sharing

sten308
16-07-2017, 22:21
Log of a crash during load of track:
https://drive.google.com/file/d/0BxG3Mwxd42gYSHhZbFV1anVZUjA/view?usp=sharing

sten308
16-07-2017, 22:31
Log of crash during navigation in menues - before any load of track:
https://drive.google.com/file/d/0BxG3Mwxd42gYWkdPOEUybE45Wlk/view?usp=sharing

sten308
16-07-2017, 22:38
Log of crash after 20sec of driving:
https://drive.google.com/file/d/0BxG3Mwxd42gYRmRQM3ozN0QwQ1U/view?usp=sharing

Crash=Graphic freeze, but audio continue and control of the car is still possible (can hear throttle/breaking)

Mad Al
16-07-2017, 23:04
OK common bit seems to be the uxtheme problem.. see end of this post and see if that helps

http://forum.projectcarsgame.com/showthread.php?21981-Unhandled-Exception-Trapped-Unable-to-Play&p=1055076&viewfull=1#post1055076

sublimelime
17-07-2017, 05:59
i have the same issue. Are you suspecting uxtheme because it's in the display stack section of the "mwldumpsessionfnl.0x000008dc.dmp.txt" file? Are you able to read the dump file and find any more information? It should point to the line of code where the crash occurred.

I'm going to try to take a full dump using procdump.exe and wait for the exception to occur. I've also began experiencing this issue and I can play other games without issue (GTA V, Forza Horizon).

I think this problem is beyond simple troubleshooting. I suspect a problem in the code or some sort of handling is needed. When I open the dump in visual studio I see this:

Dump Summary
------------
Last Write Time: 7/16/2017 5:01:52 PM
Process Name: pCARS64.exe : C:\Program Files (x86)\Steam\steamapps\common\pCars\pCARS64.exe
Process Architecture: x64
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

sublimelime
17-07-2017, 07:04
i have the same issue. Are you suspecting uxtheme because it's in the display stack section of the "mwldumpsessionfnl.0x000008dc.dmp.txt" file? Are you able to read the dump file and find any more information? It should point to the line of code where the crash occurred.

I'm going to try to take a full dump using procdump.exe and wait for the exception to occur. I've also began experiencing this issue and I can play other games without issue (GTA V, Forza Horizon).

I think this problem is beyond simple troubleshooting. I suspect a problem in the code or some sort of handling is needed. When I open the dump in visual studio I see this:

Dump Summary
------------
Last Write Time: 7/16/2017 5:01:52 PM
Process Name: pCARS64.exe : C:\Program Files (x86)\Steam\steamapps\common\pCars\pCARS64.exe
Process Architecture: x64
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

procdump didn't help, as when pc crashed my system blue screened. I had a nice 17mb dump file, but it didn't seem to help much. Instead, I re-opened one of the games mini-dumps with windbg and see this:

FOLLOWUP_IP:
gameoverlayrenderer64!VulkanSteamOverlayProcessCapturedFrame+14a36
00007ffb`b7f5b956 8b4b18 mov ecx,dword ptr [rbx+18h]


Now I'm wondering if the steam overlay is causing the issue. I'll try disabling it and see if it helps.

sublimelime
17-07-2017, 07:22
procdump didn't help, as when pc crashed my system blue screened. I had a nice 17mb dump file, but it didn't seem to help much. Instead, I re-opened one of the games mini-dumps with windbg and see this:

FOLLOWUP_IP:
gameoverlayrenderer64!VulkanSteamOverlayProcessCapturedFrame+14a36
00007ffb`b7f5b956 8b4b18 mov ecx,dword ptr [rbx+18h]


Now I'm wondering if the steam overlay is causing the issue. I'll try disabling it and see if it helps.

didn't help, crashed again.

FOLLOWUP_IP:
nvwgf2umx!NVAPI_Thunk+34301
00007fff`d9014811 488b5518 mov rdx,qword ptr [rbp+18h]

different crash this time it seems.

sten308
17-07-2017, 08:36
OK common bit seems to be the uxtheme problem.. see end of this post and see if that helps

http://forum.projectcarsgame.com/showthread.php?21981-Unhandled-Exception-Trapped-Unable-to-Play&p=1055076&viewfull=1#post1055076


I changed to "adjust for best performance", but still crash after 20-30sec of drive.
Log:
https://drive.google.com/file/d/0BxG3Mwxd42gYX3V6UFNNbDZubkE/view?usp=sharing

Mad Al
17-07-2017, 12:00
If you have ANY overlays, turn them off... that includes MSI afterburner, Steam, Geforce etc. etc.

Whilst loads of people can run without any issues with some (or in some cases many) overlays.. it really does seem some people have some massive issues with them on

sublimelime
17-07-2017, 18:13
If you have ANY overlays, turn them off... that includes MSI afterburner, Steam, Geforce etc. etc.

Whilst loads of people can run without any issues with some (or in some cases many) overlays.. it really does seem some people have some massive issues with them on

without looking at the exception from a dump file you don't really know. I'm really surprised the developers haven't with all the process dumps that have been uploaded. The last one I uploaded seems to indicate possible bug in the project cars code. In which case, no matter what we do, we cannot "fix" the bug by disabling overlays and other such nonsense. It simply has to be fixed by the developers.

Mahjik
17-07-2017, 19:17
It simply has to be fixed by the developers.

It's possible there is an event handling problem that only affects you which could be addressed in a code change. No doubt. However, it seems unlikely to be solely a Project CARS problem if only a very small minority are experiencing the issue. Typically when there is a major software bug, everyone is affected. This would more point back to something specific with those individual machines and/or builds if it's not happening for everyone (or even a large majority of the user population).

Mad Al
17-07-2017, 19:35
The only time I ever had exception errors was during development when specific bugs were introduced through code issues (and rapidly fixed), I've not had a single one since release and I do run Steam overlay (and sometimes Afterburner and Shadowplay too)... and I've played a few hours over the years and across something around 9 different hardware builds and using XP, Vista (32 bit), 7 64 bit (Pro and Home), 8 (32 and 64 bit), 8.1 (Pro 64 bit) and Windows 10 (Home and Pro, 64 bit). That includes going through upgrades from 7 to 8 to 10 on two machines as well as full fresh installs (and running a mix of AMD/Intel and NVidia hardware, from the bottom of the requirements barrel to top end)
As for examining code dumps, yes SMS have indeed seen plenty as you may have noticed the person who posted in the thread I linked to is actually the QA lead... and he definitely sent plenty of dumps up to the devs...

Roger Prynne
17-07-2017, 19:47
The only time I ever had exception errors was during development when specific bugs were introduced through code issues (and rapidly fixed), I've not had a single one since release and I do run Steam overlay (and sometimes Afterburner and Shadowplay too)

Same goes for me.

sublimelime
17-07-2017, 22:38
It's possible there is an event handling problem that only affects you which could be addressed in a code change. No doubt. However, it seems unlikely to be solely a Project CARS problem if only a very small minority are experiencing the issue. Typically when there is a major software bug, everyone is affected. This would more point back to something specific with those individual machines and/or builds if it's not happening for everyone (or even a large majority of the user population).

I'll try cleaning the driver software and reinstalling. I think I read on the other thread it's been tried already by others so who knows.

Mahjik
17-07-2017, 22:53
I'll try cleaning the driver software and reinstalling. I think I read on the other thread it's been tried already by others so who knows.

Just to state, I didn't say that would take care of the problem. I have no idea if it will or will not. But I am stating that it's not an issue everyone is having so it does appear to be localized (at least at the moment). The more information you can provide about your system, the more members here can assist.

I would start by posting all non-Microsoft applications you have starting up besides Steam (and any mods you may be using with pCARS).

sublimelime
17-07-2017, 22:56
Just to state, I didn't say that would take care of the problem. I have no idea if it will or will not. But I am stating that it's not an issue everyone is having so it does appear to be localized (at least at the moment). The more information you can provide about your system, the more members here can assist.

I would start by posting all non-Microsoft applications you have starting up besides Steam (and any mods you may be using with pCARS).

That isn't likely to help at all. I highly doubt there is a problem with other software. If there is a problem on my system it most likely some driver corruption or something, which doesn't sound likely to me but you never know.

Mahjik
17-07-2017, 23:00
That isn't likely to help at all. I highly doubt there is a problem with other software. If there is a problem on my system it most likely some driver corruption or something, which doesn't sound likely to me but you never know.

There are documented cases here on the forum of some of the OCD software as well as BitDefender and other software causing issues specifically with pCARS. When troubleshooting, it's always best to work on eliminating what is for sure not the problem so that way it leaves a more narrow scope to focus on...

sublimelime
17-07-2017, 23:13
There are documented cases here on the forum of some of the OCD software as well as BitDefender and other software causing issues specifically with pCARS. When troubleshooting, it's always best to work on eliminating what is for sure not the problem so that way it leaves a more narrow scope to focus on...

I don't have anything other than Steam, and I showed one dump that mentioned it and once disabled, I got another crash mentioning an nvidia driver. So who knows at this point.

sublimelime
05-01-2018, 17:07
i'm playing pc2 now. But just to update this thread the problem was the 16x PCI slot in the motherboard was bad. I replaced the mobo and my system is fully stable now.

HaaRaa_
08-08-2018, 23:41
If you are still getting them after a complete clean install of windows, then the most likely issue is something slightly marginal in your hardware.. (especially if it appears to happen at completely random times)

If you didn't do a complete wipe and install of everything so you started a clean profile, then it might be worth renaming the profile and seeing if that helps (it resets everything to how it was when you first fire up the game)

<Steam install folder>\userdata\<Your Steam ID>\234630\local\project cars\profiles\default.sav

just try renaming that file to default.old

If that doesn't help a few logs my throw some light on things

When I found file 234630 and enter in local it was empty

Mad Al
09-08-2018, 18:19
When I found file 234630 and enter in local it was empty

so you have so save file at all..

Would you like to explain what your issue is ?