PDA

View Full Version : [RESOLVED] OSW wheel not working with Project Cars



dpj463
16-07-2017, 23:04
I just received and set up my new OSW wheel from Simracingbay. It works fine in Assetto Corsa. I loaded up Project Cars and the game does not recognize the wheel at all.

I have Windows 10 64bit, Fanatec pedals, Fanatec shifter and handbrake.

Any help on how to set up the wheel or trouble shooting the problem would be appreciated.

Thanks

Mahjik
16-07-2017, 23:22
Can you describe more about what you mean about not recognizing the wheel? If you go into "EDIT ASSIGNMENTS", does it not register the wheel movements if you try to assign the steering axis?

dpj463
17-07-2017, 00:28
Can you describe more about what you mean about not recognizing the wheel? If you go into "EDIT ASSIGNMENTS", does it not register the wheel movements if you try to assign the steering axis?

I go into options
then click on controls.
Under Control Scheme I scroll through the different types of wheels, controllers, etc. My OSW is not listed.
I tried the Custom Wheel option
I click on edit assignments, then clicked on Steer Left. I moved my wheel left. after a seconds. A pop window comes up with" mutliple inputs were detected. No action was assigned"
What am I doing wrong? Are there settings elsewhere that I need to do first?

Mahjik
17-07-2017, 00:59
I click on edit assignments, then clicked on Steer Left. I moved my wheel left. after a seconds. A pop window comes up with" mutliple inputs were detected. No action was assigned"

What other devices do you have connected?

dpj463
17-07-2017, 12:03
What other devices do you have connected?

In addition to the Fanatec stuff mentioned above, I have
1 wireless keyboard/ mouse combo
1 Oculus Rift
2 Oculus sensors
1 USB 3 powered hub - fanatec shifter and fanatec pedals plugged in here
All the rest of the USB devices are plugged into the motherboard.

UPDATE:
On a whim, I used my old control scheme - Thrustmaster T150. under edit assignments, I got the left steer, right steer, and pedals to register. The shifter will not register. I was able to drive with an automatic transmission.

I wonder which wheel I should use under the control scheme section to get everything working properly?

Mad Al
17-07-2017, 12:42
Custom and make sure you don't have your shifter in gear... if it detects two inputs when you try to assign the steering, it thinks something else is also active (like an H shifter in gear for example)

finagle69
17-07-2017, 15:18
In addition to the Fanatec stuff mentioned above, I have
1 wireless keyboard/ mouse combo
1 Oculus Rift
2 Oculus sensors
1 USB 3 powered hub - fanatec shifter and fanatec pedals plugged in here
All the rest of the USB devices are plugged into the motherboard.

UPDATE:
On a whim, I used my old control scheme - Thrustmaster T150. under edit assignments, I got the left steer, right steer, and pedals to register. The shifter will not register. I was able to drive with an automatic transmission.

I wonder which wheel I should use under the control scheme section to get everything working properly?

When I get home this evening, I'll look through my setup for you and get more information and/or screenshots if you don't have it sorted by then.

Seelenkrank
17-07-2017, 19:20
go into the advanced settings (where you setup the buttons for all the stuff) and set the steering axis with the wheel.
then you can calibrate the wheel.

winet
18-07-2017, 08:49
I just received and set up my new OSW wheel from Simracingbay. It works fine in Assetto Corsa. I loaded up Project Cars and the game does not recognize the wheel at all.

I have Windows 10 64bit, Fanatec pedals, Fanatec shifter and handbrake.

Any help on how to set up the wheel or trouble shooting the problem would be appreciated.

Thanks Hmmmm that's odd. I too have a DD wheel from Simracingbay and it works fine in PC1. I am running HE pedals but that should not make any difference.

finagle69
18-07-2017, 15:11
I looked at my settings last night. I'm using Custom Wheel in the wheel setup page. Once you select that, you Edit Assignments, and assign left and right for the wheel. Then go on to calibrate the wheel for its rotation.

dpj463
20-07-2017, 15:20
I looked at my settings last night. I'm using Custom Wheel in the wheel setup page. Once you select that, you Edit Assignments, and assign left and right for the wheel. Then go on to calibrate the wheel for its rotation.

Solved:

I opened Mmos first. *Then launced steam *Then launced PCars.

In options I chose *custom wheel. *Then went to edit assignments. I chose steer left and turned the wheel all the way to the left until lock. *Then slightly turned the wheel right. *It finally registered!!!! *After that all the other inputs registered properly.

I*don't know if having Mmos open made a difference but I had not had it open before and was able to get the wheel to register in edit assignments page.



All good now!

dpj463
30-07-2017, 15:47
Solved:

I opened Mmos first. *Then launced steam *Then launced PCars.

In options I chose *custom wheel. *Then went to edit assignments. I chose steer left and turned the wheel all the way to the left until lock. *Then slightly turned the wheel right. *It finally registered!!!! *After that all the other inputs registered properly.

I*don't know if having Mmos open made a difference but I had not had it open before and was able to get the wheel to register in edit assignments page.



All good now!

NOPE Not all good now!!!!!

I am back to square one again. I don't know what has changed????? The game does not recognize the wheel. In custom wheel setup...edit assignments....Steer Left or Steer right, It is not registering the wheel when I move it left or right. I made sure no other buttons are touched and the gear shift is in neutral. I have tried all of the Fanatec options in Control Scheme.

I wonder if I am experiencing USB issues, although the wheel still works great in my other sim games......

Where to next?

Mahjik
30-07-2017, 15:54
Are you getting the "multiple inputs" message again?

dpj463
30-07-2017, 16:04
Nope. No reaction at all......

A couple of times when I hit the cancel button after no reaction from, for instance, Steer Left, the wheel would violently spin left and right. Then the FFB amount would be, probably, at the max. I could not turn the wheel more than a few degrees.

dpj463
30-07-2017, 16:29
I have added my hardware to my signature, hoping that might help somehow.

dpj463
31-07-2017, 01:03
Working again!!!!!!
Here is what I did, at Tomo's suggestion.
1. I changed the OSW USB from USB 3.0 to USB 2.0 port on my motherboard.
2. I disconnected all other sim hardware except the wheel
3. Launched Mmos, then Steam, then PCars
4. Went to Options/Control Scheme ......CSW base showed up
5. Went to edit assignments and clicked on steer left and moved the wheel to the left all the way and waited. The wheel SNAPPED to the center and the FFB was extremely strong.
6. I clicked on steer right and again the wheel SNAPPED back to center with extreme FFB
7. I then went to calibrate wheel and configured for 900 degrees. In this procedure there was no FFB at all
8. I then went to calibrate FFB and turned everything down 1/2. If it showed 100, I changed it to 50 etc.
9. I then plugged in all the other sim hardware and configured all the buttons on the wheel and button boxes. I have all the other peripherals plugged into a USB 3.0 hub at this point. The hub is plugged into a USB 3.0 port on my motherboard

So far, everything is working and I am setting up FFB settings for each car as I drive them. We will see how long this lasts!!!!! lol

I will work on the other games to see if there are any problems that crop up.

Hopes this helps anyone who might be having problems with PCars and their OSW wheel

finagle69
31-07-2017, 16:51
Working again!!!!!!
Here is what I did, at Tomo's suggestion.
1. I changed the OSW USB from USB 3.0 to USB 2.0 port on my motherboard.
2. I disconnected all other sim hardware except the wheel
3. Launched Mmos, then Steam, then PCars
4. Went to Options/Control Scheme ......CSW base showed up
5. Went to edit assignments and clicked on steer left and moved the wheel to the left all the way and waited. The wheel SNAPPED to the center and the FFB was extremely strong.
6. I clicked on steer right and again the wheel SNAPPED back to center with extreme FFB
7. I then went to calibrate wheel and configured for 900 degrees. In this procedure there was no FFB at all
8. I then went to calibrate FFB and turned everything down 1/2. If it showed 100, I changed it to 50 etc.
9. I then plugged in all the other sim hardware and configured all the buttons on the wheel and button boxes. I have all the other peripherals plugged into a USB 3.0 hub at this point. The hub is plugged into a USB 3.0 port on my motherboard

So far, everything is working and I am setting up FFB settings for each car as I drive them. We will see how long this lasts!!!!! lol

I will work on the other games to see if there are any problems that crop up.

Hopes this helps anyone who might be having problems with PCars and their OSW wheel

I'm pretty sure the Gaming 7 Z170x mobo does not have any 2.0 USB ports. If it does, I can't find any on mine.

In general, I have the OSW directly plugged into a port on the mobo, and most of my other gear plugged into 3.0 hubs.

I'm glad you got it working!

dpj463
31-07-2017, 17:21
I'm pretty sure the Gaming 7 Z170x mobo does not have any 2.0 USB ports. If it does, I can't find any on mine.

In general, I have the OSW directly plugged into a port on the mobo, and most of my other gear plugged into 3.0 hubs.

I'm glad you got it working!

I just looked again to make sure I was correct. I do have Rev1 of this board. My case had 2.0 and 3.0 ports on the front and I thought I remembered coming from the mobo to these ports. I copied the following from the manual:
USB Š Chipset:
- 5 x USB 3.0/2.0 ports on the back panel
- 4 x USB 2.0/1.1 ports (available through the internal USB headers)
Š Chipset+Renesas® USB 3.0 Hub:
- 4 x USB 3.0/2.0 ports (available through the internal USB headers)
Š Chipset+Intel® Thunderbolt™ 3 Controller:
- 1 x USB Type-C™ port on the back panel, with USB 3.1 support
- 1 x USB 3.1 Type-A port (red) on the back panel

finagle69
31-07-2017, 19:41
Ahh yes. Okay, you're using the internal ones then. I think my Corsair AIO cooler uses that one.

Raysracing
29-10-2017, 13:07
Working again!!!!!!
Here is what I did, at Tomo's suggestion.
1. I changed the OSW USB from USB 3.0 to USB 2.0 port on my motherboard.
2. I disconnected all other sim hardware except the wheel
3. Launched Mmos, then Steam, then PCars
4. Went to Options/Control Scheme ......CSW base showed up
5. Went to edit assignments and clicked on steer left and moved the wheel to the left all the way and waited. The wheel SNAPPED to the center and the FFB was extremely strong.
6. I clicked on steer right and again the wheel SNAPPED back to center with extreme FFB
7. I then went to calibrate wheel and configured for 900 degrees. In this procedure there was no FFB at all
8. I then went to calibrate FFB and turned everything down 1/2. If it showed 100, I changed it to 50 etc.
9. I then plugged in all the other sim hardware and configured all the buttons on the wheel and button boxes. I have all the other peripherals plugged into a USB 3.0 hub at this point. The hub is plugged into a USB 3.0 port on my motherboard

So far, everything is working and I am setting up FFB settings for each car as I drive them. We will see how long this lasts!!!!! lol

I will work on the other games to see if there are any problems that crop up.

Hopes this helps anyone who might be having problems with PCars and their OSW wheel

I did all of this and nothing. My favorite SIm and my new wheel, cant play it.

s73
28-02-2019, 20:51
Is this seriously the only way to get PC2 working with an OSW? Seems a bit odd that a popular wheel choice is not supported

Sankyo
01-03-2019, 08:57
Is this seriously the only way to get PC2 working with an OSW? Seems a bit odd that a popular wheel choice is not supported
During development it definitely wasn't a 'popular choice', but rather a niche product still. Therefore it doesn't have a specific profile, however 'Custom Wheel' should work perfectly fine. The fact that there isn't a specific profile/preset doesn't mean it won't work fully/properly, but you may have to tweak the FFB a bit more than when it would have had a preset.