PDA

View Full Version : Game running choppy in VR even on lowest settings



dantestyle
22-09-2017, 00:16
Hey all,

So I'm super excited to have pcars2 happening, and the force feedback seems so much better than 1.

However I'm having a lot of trouble with VR being really bad..

So my system is:

Windows 10
GTX1070
7700hq
16gb ram
the game is running off a 1gb nvme drive
I'm using HTC Vive


With all graphics settings lowest possible, and supersampling at 1 - I'm still getting terribly choppy video. It's at its absolute worst when both ansynchronous and interleaved reprojection are turned on. Pretty lousy with them both off. still pretty shoddy with ansynchronous on alone, same with interleaved on alone.

Oddly, if I increase the graphics to supersampling of 2.0, and medium settings, the choppiness isn't any worse either.

Any clues as to whats going on here?

Aldo Zampatti
22-09-2017, 00:22
It shouldn't. Your system is good enough!(better than that), please share a screenshot of your graphical settings and I'll try to help you out but if you got stuttering on your hardware, more than likely is caused by something else.

dantestyle
22-09-2017, 04:38
YEah, it's really weird... it should definitely be good enough hardware...

I'll attach two images of wahts going on with the VR..

It's set to lowest possible settings on everything.

It won't let me post up images unfortunately...

Other VR works just fine however...

D-Ther
22-09-2017, 04:48
just a hint, did you set the supersampling on SteamVR to 1.0?

dantestyle
22-09-2017, 05:35
Good question, but yeah I did, it's at 1.0 in both steamVR and in Pcars2

It's like there's some other problem... see if i turn graphics up or donw in pcars, the situation isn't worsened even if I put the supersampling up to 2.0 and the anti aliasing up to high, it's barely any worse.

Flashgod
22-09-2017, 09:57
VR works good on my side, i'm still fiddling with the settings, already tested ultra on everything and it runs with atleast 45fps.

dantestyle
22-09-2017, 10:09
VR works good on my side, i'm still fiddling with the settings, already tested ultra on everything and it runs with atleast 45fps.

What rig are you working with for some reference?

Has anyone tried disabling hyperthreading? Has it helped at all?

Morgan Henstridge
22-09-2017, 10:19
I don't have a Vive, but is there an app that makes it run Oculus native software??

If so you could try that and try launching the Oculus version of the game just as a test.

IlIlSHADOWlIlI
22-09-2017, 11:24
Having laggy issues too, Vive user :( changing settings does not seem to affect anything.

daz1976
22-09-2017, 11:49
Having same issues and running a GTX1080 and Oculus. Assetto and PC1 I can get to run well with a little tweaking but this, settings on low everything, SS 1.0.

No matter what I do to the settings, just me alone on the track and it's dropping fps massively at random times.

Daz

Morgan Henstridge
22-09-2017, 11:53
Having same issues and running a GTX1080 and Oculus. Assetto and PC1 I can get to run well with a little tweaking but this, settings on low everything, SS 1.0.

No matter what I do to the settings, just me alone on the track and it's dropping fps massively at random times.

Daz

What are the rest of your specs??

Boskapongen
22-09-2017, 12:01
I tried 10 different cars on 10 different tracks, was also streaming at the same time. No lag or fps issues what so ever with Oculus on 1.5 SS.

IlIlSHADOWlIlI
22-09-2017, 12:02
Reinstalling SteamVR, also removed openVR advanced settings, ill report back if it does anything.

daz1976
22-09-2017, 12:02
Windows 10
MSI Z270-A Pro
I5 7600OC
GTX 1080 Armour Edition
8GB DDR4 2400MHZ Black Fury
1TB Seagate SATAIII



Daz

IlIlSHADOWlIlI
22-09-2017, 12:20
still the same

daz1976
22-09-2017, 12:24
Something isn't right for some reason. Like I said, PC1 plays better with more headroom with similar settings and I expected this to be better optimized than that since that is well known to not be great.

Updated to the latest Nvidia drivers also, which made no difference.

Daz

Morgan Henstridge
22-09-2017, 12:25
still the same

A couple have users have said adjusting the settings for Vive makes no difference in game. Not sure whats going on there...

IlIlSHADOWlIlI
22-09-2017, 12:26
Something isn't right for some reason. Like I said, PC1 plays better with more headroom with similar settings and I expected this to be better optimized than that since that is well known to not be great.

Updated to the latest Nvidia drivers also, which made no difference.

Daz

it feels like changing the graphic settings makes no difference which is why performance is still shite when setting everything to low.

Morgan Henstridge
22-09-2017, 12:27
Something isn't right for some reason. Like I said, PC1 plays better with more headroom with similar settings and I expected this to be better optimized than that since that is well known to not be great.

Updated to the latest Nvidia drivers also, which made no difference.

Daz

Daz, try running with the monitor output windowed on your Monitor, and have Task Manager up running n the screen too.

Then when the slowdown starts, see if CPU, HDD, Memory are maxing out, and if you can also see what Process is making it happen.

Morgan Henstridge
22-09-2017, 12:29
it feels like changing the graphic settings makes no difference which is why performance is still shite when setting everything to low.

Daz is on Oculus, not the Vive. I believe it is only Vive users who have reported the issue with the settings making no difference.

I think Daz has a different issue as his runs OK, and then randomly starts playing up.

daz1976
22-09-2017, 12:35
I'll give that a try but will have to wait till tomorrow for me as I'm working now and won't be in front of the pc until tomorrow morning.

To be honest I have similar random spikes when playing Assetto and PC1 but it's never enough to drop the FPS so much. I use the Oculus tool with the performance HUD and can see the spikes.

IlIlSHADOWlIlI - I noticed that I was getting bad performance in certain areas more on tracks. Snetterton 300 I was getting frame jumps entering and exiting the 3rd right hander always, no matter what I changed the setting to. 1 car or 15 cars. Always the same drop.

Daz

IlIlSHADOWlIlI
22-09-2017, 13:20
Cannot play this game in VR, motion sickness is just too much with the Vive, hoping for a quick patch.

D-Ther
22-09-2017, 14:49
Cannot play this game in VR, motion sickness is just too much with the Vive, hoping for a quick patch.

For motion Sickness try this:
https://www.reddit.com/r/Vive/comments/4l0w6w/vr_sickness_get_rid_of_motion_sickness_in_project/

As for problem related to the Vive, i can't really help, working fine here on max setting (i7 860@3.8Ghz + 980TI OC )

Morgan Henstridge
22-09-2017, 14:52
If we have a working Vive user, it may be worth attaching the working "openvrsettings.xml" from \Documents\Project Cars 2\ for the guys with Vive issues to compare and see if there is something different with the config file??

IlIlSHADOWlIlI
22-09-2017, 14:58
For motion Sickness try this:
https://www.reddit.com/r/Vive/comments/4l0w6w/vr_sickness_get_rid_of_motion_sickness_in_project/

As for problem related to the Vive, i can't really help, working fine here on max setting (i7 860@3.8Ghz + 980TI OC )

could you attach your "openvrsettings.xml" from \Documents\Project Cars 2\

mr_belowski
22-09-2017, 15:00
you'll also need to attach graphicsconfigopenvrdx11.xml too. When I switched to VR lots of things got turned down - shadows were disabled entirely, making the interior of tin-top cars look weirdly bright and distracting

hotak
22-09-2017, 15:05
With my massively inferior PC i was able to run it smooth on the oculus during WMD, still didn't try the release version, but if it doesn't run smooth there's probably some issue on your side..

mshagg
22-09-2017, 15:13
If you are using HTC Vive, be sure to disable asynchronous reprojection and enable always on reprojection.

mr_belowski
22-09-2017, 15:19
this made it massively worse for me. Without asynchronous reprojection it was a stuttering mess. Always on reprojection didn't make a noticeable difference

IlIlSHADOWlIlI
22-09-2017, 15:21
this made it massively worse for me. Without asynchronous reprojection it was a stuttering mess. Always on reprojection didn't make a noticeable difference

5 mins and ill give you my files, i got it working pretty sweet now.

IlIlSHADOWlIlI
22-09-2017, 15:34
Steam VR Settings

Super Sampling 1.0
Yes: Enable Always on Reprojection
No: Allow async repro
Yes: Allow interleaved repro

240260
240261
240262

Let me know how you get on.

mr_belowski
22-09-2017, 15:47
OK, with those settings I get no shadows and no anti-aliasing of any kind - the


<prop name="VRSuperSampling" vrsupersampling="4" />


line makes no different at all. It's a jaggy mess with no supersampling and looks horrible on the Vive. It runs well but just looks nasty :(

I run with MSAA at high and shadows at Low. It looks tons tons better but needs to have async reprojection enabled.

IlIlSHADOWlIlI
22-09-2017, 15:56
Yeah I turned shadows off as that was dropping frames, im running 1.4SS in the game options.

IlIlSHADOWlIlI
22-09-2017, 16:03
OK, with those settings I get no shadows and no anti-aliasing of any kind - the


<prop name="VRSuperSampling" vrsupersampling="4" />


line makes no different at all. It's a jaggy mess with no supersampling and looks horrible on the Vive. It runs well but just looks nasty :(

I run with MSAA at high and shadows at Low. It looks tons tons better but needs to have async reprojection enabled.

I see you have issues with your SS slider in game, try using the steamVR one and set it to 1.4.

mr_belowski
22-09-2017, 16:07
It's already at 1.6 but pcars2 doesn't seem to use it at all

IlIlSHADOWlIlI
22-09-2017, 16:17
List of things I've done.


Uninstalled Open VR advanced settings
Reinstalled SteamVR
Deleted everything from C:\Program Files (x86)\Steam\steamapps\common\Project CARS 2 apart from the 2 PAK folders
After deleting it all right click on PC2 on steam then click properties/local files/verify integrity of game files
Deleted all the .XML files from Documents\Project CARS 2

msmith792
22-09-2017, 16:25
List of things I've done.


Uninstalled Open VR advanced settings
Reinstalled SteamVR
Deleted everything from C:\Program Files (x86)\Steam\steamapps\common\Project CARS 2 apart from the 2 PAK folders
After deleting it all right click on PC2 on steam then click properties/local files/verify integrity of game files
Deleted all the .XML files from Documents\Project CARS 2


It's not you bud. I have a 1080FTW with i5-4690K and i'm having the same issues. I have to turn all aliasing off and run 1.4 to get it to work. Everything else on low. Something isn't right. At least I hope not, cause the performance is terrible right now.

IlIlSHADOWlIlI
22-09-2017, 16:47
It's not you bud. I have a 1080FTW with i5-4690K and i'm having the same issues. I have to turn all aliasing off and run 1.4 to get it to work. Everything else on low. Something isn't right. At least I hope not, cause the performance is terrible right now.

Knew I should of bought the Rift instead :mad:

Eddy555
22-09-2017, 17:59
Vive here running with a lot of settings pushed up to high or medium.
1080Ti and 4790K on Win 10. Supersampling in game at 1.5. Running at 90fps mainly according to AfterBurner.
Steam VR Beta, SS 2.0, Async Reproj On, Interleave Repoj Off, Advanced Suspersample Filtering On

IlIlSHADOWlIlI
22-09-2017, 18:25
Vive here running with a lot of settings pushed up to high or medium.
1080Ti and 4790K on Win 10. Supersampling in game at 1.5. Running at 90fps mainly according to AfterBurner.
Steam VR Beta, SS 2.0, Async Reproj On, Interleave Repoj Off, Advanced Suspersample Filtering On

Could you post your openvrsettings oculussettings graphicsconfigopenvrdx11 graphicsconfigdx11 .XML files for me? under docs/pc2

Eddy555
22-09-2017, 19:40
Worked out how to attach files so my settings are attached below

240274
240275
240276

IlIlSHADOWlIlI
22-09-2017, 20:01
Made a new thread so I could keep the OP updated. http://forum.projectcarsgame.com/showthread.php?51697-FIX-Vive-Users-Choppy-VR&p=1358660#post1358660

dantestyle
22-09-2017, 23:20
Steam VR Settings

Super Sampling 1.0
Yes: Enable Always on Reprojection
No: Allow async repro
Yes: Allow interleaved repro

240260
240261
240262

Let me know how you get on.


Okay so this is interesting...

So it's not your settings that do much for me - more on that in a minute. But it's setting always on reprojection and interleaved together.

NOW when I use your settings above which are basically pretty low settings, it's overall pretty smooth except every 3-4 seconds I get a weird kind of jumping frame. It's worse when I move my head around, and very rare when I keep my head absolutely steady.

NEXT I took your settings and bumped in game SS up to 2.0, and mxaa up to medium - the game is just as smooth now, of course graphics look much better, BUT the random frame jumping effect is still there.

Any insight?

D-Ther
22-09-2017, 23:41
could you attach your "openvrsettings.xml" from \Documents\Project Cars 2\

i'm not comming in this forum regulary :p

IlIlSHADOWlIlI
22-09-2017, 23:48
Okay so this is interesting...

So it's not your settings that do much for me - more on that in a minute. But it's setting always on reprojection and interleaved together.

NOW when I use your settings above which are basically pretty low settings, it's overall pretty smooth except every 3-4 seconds I get a weird kind of jumping frame. It's worse when I move my head around, and very rare when I keep my head absolutely steady.

NEXT I took your settings and bumped in game SS up to 2.0, and mxaa up to medium - the game is just as smooth now, of course graphics look much better, BUT the random frame jumping effect is still there.

Any insight?

Go here, we worked out the proper fix http://forum.projectcarsgame.com/showthread.php?51697-FIX-Vive-Users-Choppy-VR&p=1358660#post1358660 no choppyness and decent settings.

dantestyle
23-09-2017, 22:58
So the above isn't fixing it for me, how's it doing for everyone else?

isniedood
24-09-2017, 15:40
I tried everything but the game is just unplayable and ugly. My Ryzen 1700, 16 gig memory and msi GTX 1080 should be more then good enough, but even on the lowest settings I will get an occasional stutter. Tried getting rid of the steam beta, but did not help. Got all the new drivers. Tried enabling and disabling async repro but did not really matter much

isniedood
24-09-2017, 15:41
same here.... anyone has it fixed yet?

Aldo Zampatti
24-09-2017, 17:26
Please take a quick look on this spreadsheet:
http://forum.projectcarsgame.com/showthread.php?51807-Pcars-2-looks-worse-in-VR-than-Pcars-1&p=1362305&viewfull=1#post1362305

isniedood
25-09-2017, 21:56
None of the above helped here

satco1066
25-09-2017, 22:08
Okay so this is interesting...

So it's not your settings that do much for me - more on that in a minute. But it's setting always on reprojection and interleaved together.

NOW when I use your settings above which are basically pretty low settings, it's overall pretty smooth except every 3-4 seconds I get a weird kind of jumping frame. It's worse when I move my head around, and very rare when I keep my head absolutely steady.

NEXT I took your settings and bumped in game SS up to 2.0, and mxaa up to medium - the game is just as smooth now, of course graphics look much better, BUT the random frame jumping effect is still there.

Any insight?

this one random appearing frame jump effect is a known issue. You cannot repair it with any setting. Just have to wait for a patch.

GTsimms
25-09-2017, 23:15
I run on a 1070 see signature!

drs200
21-07-2018, 11:41
Hey all,

So I'm super excited to have pcars2 happening, and the force feedback seems so much better than 1.

However I'm having a lot of trouble with VR being really bad..

So my system is:

Windows 10
GTX1070
7700hq
16gb ram
the game is running off a 1gb nvme drive
I'm using HTC Vive


With all graphics settings lowest possible, and supersampling at 1 - I'm still getting terribly choppy video. It's at its absolute worst when both ansynchronous and interleaved reprojection are turned on. Pretty lousy with them both off. still pretty shoddy with ansynchronous on alone, same with interleaved on alone.

Oddly, if I increase the graphics to supersampling of 2.0, and medium settings, the choppiness isn't any worse either.

Any clues as to whats going on here?

After a lot of mucking about, the biggest performance gain was setting the resolution to as low as you can read the menu. It doesn't affect in game race resolution. Looks fantastic and smooth now.