PDA

View Full Version : [DedicatedServer] Failed to start server - GLIBCXX_3.4.15 & GLIBC_2.14



Vincen
22-09-2017, 14:12
I can't start the server.




[pc2 cars2_ds]$ ./DedicatedServerCmd.elf

./DedicatedServerCmd.elf: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/pc2/pcars2_ds/lib64/libsteam_api.so)
./DedicatedServerCmd.elf: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/pc2/pcars2_ds/lib64/libsteam_api.so)





strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH



[pc2 pcars2_ds]$ cat /etc/*-release
CentOS release 6.9 (Final)

Vincen
22-09-2017, 16:41
Anyone else with this problem?

Visceral_Syn
22-09-2017, 16:44
try this as sudo, yum install glibc.i686 libstdc++.i686

Vincen
22-09-2017, 16:47
try this as sudo, yum install glibc.i686 libstdc++.i686


already installed and latest version :/


yum install glibc.i686 libstdc++.i686

Loaded plugins: fastestmirror, presto
Setting up Install Process
Loading mirror speeds from cached hostfile
Package glibc-2.12-1.209.el6_9.2.i686 already installed and latest version
Package libstdc++-4.4.7-18.el6.i686 already installed and latest version
Nothing to do

Visceral_Syn
22-09-2017, 16:51
you need a newer glibc, i'm not sure about the libstdc++, it looks like you have the latest, maybe doesn't have the older libraries you need?

Vincen
22-09-2017, 17:13
you need a newer glibc, i'm not sure about the libstdc++, it looks like you have the latest, maybe doesn't have the older libraries you need?

I don't know :confused:
I hope someone on staff tells us something, i don't want migrate my dedicated server to another distro..i have a lot of things ..

Vincen
23-09-2017, 14:08
up!