PDA

View Full Version : RGT Force Feedback Pro Clutch Edition doesnt work



Soul808
22-09-2017, 18:46
The game recognizes the wheel. But I want to reassign some buttons and it does not recognize any inputs from at all after I click the function I want to reassign, not even the keyboard.
I do this with all of my other racing games and there it works fine.

Since my shifters are broken I am forced to use automatic gears until this is fixed.

Thing I already tried:
un-ticking all the options in the steam > controller options.
Reinstalling the drivers and rebooting.
Assigning buttons during a race.

Any suggestions?

Soul808
23-09-2017, 06:45
bump

Booster
23-09-2017, 07:30
I have the same steering wheel, it works perfectly

Soul808
24-09-2017, 13:03
bump

Morgan Henstridge
24-09-2017, 13:22
Try mapping the assignments in a race / practice session, not from the main menu.

Soul808
24-09-2017, 14:16
Try mapping the assignments in a race / practice session, not from the main menu.

Already tried it. Still doesn't work. Added it to the original post list.

Soul808
24-09-2017, 20:03
bump

Faceless
24-09-2017, 20:58
I have the exact same problem with the same Wheel.

Soul808
25-09-2017, 18:03
bump

TM-Racer500
25-09-2017, 18:45
Since my shifters are broken I am forced to use automatic gears until this is fixed.



You mean they are physically broken ?

This might be a long shot, but when you check your wheel under Game Controller, are the buttons associated to the shifters On all the time (given the wheel is properly recognized and working in the first place)?

If this is the case, then it may prevent you from assigning anything new in the game since it could see it as if you're already pressing buttons and it doesn't know how to interpret them.

Soul808
25-09-2017, 20:04
You mean they are physically broken ?

This might be a long shot, but when you check your wheel under Game Controller, are the buttons associated to the shifters On all the time (given the wheel is properly recognized and working in the first place)?

If this is the case, then it may prevent you from assigning anything new in the game since it could see it as if you're already pressing buttons and it doesn't know how to interpret them.

Yes, both my shifters (sequential and flappy paddle) upshift are physically broken. As in I can get anything to register my upshift on the sequential shifter and the flappy paddle upshift has broken off.

As for the other part. Yes. The shifter buttons are on all the time. This is just how this wheel works and has nothing to do with my setup as far as I know, and it seems to be an oversight on the developers part...

I added the screenshots of my two options. Both have the two shifter buttons active at all time.

240555240556

TM-Racer500
26-09-2017, 14:56
Yes. The shifter buttons are on all the time. This is just how this wheel works and has nothing to do with my setup as far as I know, and it seems to be an oversight on the developers part...



Looks like I was unfortunately correct about your problem.

The buttons should only lit up in the controls panel when they are pressed and not be permanently On as it is the case for you. Consequently, this must create a problem when trying to proceed with a custom mapping in Project Cars 2.

Soul808
26-09-2017, 18:26
Do you know anything I can do about it? As far as I know this is expected behavior.

TM-Racer500
26-09-2017, 19:55
Again, this is not the expected behavior. Right now, it is as if you are pressing two buttons all the time.

As to what you can do, its hard to says. The problem is internal; either the switches or a pinched wire.

Soul808
26-09-2017, 20:25
Again, this is not the expected behavior. Right now, it is as if you are pressing two buttons all the time.

As to what you can do, its hard to says. The problem is internal; either the switches or a pinched wire.

How are you sure its not expected? The wheel works with other games (including both downshifts which are not broken). When I use the sequential shift down the buttons get released. In other games this works fine...
I believe this is simply how the sequential shifter works on this wheel, instead of shifting when the button gets pressed, it shifts when getting released.

This is the first game I've had issues with, and continues to be the only one. Even when I test other racing games now, they all recognize my inputs.

TM-Racer500
27-09-2017, 13:10
I use to own one of these wheel years ago and all buttons were Off unless you used them. Beside, there is no reason why only two buttons would behave differently then the rest.

Soul808
28-09-2017, 17:39
If it was a faulty connection or something similar it also doesn't make sense that when I engage the shifter the button input gets released and works in other games

Soul808
30-09-2017, 09:22
Seems like the baseboard got damaged somehow. I rewired my wheel to have my start and select buttons from my sequential gear shifter linked to what used to be my sequential gear stick. Then I ductaped them shut so they always give an imput, cancelling out the broken baseboard which was working the wrong way round as explained above.