PDA

View Full Version : [RESOLVED] DFGT ratio not 1 to 1



nismofreak
22-09-2017, 19:40
So... when driving in PC2 and turning the wheel, my Logitech Driving Force GT requires me to turn twice as much just to register in game. For example, I need to turn 180 degree just to see it turn 90 in the game. I have calibrated the wheel in game as per the instructions several times to no avail.

Here are my settings for the wheel in Logitech game profiler:
Overall Effects Strength: 75%
Spring Effect Strength: 0%
Damper Effect Strength: 0%
Enable Centering in Game: Checked
Centering Spring Strength: 0%
Degrees of Rotation: 900 degrees
Report Combined Pedals: Unchecked
Allow Game to Adjust Settings: Checked

As a reference, PC1 works bang on with the wheel with no issues.

Help me racing gods. You're my only hope!

Bealdor
22-09-2017, 19:42
At the last calibration screen, what numbers are shown left and right?
It should be 100 on the left and 900 on the right side.

nismofreak
22-09-2017, 19:46
Thanks for the response!

I do get 100 on the left but only 180 on the right. I don't see how to get 900.

Edit:
So I fudged the calibration to register 900 and it works!

If you follow the instructions on the screen, it will not register 900 because you need to turn more than the 90 degrees clockwise or counterclockwise.

Thanks again!

Shooter80
22-09-2017, 21:11
Thats interesting. I have a DFGT, and I didnt go through any form of calibration, and the wheel in the game exactly matches the DFGT wheel.

The game detected the wheel, and even showed a nice picture of it. I remapped some keys but nothing else. Maybe better not to calibrate it in game? Just let the wheel self calibrate at power on, then leave the game to assume it goes 900 degrees as per its design.

nismofreak
23-09-2017, 00:36
How is the weight of your wheel? I am not getting much in the way of resistance.

Morgan Henstridge
23-09-2017, 01:49
Thats interesting. I have a DFGT, and I didnt go through any form of calibration, and the wheel in the game exactly matches the DFGT wheel.

The game detected the wheel, and even showed a nice picture of it. I remapped some keys but nothing else. Maybe better not to calibrate it in game? Just let the wheel self calibrate at power on, then leave the game to assume it goes 900 degrees as per its design.

I believe the rotation etc is set by default by the wheel profile you choose, as I have never calibrated my wheel and it's spot on. However if there is an issue, running the calibration should Force it to set the correct rotation.

nimix
23-09-2017, 12:59
I'm using a DFGT too and did the calibration process correctly, however the steering lock is ALWAYS set to 900, which is fine with road cars/GTs, but is an issue with single seaters etc (i.e. I need to turn the wheel like 200+ to get it to turn 90 in game in the indy car). I set 900 in the logitech profiler, ticked the box to allow games to modify settings, and have 100/900 in the calibration settings in pcars. I've posted this in another thread and on reddit but can't seem to find a solution. The cars with lower steering lock are unplayable at the moment, quite a big bummer...

Bealdor
23-09-2017, 13:04
I'm using a DFGT too and did the calibration process correctly, however the steering lock is ALWAYS set to 900, which is fine with road cars/GTs, but is an issue with single seaters etc (i.e. I need to turn the wheel like 200+ to get it to turn 90 in game in the indy car). I set 900 in the logitech profiler, ticked the box to allow games to modify settings, and have 100/900 in the calibration settings in pcars. I've posted this in another thread and on reddit but can't seem to find a solution. The cars with lower steering lock are unplayable at the moment, quite a big bummer...

Make sure to load your setup before you start the session.
You can also reduce the steering ratio setting in the car setup.

Shooter80
23-09-2017, 13:39
I'm using a DFGT too and did the calibration process correctly, however the steering lock is ALWAYS set to 900, which is fine with road cars/GTs, but is an issue with single seaters etc (i.e. I need to turn the wheel like 200+ to get it to turn 90 in game in the indy car). I set 900 in the logitech profiler, ticked the box to allow games to modify settings, and have 100/900 in the calibration settings in pcars. I've posted this in another thread and on reddit but can't seem to find a solution. The cars with lower steering lock are unplayable at the moment, quite a big bummer...

I dont get that. I just tried a Formula A car, and again the on screen wheel is perfectly in line with the real wheel.

All I did was install and start the game, it had auto selected the DFGT, I remapped some buttons to how I liked them (didnt touch the Axis') and everything works fine. Maybe worth closing the game, renaming your My Document\Project CARS 2 to something else (like Project CARS 2.BAK) then start the game and dont touch anything to do with calibration, and try that. You can always rename your original folder back into place if it changes nothing and you want to keep other settings.

For the Logitech Profiler I just use Global settings (80%,0%,0%,<unchecked>,0%,<unchecked>,900,<checked>), the same I have it for all games.

BTW: Once you get the wheel rotation problem fixed, I'd suggest using Jack Spades 'Custom' FFB profile, either 'Standard Low' or 'Standard Mid' and using his other suggested settings:
http://forum.projectcarsgame.com/showthread.php?51628-Jack-Spade-Custom-FFB-Files

Good luck.

F1Aussie
23-09-2017, 14:31
Where is this in game calibration? I have not seen anything like this in game. Cheers

Shooter80
23-09-2017, 14:38
I have no idea, and since I have no problems, and people who have used it have, I'm hoping I never find it. Hopefully somebody else can tell you.

nimix
23-09-2017, 14:46
Thanks Shooter80, I'll try that next time I start the game. I already tried resetting the profile though which should be about the same thing and it didn't work. This problem is really weird, I wonder if it doesn't have something to do with the fact that I use the Logitech profiler for my DFGT, but also their newer software for my mouse, which may create some sort of weird conflict that only happens in pc2? :/

patientx
23-09-2017, 15:16
I bought this wheel for PCARS1 back in the day and used it with several games since. This week I tried Forza's new demo and was disappointed with how bad the wheel was with that game to be honest my interest in that game nearly lost. I am of course buying the second PCARS and reading this thread I am happy to be able to use my wheel without any problems and to its full potential.

nimix
23-09-2017, 17:41
Whelp, fresh settings didn't work. Still forced 900 on all cars. What the shit?

nimix
23-09-2017, 18:05
Okay, kept resetting the profile and trying to drive, and I randomly just got 1:1 steering, doing nothing different that the 10 past resets. However, the game won't recognize my T3PA pedals anymore, at all. My refund window has long expired, and I've barely been able to play the game in between the sessions of tweaking the settings to GET MY VERY BASIC AND RELIABLE HARDWARE TO WORK. This is not a finished product, and such menu/settings bugs are not acceptable on a AAA, full price title launch. Anyway, back to spamming the menus until they randomly work again :))

edit : yay everything works, I can finally try the community events after 2 days of tweaking settings...

zaki79
24-09-2017, 15:46
Hi guys!

I'm heaving the same issue here. I bought PCars 2 yesterday. Everything seemed to be working fine. I kept looking for accurate Steering wheel settings as some cars were undrivable (for example Mercedes AMG GT). 900 deg rotation used to work fine. I've started tweaking Logitech settings (Game Controller app.). I turned off Damper and Spring effects as some of you suggested. Suddenly my game stopped detecting this wheel. After installation it did work without any problems. Restarting my machine, unplugging the wheel etc. didn't help. I gave up after a couple of hours. Now, as someone has already mentioned, game can't see 900 degrees, but only 100! I used to have this problem with Assetto Corsa so it seems to be a DFGT driver's issue. I remember that using different USB ports (2.0/3.0?) solved this problem in AC, but that did not work here. I'll post a solution if I will find one.

nimix
24-09-2017, 16:13
If you've had the windows creator whatever update recently, you should wipe your drivers clean and reinstall them; the update installs bad drivers for the DFGT. You can google it up and find tutorials, I did a few weeks ago and it worked fine then. My setup finally works fine, I have no idea why. The way the game detects controllers really must be screwed up :(

Chris28
24-09-2017, 16:20
I have DFGT and didn't have any problems at all. Be sure to run the Logitech Profiler in administrator mode and make a profile for Project Cars 2 with a path to the games .exe file.

zaki79
24-09-2017, 16:44
Chris28- I didn't have any problems during first few hours either. I've already tried that. I've deleted all profiles, recreated them, but that didn't help. Why would you use administrator mode? Logitech Controller starts with windows. This is not the first time I'm having that kind of issues with this wheel.

nimix- Windows 10 keeps updating every single day. If I would wipe out some drivers I bet that windows would replace it with new ones. I had this problem before and I didn't have to delete any drivers.

I keeps browsing PCars1 forums as it's been (is) a common issue.

Chris28
24-09-2017, 16:48
I used to have problems with Euro Truck Simulator long time ago, starting the app in admin mode solved it so maybe it could help.
I was in PC2 alpha/beta and never had problems with the wheel. I do have in Forza though.