PDA

View Full Version : Unable to fully turn off HUD



MK153
22-09-2017, 20:31
I have a bit of a unusual setup so I'll post that first:

GTX1070
Triple 4K monitors
Oculus Rift
Simvibe


I enjoy playing games in VR when in the mood, but mostly with triple screens. I have a few problems with the game - the most annoying first:

In VR OR on triples - unable to turn off HUD lap timer:
I like driving without any HUD. It appears the controls for how to move hud items REALLY sucks on triple screens with random boxes appearing and the clickable controls to toggle betwen off/minimal/full etc are not actually where they are displayed. I would be able to get around this if "reset to defaults" actually had the lap timer turned off when HUD mode is off - but it appears thats the only one they leave on - why?!?! I'm referring to the one that has the word "Potential" in it. Any ideas? Headlocked visuals like this are completely nauseating in VR especially when ASW comes into play.

When playing with 4k triples: 5760x1080 acts like game is running at 11520x2160
Normally I run my computer with all 3 monitors at their native 4K 11520x2160 resolution, but tell games to run 5760x1080 for performance reasons. That doesn't appear to work at all in Project Cars 2, but does in Project Cars 1 and Assetto Corsa. If I try to do that in PCars2 its like the game's view is 11520x2160 but I only get to see the upper left 5760x1080 piece of it. I got around it for now by setting my desktop resolution to 5760x1080 but its very annoying. Should I be using nVidia surround or not?

Other problems:

VR image spans all three displays even in windowed mode
VR image if "enable triple screen" is on is completely uninteligible and squished
Brake pedal on G29 seems uber sensitive, experencing constant lockups causing spin outs, don't have that problem in any other game.
Steering ratio for virtual driver not same as physical steering wheel, off only by ~10% or so but noticeable in hairpins
Feature request: Switching from one fidelity setting for VR and another for triples should be easy but is far from it. You have to go back and touch all of the different little fields. This makes switching from one or another a 10 minute operation hoping you remembered to change texture resolutions, filtering settings, shadow detail, etc...


My setup if you'd like to see:
240282

Zenzic
22-09-2017, 20:49
Might be worth mentioning this problem occurs on PS4 too. I can't get rid of the "potential" box. Even with the hud off it's still shown. Didn't have this issue at first though. I think messing around with the hud or restoring the hud to defaults is what triggered it.

Edit: Since this was driving me bonkers I removed all hud elements from the "light" screen, de facto turning into a new "off" screen.

Morgan Henstridge
22-09-2017, 22:30
With the HUD, I have not seen this, but i have toggled all the elements on and off. Try going to the full HUD display, then switch through the lap timers until they are off, and then toggle the HUD to off again.

As for the Oculus Mirror display, check out \Documents\Project Cars 2\graphicsconfigoculusdx11.xml
Save a copy of this file first incase this doesnt work.....

Set the resolution in the line....
<prop name="Mode" adapter="0" width="1920" height="1080" refresh_num="59940" refresh_dem="1000" />

Set windowed mode in the line...
<prop name="Windowed" windowed="0" />


For the Virtual driver wheel, run the Steering Calibration in game. M<y wheel lines up perfectly with the on screen wheel in VR.


PS - Sweet Rig :)

MK153
24-10-2017, 03:21
I still have these problems with the new patch - I also found a (pretty minor) bug with headlights when you use three displays where they flicker on the side monitors.

Vid: https://www.youtube.com/watch?v=YBiNOAXu8V8

Zenzic
06-11-2017, 21:34
Has this issue been passed on to the devs? I just edited the HUD (on PS4), expecting it to have been fixed since 2.0. I'm now stuck once again with the "potential" box being shown when the HUD is off, with no way to remove it except form deleting my profile (and progress).