PDA

View Full Version : Stutter Fix



Andrew_WOT
23-09-2017, 03:35
If you suffer from weird stuttering, judder, stroboscope effect in turns when camera moves around quickly, here's the solution that worked for me.
After trying everything to fix that annoyance I used same trick that worked in pCars1.
1) Turn Vsync off in game
2) Force Adaptive Vsync in video driver
3) Add the following launch options in Steam game properties -fpscap 63
(Also Try 62.8 see this post (http://forum.projectcarsgame.com/showthread.php?51812-Stutter-Fix&p=1364310&viewfull=1#post1364310[) (#25), not 100% sure though if 62.8 vs 63 makes a difference, could be placebo, but it does look smoother, not worse for sure :))

You can even set prerendered frames to 1, it's still smooth and doesn't tax GPU as much plus eliminates input lag.

Finally, butter smooth gameplay. :)

P.S. It wouldn't help if your GPU can't keep up, only if you get that stuttering at otherwise stable 60fps.

241896

Kitt
23-09-2017, 08:52
thanks will give this a go later...getting some crazy stuttering with i7 4790k and gtx 1080,thought it might be my HDD but if this fixes it I'll be well chuffed

Kitt
23-09-2017, 14:59
well that fixed it :D smooth as silk on high and ultra settings but why did it fix it? is there something wrong with my system? and putting in the launch options is some kind of bodge fix?

Maurice Boeschen
23-09-2017, 15:04
Fixed it also for me (using -fpscap 100 as my monitor has 100 Hz).

Strange that a FPS cap solves stuttering/jittering in corners.. But yes, now butter smooth :)

Andrew_WOT
23-09-2017, 15:10
thanks will give this a go later...getting some crazy stuttering with i7 4790k and gtx 1080,thought it might be my HDD but if this fixes it I'll be well chuffed

Question to SMS, while 2 years later we still have to do that. I had this issue with GFX 980 on pCars1, now with 1080Ti on pCars2.

RomKnight
23-09-2017, 15:12
Andrew, I actaully just use v-sync (on triples). I leave it off for VR.

PS: you using yesterdays' new nvidia drivers? There's support for pC2.

Andrew_WOT
23-09-2017, 18:04
Yes, 385.69.
We had this very issue with pCars1 and Assetto Corsa had the same problem, something to do with frames timing. Similar solutions as well, in game fps cap just a bit over refresh rate and outside game VSync via driver.
Kunos managed to fix it, guess SMS will do it in pCars3, hopefully. :)

Sankyo
23-09-2017, 18:08
Where do you see this stuttering? When driving, during replays, both?

Maurice Boeschen
23-09-2017, 18:11
I had them only in some corners like the first 5 at Algarve. Setting the fps cap completely eliminated the stuttering/jittering.

Andrew_WOT
23-09-2017, 18:13
Driving.

Replays are much worse.

Andrew_WOT
23-09-2017, 18:17
I had them only in some corners like the first 5 at Algarve. Setting the fps cap completely eliminated the stuttering/jittering.

Yep, some corners, guess it's mostly combination of turn radius and vehicle speed that affect camera panning speed, when it starts skipping frames or something along these lines. It's almost like stroboscope effect.

Kitt
23-09-2017, 18:52
yep corners and was also getting it on the straights at classic hockenheim

Richard83945
24-09-2017, 12:09
1) Turn Vsync off in game
2) Force Adaptive Vsync in video driver
3) Add the following launch options in Steam game properties -fpscap 63


Andrew - Thanks for the fix.

I use MSI Afterburner with Rivatuner Statistics Server.
The latest beta allows realtime graphs on the OSD during the game.
http://www.guru3d.com/files-details/msi-afterburner-beta-download.html



1) Turn Vsync off in game
2) Force Adaptive Vsync in video driver.
The Frametime and FPS graphs were not flat.

3) -fpscap 63 fix
It made some improvement, but the graphs were still bumpy on my system. It probably varies with different monitors and hardware.
I tried -fpscap 60. This cut the FPS to below 60.

I then tried the same fix I'd used in pCars 1 - Set the Framerate limiter in Rivatuner Statistics Server to 60fps.
The graphs are flat!!!!!



***** I have read that using an external framerate limiter might increase lag. *****



Why Frame Time Analysis is important
https://www.vortez.net/articles_pages/frame_time_analysis,1.html

sherpa25
24-09-2017, 13:43
...Set the Framerate limiter in Rivatuner Statistics Server to 60fps.

Is this a global setting in Riva, or can it be per game?

Richard83945
24-09-2017, 14:17
Is this a global setting in Riva, or can it be per game?

Yes it can be per game.
I'm not sure what the difference is between pCARS2.exe and pCARS2AVX.exe.
pCARS2AVX.exe is the one to choose in RivaTuner.

Here are my settings:
240390

thepharcyde
24-09-2017, 14:39
Why not just enable Steams own FPS on screen overlay?

Roger Prynne
24-09-2017, 15:06
^ Because that's all it does, display FPS.

Richard83945
24-09-2017, 15:08
Why not just enable Steams own FPS on screen overlay?

The RivaTuner beta OSD displays realtime line graphs which show very fast changes in FPS and framerate.
240406

thepharcyde
24-09-2017, 15:16
The RivaTuner beta OSD displays realtime line graphs which show very fast changes in FPS and framerate.
240406

That's just overkill IMO - I don't even use Steams own counter, I've found in the past using it you spend so much time tweaking settings to maintain 'x' FPS that it detracts from racing.

Andrew_WOT
24-09-2017, 15:29
That's just overkill IMO - I don't even use Steams own counter, I've found in the past using it you spend so much time tweaking settings to maintain 'x' FPS that it detracts from racing.
Come on, this is Project Cars. You spend most time either tuning graphics or ffb. :)

Richard83945
24-09-2017, 15:32
I tried to take a screenshot of the OSD graphs with the 60fps limiter on, but the steam screenshot process produced large bumps in the graph.
Instead I've used the graphs in Afterburner.

LEFT - Adaptive Sync
RIGHT - Adaptive sync with 60fps limit in RivaTuner
UPPER - Frame Time (0-100ms)
LOWER - FPS (0-400fps)

The lines on the graphs are at slightly different heights - just my poor cropping!
The vertical scale of these graphs is very exaggerated, so the fluctuations in Frame Time in the right graph are tiny.

240408 [240409


Since my first post, I noticed that the 60fps limit in RivaTuner doesn't cure the problem completely. There are sections of the Spa Historic track which still produce very slight bumps in the graphs, but these sections are still much smoother than without RivaTuner's fps limit.
The graphs are flat for most of the track.

Richard83945
24-09-2017, 15:44
Monitor PC Performance with Display and Graphs - MSI Afterburner/RivaTuner (Beta/v4.4.0 Update)


https://www.youtube.com/watch?v=kw72qy1Rc6o

SpeedLimitUnknown
24-09-2017, 22:03
Thank you for reposting this information. I had the same problem in PC1 and used this fix but completely forgot about it. Fired up PC2 for the first time last night and noticed the very SUBTLE microstutter in turns which gives the impression of a fps drop of 60 down to 30 (even though the counter is still showing 60). Tried this fix this morning and it's buttery smooth in turns now, I'm so happy! It may have something to do with how PC2 looks at the default resolution refresh rate (within the frontend settings) but doesn't actually use it in-game. My default PC monitor spec is 1920x1080@59, which PC2 displays correctly in the options, but in-game the frame counter is at 60 fps, instead of locked at 59 fps which it should be when vsync is used. When I use the nvidia adaptive vsync and go back into the game it correctly locks it at 59 fps.

EDIT: I feel that this thread should be stickied :D

pool101
24-09-2017, 22:41
Thanks for everyone for the tips here. I tried all the steps but struggled with the Adaptive V-Sync (I couldn't find the setting). I think this is because I have GSync but not sure?
Anyway, here's what I did to fix the stutters for me. I disabled v-sync in the game, forced it on in the NVidia driver. I then set the FPS flag to 59FPS on the startup option in Steam.

Voila, smooth as butter!!

p.s. I LOVE THIS GAME! Amazing so far!

Andrew_WOT
24-09-2017, 22:44
Here's more interesting stuff. I fired up NVidia Inspector and for Project Cars 2 profile it had these FPS limiters listed
240446

Tried them all from 60.7 up, 62.8 worked the best, incidentally the closest to 63. So you can set it there in NVidia Inspector or still pass in command param in Steam Client launch option for Project Cars 2
-fpscap 62.8

Works the same and from my initial testing works even better than 63.

240447

Tepp
24-09-2017, 23:26
My experience is different. I had a bad stutter with V-Sync Off, even when Fraps showed about 80-120fps. I enabled V-Sync in-game and in drivers for pCars2.exe: V-Sync On and Triple Buffer On, as well as set the -fpscap 65. Now the game runs very smooth. Of course I had to set the graphics as low as possible to keep the fps at 60 in heavy weather conditions with full grid.

Tepp
24-09-2017, 23:42
Thanks for everyone for the tips here. I tried all the steps but struggled with the Adaptive V-Sync (I couldn't find the setting). I think this is because I have GSync but not sure?
Anyway, here's what I did to fix the stutters for me. I disabled v-sync in the game, forced it on in the NVidia driver. I then set the FPS flag to 59FPS on the startup option in Steam.

Voila, smooth as butter!!

This is strange. When I tried to set the -fpscap to 60, it keeps stable 59fps, so you have to add some value, for example: to get 60, you have to set -fpscap to something like 63 or 65. If you set the 59 in steam, which I suppose sets the option "-fpscap 59", so the game is cutting fps to about 58. If you set the V-Synk On in drivers, it will drop the fps to a nearest multiple of 30fps. Seems you are getting "smooth as butter" at 30fps !!! ... :) What the Fraps show?

Andrew_WOT
24-09-2017, 23:53
My experience is different. I had a bad stutter with V-Sync Off, even when Fraps showed about 80-120fps. I enabled V-Sync in-game and in drivers for pCars2.exe: V-Sync On and Triple Buffer On, as well as set the -fpscap 65. Now the game runs very smooth. Of course I had to set the graphics as low as possible to keep the fps at 60 in heavy weather conditions with full grid.
You still need in driver vsync with fpscap.
If you use fpscap command line param, it effectively disables in game vSync, this is why you need to set one in driver.
And guys, do not use fpscap 60. I think you can safely go over 62.8 which is minimum for this to work, but you just make GPU work harder rendering extra frames with no real benefit as they get discarded by VSync.

pool101
25-09-2017, 00:37
This is strange. When I tried to set the -fpscap to 60, it keeps stable 59fps, so you have to add some value, for example: to get 60, you have to set -fpscap to something like 63 or 65. If you set the 59 in steam, which I suppose sets the option "-fpscap 59", so the game is cutting fps to about 58. If you set the V-Synk On in drivers, it will drop the fps to a nearest multiple of 30fps. Seems you are getting "smooth as butter" at 30fps !!! ... :) What the Fraps show?

I'm not getting 30fps as I have a GSync screen (which was in my post and my signature). I'm getting a very smooth 58-59 FPS .. without any micro stutters at all.

pyide_maybe
25-09-2017, 01:05
What's the best solution for AMD?

RadeonPro doesn't work with PCARS2 so I cannot force adaptive sync. No other nvidia inspector type equivalent. I've tried a few different things and capping the FPS to 60 via drivers or RTSS seems to provide the most consistent results, but I still notice the cars ahead of me stuttering a bit when turning corners despite the frame counter never faltering.

I'll have to try graphing it like Richard83945 sometime to see the frame timings in greater detail.

Andrew_WOT
25-09-2017, 01:49
Does AMD have equivalent to NVidia Adaptive vSync as command line param should work regardless of GPU. But you need both to make it work.

pyide_maybe
25-09-2017, 01:56
No adaptive sync option in the AMD drivers. RadeonPro (3rd party app) is used to force adaptive vsync in various games, but it refuses to function with PCARS2.

jonston
25-09-2017, 02:22
Bahhhh, none of this is working for me.....do you think SMS recognises the problem and will fix it?

Aldo Zampatti
25-09-2017, 02:26
No adaptive sync option in the AMD drivers. RadeonPro (3rd party app) is used to force adaptive vsync in various games, but it refuses to function with PCARS2.

For my AMD setup I've always used the -fpscap 60 limit from the command line. That helps.

Andrew_WOT
25-09-2017, 02:31
Bahhhh, none of this is working for me.....do you think SMS recognises the problem and will fix it?
It was there from PCars1, so there is a some slim hope.
Afraid it's something fundamental in rendering engine, but Kunos had similar problem and just fixed it in one of the patches.
May be Ian can just nicely ask Stefano, I am pretty sure he likes Ferraris.;)

RoccoTTS
25-09-2017, 10:58
Thanks guys for the tip !
Adaptive vsync and -fpscap 62.8 solved the micro stuttering, very smooth now.

B1rdy
25-09-2017, 11:09
Bahhhh, none of this is working for me.....do you think SMS recognises the problem and will fix it?I think people talk of different problems. One, that is caused by vsync by design, and one that has some other cause, unrelated to vsync and FPS in general. Therefore the fixes posted here, are only for the vsync issue. The other problem seems to be game engine related as I wittnessed it on three different systems with various severity (stuttering going from about 0.1 seconds to about a full second).

jonston
25-09-2017, 11:59
hmmm ok, here are my videos. is this the problem described here?

https://www.youtube.com/watch?v=Mf0ooMZjhmY&feature=youtu.be

https://www.youtube.com/watch?v=GqFLvCNX-og&feature=youtu.be

Maurice Boeschen
25-09-2017, 12:13
hmmm ok, here are my videos. is this the problem described here?

https://www.youtube.com/watch?v=Mf0ooMZjhmY&feature=youtu.be

https://www.youtube.com/watch?v=GqFLvCNX-og&feature=youtu.be

Dont think so. I dont have that at all, only little jittering in corners without this fps cap trick but not such bad stutter

pyide_maybe
25-09-2017, 20:57
For my AMD setup I've always used the -fpscap 60 limit from the command line. That helps.

That actually makes things much worse for me. The framerate fluctuates between 59 and 56 when I do that, compared to other suggestions of -fpscap 63 here + an external limiter, where it stays at a solid 60 but still shows slight stuttering at times.

meliodas
25-09-2017, 23:09
hi guys thanx for the imput ive got the game running perfectly offline all settings on high perfectly stable, yet when i play online i get all these micro stutters i thought it was my graphics and turned everything to low and it still stutters online, my assetto corsa runs perfectly online and off but i enjoy the variety of online public events on project cars but this kills all immersion any one got any ideas what i could try?

Aldo Zampatti
26-09-2017, 00:15
That actually makes things much worse for me. The framerate fluctuates between 59 and 56 when I do that, compared to other suggestions of -fpscap 63 here + an external limiter, where it stays at a solid 60 but still shows slight stuttering at times.

Try VSYNC Enabled with Render Frames Ahead=1.

In *SOME* scenarios this might also help smooth things out without adding (too much, if any) input lag. Might worth a shot.

BUT if you do this, you must have not any dips into mid 50s.fps

Wings11
26-09-2017, 10:51
Hi all,

I've used the tips in this forum and it nearly removed all my problems but I also had to make a couple of changes to my settings on the monitor itself. (LG)

I've finally cured the problem totally by doing the changes to the monitor, plus the fixes in here PLUS a clean install of my Nvidia drivers and everything is perfect!

Thanks everyone, I also would agree with others because this should be stickied.

Daynja
26-09-2017, 14:12
I get massive stuttering, a glitchy HUD UI/editor & buggy driver name/avatar visuals if i I use the triple screen spanning option (no nvidia surround), especially when it comes to corners/braking. Its so off putting that I switched to NVSurround (7870x1080) and kept to a single screen res option in game @ 7870*1080 (stretch) and the FPS frame time is vastly improved although it looks awful on the left & right screen compared to triple screen spanning.

NVCP set to Fast Sync
Game command line set to 63

HLR Ghosty
26-09-2017, 14:19
hmmm ok, here are my videos. is this the problem described here?

https://www.youtube.com/watch?v=Mf0ooMZjhmY&feature=youtu.be

https://www.youtube.com/watch?v=GqFLvCNX-og&feature=youtu.be

Thats what I get but not as severe since upgrading to the GTX 1060 G1 at the weekend

SimonJ
26-09-2017, 15:44
Thats what I get but not as severe since upgrading to the GTX 1060 G1 at the weekend

yep have similar with GTX1070 not as bad though and mainly noticeable on corners will try few more settings later

Gabe777
26-09-2017, 15:50
If anyone is interested, I found this works for a number of games like.... SKYRIM, GTA5 etc.

I set 70 fps in frame limiter in nvidia inspector, and force on vert sync, keeping it off in the game.

I have a 60hz HDTV, so it still runs at 60 fps 1080p, but it erradicates stutters when rotating the camera on the z axis..... turning around etc.

Don't know why, but it had something to do with the poor way the game times the frame buffers.

The OP here uses 63 fps.... a few above the desired fps..... so just experiment as it probably depends on your particular system.

Being able to use the command line allows a specific number to be set, whereas in nvidia inspector it is only 50, 59, 60 or 70.

Sorry to butt in, but this interesting observation is actually useful elsewhere as well. Thought I'd share.

Andrew_WOT
26-09-2017, 16:59
If anyone is interested, I found this works for a number of games like.... SKYRIM, GTA5 etc.

I set 70 fps in frame limiter in nvidia inspector, and force on vert sync, keeping it off in the game.

I have a 60hz HDTV, so it still runs at 60 fps 1080p, but it erradicates stutters when rotating the camera on the z axis..... turning around etc.

Don't know why, but it had something to do with the poor way the game times the frame buffers.

The OP here uses 63 fps.... a few above the desired fps..... so just experiment as it probably depends on your particular system.

Being able to use the command line allows a specific number to be set, whereas in nvidia inspector it is only 50, 59, 60 or 70.

Sorry to butt in, but this interesting observation is actually useful elsewhere as well. Thought I'd share.
Weird, I have full range including fractions in NVidia inspector
http://forum.projectcarsgame.com/showthread.php?51812-Stutter-Fix&p=1364310&viewfull=1#post1364310

IJerichoI
27-09-2017, 06:00
I was reading a bit regarding this topic and eventually tried out a bit yesterday. Although I didn't really have had a problem with my old settings, but I am seriously impressed. I run standart settings with my specs, the only changes are no AA and SMAA Ultra (works well for me) and I get mostly 60FPS with some drops in really harsh conditions.

So I did the following:

1) Turn on adaptive VSync in the Nvidia Control Panel
2) set "maximum power" in the Nvidia Control Panel (don't remember the name of the setting)
3) set -fpscap 63 in the start options of the game
4) Turn off VSync ingame

This really lead to more stable frame times and a very smooth picture. Of course with a 60hz monitor. Really good tips in here.

Andrew_WOT
27-09-2017, 16:14
I was reading a bit regarding this topic and eventually tried out a bit yesterday. Although I didn't really have had a problem with my old settings, but I am seriously impressed. I run standart settings with my specs, the only changes are no AA and SMAA Ultra (works well for me) and I get mostly 60FPS with some drops in really harsh conditions.

So I did the following:

1) Turn on adaptive VSync in the Nvidia Control Panel
2) set "maximum power" in the Nvidia Control Panel (don't remember the name of the setting)
3) set -fpscap 63 in the start options of the game
4) Turn off VSync ingame

This really lead to more stable frame times and a very smooth picture. Of course with a 60hz monitor. Really good tips in here.
Try 62.8 that can smooth it out even more.

koly
27-09-2017, 17:23
force vsync with nvidia panel resolve all.
no need to use adaptive.

Andrew_WOT
27-09-2017, 17:30
force vsync with nvidia panel resolve all.
no need to use adaptive.

Any advantage using regular sync over adaptive?
Adaptive just prevents halfing frame rate if you dip under 60 even a bit. But if you never go under 60, you won't notice the difference.

pyide_maybe
27-09-2017, 18:23
I think my problem at this point may just be the look to apex option in the helmet causing visual stutters. People have mentioned that the camera movement coupled with the turning of your car can create some visual anomalies.
I'm using a 75hz freesync display which is already a form of adaptive syncing, and limiting the framerate to 60 via RTSS.

I tried graphing the frametime via msi afterburner, and the game was pinned at ~16.667ms the entire race, but the other cars were still stuttering a bit as we're going around corners.
Although in the normal cockpit view I still see it stuttering at times, but it is less obvious than automatic looking to the apex view.
I suppose I just have to deal with it. It's not a major hitching issue like it seems to be for some of you. These are just microstutters, it's not affecting the whole game, either. Just causing the other cars on the track to stutter a bit rather than display smoothly.

Zeiss
29-09-2017, 16:20
I have this issue as well. It started with Pcars 1 and seems to still be here in pcars 2. The fix didnt work for me. However, strangely, going from 670 GTX in SLI to a single 1070 gtx started the stuttering for me in pcars 1. With the 670 SLI setup I had no micro stutters. Strange because a single 1070 is faster than SLI 670. Has to be some technical issue for certain.

pablito
30-09-2017, 08:48
Dont know what happend because everything was perfectly fine after long fight with setting...but from yesterday stutter/corner freeze and fast forward effect is again there :( ... but nothing changed on my side.

:mad:

Zeiss
30-09-2017, 15:16
Stutters are gone now. The fix was to use Rivatuner statistic server beta 7. Set frame rate cap to game refresh rate (mine is 100) and set detection level to high. Also, I set vsync to on in control panel, and off in game. I also set prerendered frames to 3 in game. Smooth as glass, and no more micro stutters.

Aldo Zampatti
01-10-2017, 03:31
Dont know what happend because everything was perfectly fine after long fight with setting...but from yesterday stutter/corner freeze and fast forward effect is again there :( ... but nothing changed on my side.

:mad:

What are your system specs?? That might be CPU bottlenecking.

ShimonART
01-10-2017, 07:07
i only have stutter on multiplayer session during practice and qualifying sessions. probably because people are joining the lobby.

pablito
01-10-2017, 08:19
What are your system specs?? That might be CPU bottlenecking.

That was funny situation and strange..

im on laptop Lenovo Y720, i5-7300, 16GB ram, gtx1060...but...in some magical way steam transfered my games from ssd to second disc.
now everything is rock solid on high/ultra 60fps (except replays :P ) no stutter freezing anymore!

Mariangello
01-10-2017, 09:15
Dont know what happend because everything was perfectly fine after long fight with setting...but from yesterday stutter/corner freeze and fast forward effect is again there :( ... but nothing changed on my side.

:mad:

I had same problem, what helped me was turn off headphone mix in audio settings.

mister dog
01-10-2017, 11:49
I had same problem, what helped me was turn off headphone mix in audio settings.
I use the headphone mix too, how does that cause stutters and freezes? Yesterday I was playing online and on each start the image would freeze a couple of times, happened during the first corners when everyone was bunched up. The game/image then unfreezes itself after a second or 2 so I must make sure that I kept the car on the asphalt in the meantime or I wake up in the barriers.

This happened only in online races so I was wondering bug/netcode/ GPU? I'm planning on upgrading from a GTx960 to a 1060 anyway so it would be nice if that would help :p.

Anyhow because of this I'm a bit of a Maldonado online now before turn 1... Better stay clear before my rep sinks to the bottom this way.

Andrew_WOT
01-10-2017, 17:49
I use the headphone mix too, how does that cause stutters and freezes? Yesterday I was playing online and on each start the image would freeze a couple of times, happened during the first corners when everyone was bunched up. The game/image then unfreezes itself after a second or 2 so I must make sure that I kept the car on the asphalt in the meantime or I wake up in the barriers.

This happened only in online races so I was wondering bug/netcode/ GPU? I'm planning on upgrading from a GTx960 to a 1060 anyway so it would be nice if that would help :p.

Anyhow because of this I'm a bit of a Maldonado online now before turn 1... Better stay clear before my rep sinks to the bottom this way.

Most likely netcode, definitely not the problem and solution in OP.

mister dog
01-10-2017, 20:41
Most likely netcode, definitely not the problem and solution in OP.
Too late I already ordered it :p :D

Yes I think you're describing small micro stutters in corners right, not sure if the solution would help with the 3 second freezes I had. Did you have these long freezes online too?

vbracer
21-10-2017, 23:20
I have gtx960 with almost everything on low.
The 62.8fps limiter helps (not eliminates) with stutter during driving mostly.
Replays are a complete Stutter-Fest (more so with AI cars).

Then if I return to desktop and start Assetto Corsa/Automobilista/Dirt4 I get silky-smooth zero stutter with a 12-car grid during a smoking start of the race (Driving view AND Replays).
You can't convince me this is not purely an issue with this games graphics coding.
I only write this negative graphics review in the hope that SMS can improve in the Graphics/FPS in this game (after all it is still young).
Because truly, the Physics/Car replay behaviour are superb!

e270889o
22-10-2017, 00:09
Try vsync on in game + adaptive in nvidia control panel + pre render 2

Only way to achieve stutter free for me. Some games like bf1 works fine with adaptive only (vsync off in game) but with this game I have to enable both.

Andrew_WOT
22-10-2017, 00:43
I have gtx960 with almost everything on low.
The 62.8fps limiter helps (not eliminates) with stutter during driving mostly.
Replays are a complete Stutter-Fest (more so with AI cars).

Then if I return to desktop and start Assetto Corsa/Automobilista/Dirt4 I get silky-smooth zero stutter with a 12-car grid during a smoking start of the race (Driving view AND Replays).
You can't convince me this is not purely an issue with this games graphics coding.
I only write this negative graphics review in the hope that SMS can improve in the Graphics/FPS in this game (after all it is still young).
Because truly, the Physics/Car replay behaviour are superb!
Can you try fraps or other fps monitor, your fps are dropping, it has nothing to do with judder fix.

AEIDOLONE
26-10-2017, 16:04
Ok... I applied the OP method and it fixed this constant stutter, and the game runs smooth....... - but I still have a one-time big stutter EVERYTIME I hit a wall, an another car, and even when those race info labels appear (like Lap Invalidated etc...) the game stutters!

I love this game, but it's driving me crazy.

Aldo Zampatti
26-10-2017, 16:06
Ok... I applied the OP method and it fixed this constant stutter, and the game runs smooth....... - but I still have a one-time big stutter EVERYTIME I hit a wall, an another car, and even when those race info labels appear (like Lap Invalidated etc...) the game stutters!

I love this game, but it's driving me crazy.

What are your CPU specs?

AEIDOLONE
26-10-2017, 20:39
What are your CPU specs?

i5 6400 @ 3.10 Ghz

Aldo Zampatti
27-10-2017, 00:01
i5 6400 @ 3.10 Ghz

Try monitoring the CPU and see if you see any weird CPU behavior in that second when you see this stutter.. Maybe CPU utilization goes 100% on one or all cores for a split second or something like that.

RomKnight
27-10-2017, 10:24
I'm sure it's more than a second or two.

My 4670k is at 4.2 and it's over 80 and on the 90% more often than not

mononokehime
27-10-2017, 13:47
Glad to see I'm not the only one with weird stutter and fast forward effect. I have a i5 4430, 8go of ram and a GTX 1060. I noticed that the issue is more often to ocure when I have settings on High than middle or low. Also try 4K and Low, Game was playable at 50 fps but with more stutter than ever. My games are in a different disk than the system, both 2To HDD WD.

I noticed two different kind of stutter :

The loading stutter, when the game seems to load something when I have, for eg, an accident or when I finish a first lap ou when I hit a wall.

The corner stutter, when I take a corner, the game stops and load several pictures at once and suddenly I end up in a wall or off track, or by any chance, I try to maintened my curve. I let you imagine when it happened in a online race !

I try to avoid stutter by closing several apps but I can't close Steam or another critical apps.

I think, when the track is loading, the track isn't at 100% loading in the Ram or in the GPU, it's seems to load when we playing and after 3 or 4 laps the stutter stops because the game loads everything that it's needed for him.

I'll will try to lower the settings again tonight especially with low textures to see the impact on the game.

Andrew_WOT
04-12-2017, 02:47
Seems like v3.0 patch fixed the issue, you can remove fpscap.
Thanks SMS.

H1LLIER
04-12-2017, 13:44
Until recently mine was nice and smooth using RTSS to limit FPS to 60 and v-sync on in game. I'm getting frame dips using that method now, it's only 1 or 2 fps but is very noticeable as the game normally runs so smoothly. With FPS cap and v-sync off it ticks along nicely at 100+ FPS so it's not a GPU power issue but the tearing , oh the tearing.

I'll try the 62.8 limit later and hopefully the extra overhead will eliminate the dropped frames.

What would people suggest as a good track and weather combo for benchmarking? Highest stress for the GPU

Andrew_WOT
04-12-2017, 18:16
I am still using Nvidia Advanced vsync, not the one in game, and max prerendered frames set to 1. Just removed fpscap from command line option.
Make sure that you have the latest NVidia driver, there were some issues in 388.13 with micro freezes related to GPU power monitoring. Has been fixed since.

MISTER WU
05-12-2017, 00:31
Until recently mine was nice and smooth using RTSS to limit FPS to 60 and v-sync on in game. I'm getting frame dips using that method now, it's only 1 or 2 fps but is very noticeable as the game normally runs so smoothly. With FPS cap and v-sync off it ticks along nicely at 100+ FPS so it's not a GPU power issue but the tearing , oh the tearing.

I'll try the 62.8 limit later and hopefully the extra overhead will eliminate the dropped frames.

What would people suggest as a good track and weather combo for benchmarking? Highest stress for the GPU

I would say Azure, rain and full race grid lol.
That will push the GFX card and CPu

H1LLIER
05-12-2017, 09:58
I am still using Nvidia Advanced vsync, not the one in game, and max prerendered frames set to 1. Just removed fpscap from command line option.
Make sure that you have the latest NVidia driver, there were some issues in 388.13 with micro freezes related to GPU power monitoring. Has been fixed since.

Ok I'll try the latest drivers. I'm using a driver that's about 4 or 5 revisions old after updating a few times and finding they were causing instability so I reverted back to 1 I knew was stable.

When you say "advanced v-sync" do you mean adaptive?

BigDad
05-12-2017, 10:50
Until recently mine was nice and smooth using RTSS to limit FPS to 60 and v-sync on in game. I'm getting frame dips using that method now, it's only 1 or 2 fps but is very noticeable as the game normally runs so smoothly. With FPS cap and v-sync off it ticks along nicely at 100+ FPS so it's not a GPU power issue but the tearing , oh the tearing.

I'll try the 62.8 limit later and hopefully the extra overhead will eliminate the dropped frames.

What would people suggest as a good track and weather combo for benchmarking? Highest stress for the GPU

LongBeach at 18:00 maxes out my GPU and even CPU and is a test to see if settings will hold up .
Just change seasons and weather to suit but even just clear at 18:00 because of shadows and some corners are not so well optimised .

Andrew_WOT
05-12-2017, 16:30
Ok I'll try the latest drivers. I'm using a driver that's about 4 or 5 revisions old after updating a few times and finding they were causing instability so I reverted back to 1 I knew was stable.

When you say "advanced v-sync" do you mean adaptive?

Yes, adaptive, sorry.

Martin03
30-01-2018, 01:52
I have had this problem for a long time, and tried all fixes people post, included the ones in this post. But it does not help, still stuttering/screen freezing even if FPS is stable

GTX 1060
i7700
16gb RAM
Windows 10

Sankyo
30-01-2018, 07:40
I have had this problem for a long time, and tried all fixes people post, included the ones in this post. But it does not help, still stuttering/screen freezing even if FPS is stable

GTX 1060
i7700
16gb RAM
Windows 10

What input device are you using? What graphics driver version? What background applications do you have running, including anti-virus?

Martin03
30-01-2018, 12:21
What input device are you using? What graphics driver version? What background applications do you have running, including anti-virus?


Im using T500rs, graphic driver 390.77, pretty much just discord(not using voice just have discord itself running) and steam ofc running, virus program is Norton

Zenzic
30-01-2018, 13:12
What fps are you getting when leaving it uncapped? What value are you capping your fps at? What's your gpu load percentage with fps capped?

For me stutters were caused by varying frame times. Capping my fps well below the value my gpu could reach when left uncapped caused my gpu load to go down a bit and evened out my frame times. No more stutters.

I can imagine this frame time variance becomes much less noticeable at much higher frame rates. Around 65 fps however, a frame time variance from 18 ms to 36 ms was very noticeable, even with my frame rate remaining more or less stable.

Martin03
30-01-2018, 14:18
What fps are you getting when leaving it uncapped? What value are you capping your fps at? What's your gpu load percentage with fps capped?

For me stutters were caused by varying frame times. Capping my fps well below the value my gpu could reach when left uncapped caused my gpu load to go down a bit and evened out my frame times. No more stutters.

I can imagine this frame time variance becomes much less noticeable at much higher frame rates. Around 65 fps however, a frame time variance from 18 ms to 36 ms was very noticeable, even with my frame rate remaining more or less stable.

Have tried to cap FPS to 58.9, 60, 62.8 and 63 with no differance in stuttering/freezing

And not tested to much what avarage FPS is uncapped, but on Spa practice mode in foggy conditions it was 105-120FPS. And when it freezed GPU load was 98%, but GPU load is supposed to be high as long as temps are normal ofc. If you're not using 100% of your available resources than something is being bottlenecked which is unnecessarily hindering your performance. eg Having your GPU at 50% while your CPU is at 100% means you spent a lot more on your GPU than was necessary, as you could have gotten away with something half as powerful while getting the same performance.

pferreirag60
30-01-2018, 15:08
Maybe your cpu? mine never goes more than 25%, of course the gpu in perfect conditions should be at 99%, but if cap at your minimum fps or better if you can, at your refresh rate, no more stutters.

In my case my main monitor is 100hz but the other ones are 60hz, so I cap at 60 Hz, even so because i cannot maintain 100 fps with 3 monitors all the time in all conditions. But as mine minimum is about 68 fps, i cap at 60 with adaptive vsync enable and novsync in game.

Martin03
30-01-2018, 16:11
Maybe your cpu? mine never goes more than 25%, of course the gpu in perfect conditions should be at 99%, but if cap at your minimum fps or better if you can, at your refresh rate, no more stutters.

In my case my main monitor is 100hz but the other ones are 60hz, so I cap at 60 Hz, even so because i cannot maintain 100 fps with 3 monitors all the time in all conditions. But as mine minimum is about 68 fps, i cap at 60 with adaptive vsync enable and novsync in game.

Well, as told earlyer I have tried to cap it to many differant frames, and use adaptive vsync and not ingame. But no matter what I do the result is the same, smooth frames but with stuttering/freezes here and there

AEIDOLONE
30-01-2018, 16:15
Well, as told earlyer I have tried to cap it to many differant frames, and use adaptive vsync and not ingame. But no matter what I do the result is the same, smooth frames but with stuttering/freezes here and there

The game is just not enough optimized. I've done also pretty much everyrhing (fps cap, adaptive vsync, windows, borderless etc) It's smooth. But every now and than it stutters a little. (i.e. when hitting the wall, another cars, and even on bumps etc) I'm talking minimal hiccups, but still...

pferreirag60
30-01-2018, 18:42
yes, me too, I have that kind of hicups, they are rare and miliseconds of time, but they are there, even more rare in single player and only when hitting a wall a big hicup, maybe 1 second.

If I donīt count that hicups, or not go online, it is perfectly smooth.

Another kind of bug, accelerated time, and going backwards in the circuit, i only do that in practice of course and in the 2 fantasy road tracks, the shadows flash and if you use rain, sometimes the sky flash(not thunderstorm). When i said backwards, i mean before the finish i turn the car around and race to the begin :) I just love the road tracks to much, pity that there are only 2, and we have so much road cars

Martin03
30-01-2018, 19:33
For me they can be rarely and they can be quite often, but they are often not just small hicups but can last for 2-3sec and when in middle of a corner that can end your race pretty fast...

So this makes the game unplayable for me right now, speccialy since I like Endurance races, and no way im going to start a 2hour+ race and just wait for this to ruin the race

Pollinflas
16-02-2018, 22:34
Thanks!!! It work for me.

Fuzzy
16-02-2018, 23:17
A lot of these issues sound like either graphics drivers or cpu threshold. Adding system specs to sigs would help others to help. Using monitoring software like afterburner would also help. Disabling 3rd party antivirus is also a good idea, as is turning down the number of ai if you have older hardware.

ironcobra
08-03-2018, 22:41
If you suffer from weird stuttering, judder, stroboscope effect in turns when camera moves around quickly, here's the solution that worked for me.
After trying everything to fix that annoyance I used same trick that worked in pCars1.
1) Turn Vsync off in game
2) Force Adaptive Vsync in video driver
3) Add the following launch options in Steam game properties -fpscap 63
(Also Try 62.8 see this post (http://forum.projectcarsgame.com/showthread.php?51812-Stutter-Fix&p=1364310&viewfull=1#post1364310[) (#25), not 100% sure though if 62.8 vs 63 makes a difference, could be placebo, but it does look smoother, not worse for sure :))

You can even set prerendered frames to 1, it's still smooth and doesn't tax GPU as much plus eliminates input lag.

Finally, butter smooth gameplay. :)

P.S. It wouldn't help if your GPU can't keep up, only if you get that stuttering at otherwise stable 60fps.

241896

You sir are the man, the slight stutters on my 1080ti were killing me at 4k this completely fixed them and now its butter smooth thanks alot!!