PDA

View Full Version : Patch 1.1.2.0 - Multiplayer fix- Killed G29 Wheel and Pedal response in game



Dingo7222
23-09-2017, 03:39
After the update my G29 steering wheel won't respond in game. I load into races with a bumper cam (never used it before) and cannot change it and cannot do anything with the wheel or pedals. I loaded up Beam to test it and it works fine still so its not the wheel... :(

It seems like the wheel is not even plugged in even though when I click on the control menu it has a G29 set up there but when I go to calibrate the pedals or the wheel everything stays at zero. It was working for the 7 hours of play prior to the update lol

Morgan Henstridge
23-09-2017, 03:55
Have you checked that the G29 is still the selected controller profile??

Also have you tried to Edit Assignments and see if you can configure the wheel again?

Dingo7222
23-09-2017, 04:05
The G29 is still the selected controller and in the edit assignments tab I I cannot set anything to any buttons on the wheel or set any axis to steering, throttle, brake or clutch. When I click on say steering left and turn the wheel nothing happens. When I click calibrate pedals it says center undefined and stays at zero while I press the pedals :/

Morgan Henstridge
23-09-2017, 04:08
That is odd.

MAybe try changing it from the Logitech profile ingame to custom wheel and then exit.

reload the game and see if you can assign anything in the Custom Wheel Profile.

If you can, then re-select the Logitech profile and restart the game and see if it is responding again.

Dingo7222
23-09-2017, 04:10
I will give that a go as soon as I finish reinstalling it hahaha which will take a while, Thanks for the help I will let you know if it works!

Dingo7222
23-09-2017, 15:22
Dang, I reinstalled, still nothing, I tried setting it as a custom wheel and went to the edit assignments tab and I cannot assign anything the the wheel or pedals still, it just sits at Please assign the new configuration screen until I hit escape, then it says Multiple inputs were detected. No action was assigned. I can however remap my handbrake to my keyboard which is where I have had it from the beginning but I can map anything to the keyboard just nothing on the wheel. Weird.

Dingo7222
23-09-2017, 16:04
FIXED!!!!!!!!!!!!!!! :D
Alright so I read the other forum post with the G920 not working and he did a driver uninstall and reinstall and it worked. This is what I did.

With everything plugged in and turned on,
Opened Device Manager and found Logitech G29 Driving Force Racing Wheel USB and right clicked and uninstalled, I also check the box that said Delete driver software for this device
There is also a device that says Logitech G29 Driving Force Racing Wheel USB (HID) I left that alone and it disappeared when I uninstalled the above.

Next I When to the control panel and uninstalled Logitech Gaming Software 8.96

Next redownloaded and reinstalled Logitech Gaming Software 8.96 from their website
After my pc restarted I opened up Project Cars 2 and remapped everything on my wheel and pedals that I cared about in the INGAME Controls menu, Not sure if it matters but that is the menu I used.

So I started Project Cars 2 started a private race, hit start, tried to drive, couldn't.
Hit escape, clicked on controls and when to edit assignments, I had to remap everything on my wheel and pedals, even though "nothing" changed I had to do it to get it to work. I say "Nothing" changed because everything had an asix or button already assigned and I had to go through and reassign that same key , button or axis to that action.

Hope that helps someone out there.

Thanks to Morgan Henstridge for helping too!!!

Gabe777
03-06-2018, 17:54
This is still happejing with tge G29.

What a joke.

I have many games working just fine.

It will be cold day in hell before I reinstall drivers for any one particular game. Too many profiles that I have fine tuned, to lose.

Not a chance.

This game is a joke. Always has been.


Uninstalling now.


Sick of it. Not worth it. Bin it.