PDA

View Full Version : Game won't launch.....



Devilmanzero
23-09-2017, 08:30
Hi all,
As the title says, game won't launch.....

Has anyone else had this problem?
It's a steam deluxe version.
Basically I try to start the game in non vr mode and the side menu says "running" then it flashes to syncing and that's it.

So I have had a look on the forum and see that a few had a similar issue on pcars 1, but I see nothing for pcars 2.

Drivers are up to date.
Turned off all windows defender firewalls.
Re-installed the game.
Tried launching from GeForce experience. (but have the message unable to retrieve current game settings. Starting or closing the game should fix this problem.)
Check the game isn't running in the background.
Tried launching directly from the games folder using the .exe and failing that even tried the old renaming trick. (But was greeted by C:\windows\system32\vcomp140.dll contains an error, try reinstalling or get support!
Re installed.

I am out of ideas really so welcome thoughts and ideas on how I might get going.
Using a Thrustmaster wheel knob peddle combo and haven't even bothered to plug in the Vive yet....

Pc spec
Windows 10
i7-7700k
gtx1080
16g ram

jonnotheone
23-09-2017, 11:10
1st thing i would recomend is to set the pcars2 exe to run as administrator go to local disk> programfiles86> steam> steam apps> common> pcars2... And look for the exe rigjt click and tick box that says run as administrator..
Hope that helps.

Morgan Henstridge
23-09-2017, 11:22
Check the Windows Event Viewer > Application and System logs and see what windows is logging at the time of this crash.

Devilmanzero
23-09-2017, 15:32
1st thing i would recomend is to set the pcars2 exe to run as administrator go to local disk> programfiles86> steam> steam apps> common> pcars2... And look for the exe rigjt click and tick box that says run as administrator..
Hope that helps.

I tried this and it comes up with the message

pCARS2.exe - Bad Image C:\WINDOWS\SYSTEM32\VCOMP140.DLL is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc000012f.

Thanks for the effort tho.

Devilmanzero
23-09-2017, 15:33
Thanks for the advice, I looked at the log and it comes up with this at the various times that I attempted to get into the game

pCARS2.exe - Bad Image C:\WINDOWS\SYSTEM32\VCOMP140.DLL is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc000012f.

Question is where do I get a new vcomp140.dll?
thanks in advance!

Mahjik
23-09-2017, 16:13
Try this...

Go into your Steam folder under Project CARS 2:

\Steam\steamapps\common\Project CARS 2\_CommonRedist\vcredist\2012

Try running vcredist_x64.exe (or vcredist_x86.exe if you are 32-bit which I doubt) as Administrator. I've seen some reports with other applications of the same error which pointed to the Visual C++ runtimes.

Mad Al
23-09-2017, 16:18
It's part of the Visual C++ 2015 redistributable

It should be installed from

<Steam Install Folder>\SteamApps\common\Project CARS 2\_CommonRedist\vcredist\2015

that looks like an issue with the 32 bit version, so run the file Microsoft Visual C++ 2015 x86.cmd

it might be worth deleting vc_redist.x86.exe first and doing a steam integrity check to get a fresh copy.


edit: ninja'd, must type faster

jonnotheone
23-09-2017, 16:18
I assume you have alos verified the files through steam too...

Devilmanzero
23-09-2017, 17:16
I assume you have alos verified the files through steam too...

I did, but forgot to put that in the details...... sorry bout that.

Aldo Zampatti
23-09-2017, 17:27
can you try launching it with -avx ?
If that still fails, remove that one and add -sse2
That basically launches two different EXEs

Devilmanzero
25-09-2017, 16:07
Try this...

Go into your Steam folder under Project CARS 2:

\Steam\steamapps\common\Project CARS 2\_CommonRedist\vcredist\2012

Try running vcredist_x64.exe (or vcredist_x86.exe if you are 32-bit which I doubt) as Administrator. I've seen some reports with other applications of the same error which pointed to the Visual C++ runtimes.

Ok, so I have tried that... unfortunately it didn't work. I tried both the repair and the uninstall/reinstall. On both 64 and 86. This included deleting the exe and grabbing a new one from verification from steam. Still saying the same thing...

Devilmanzero
25-09-2017, 16:13
can you try launching it with -avx ?
If that still fails, remove that one and add -sse2
That basically launches two different EXEs

Ok, so I tried with the avx and it comes up with the same message, this was after I reinstalled them by deleting, verifying and then reinstalling them. Sse2? You have to forgive me as I'm not a pro on the pc, and I'm not sure exactly where/what I need to do there.... had a good look about but didn't find that file?

gecervi
25-09-2017, 18:14
I have the same problem every time I turn on the PC, and I must do the procedure described above "<Steam Install Folder> \ SteamApps \ Common \ Project CARS 2 \ _CommonRedist \ vcredist \ 2015

that looks like a problem with the 32-bit version, so run the Microsoft Visual C ++ 2015 x86.cmd file

it might be worth deleting vc_redist.x86.exe first and doing a steam integrity check to get a fresh copy.
", otherwise I" CRASHA ", how ever, what can you do ??? do i know the developers? i have windows 10 64bit.

gecervi
08-10-2017, 09:32
242180

attached crash log files, help me

Pyjter
11-10-2017, 17:24
Someone solved this ?

Ronnie Peterson
25-11-2017, 17:14
Someone solved this ?

In a word no!

dmelan7
25-11-2017, 19:03
In a word no!

If you are talking about demo >>> I had same problem then I attempted to launch game from steamapps/common/pc2 demo folder bu clicking .exe file . I get .dll error then I downloaded vcomp140.dll and placed it into the system32 folder and eventually game launched.

Roger Prynne
25-11-2017, 19:40
http://windowsreport.com/fix-missing-vcomp140-dll/

valman100
28-12-2017, 13:09
Installing the Visual C++ Redistributable for Visual Studio 2015 from the Microsoft website fixed it for me on the demo.

Didn't even need to use all the steps from the link above. Just download the x64 version and hit run. After that it started right up!