View Full Version : Does dedicated server for Linux work?

23-09-2017, 11:38
I've set up a dedicated server for Project Cars 1 and it works fine.

Using SteamCMD on Linux I downloaded the app, (I'm not allowed to posts link apparently as I'm new, but its the app I found on SteamDB) I also tried 413772 and it downloads succesfully but the actual content is blank? Nothing is in the download?

Has anyone managed to get it working on Linux?

23-09-2017, 11:41
I should note when trying to download the linux depot 413772 I get

ERROR! Failed to install app '413772' (No subcription)

Marc Wieneke
23-09-2017, 12:13

Installation via steamcmd on linux:
At the moment you have to login to steam with steamcmd to execute: ./steamcmd.sh +login STEAM_USERNAME +force_install_dir ./pcars2 +app_update
413770 validate +quit

But there are no files transfered, not on windows and not on linux. It says "progress: 0,00 (0 / 0)....fully installed!"

./steamcmd.sh +login ****** +force_install_dir /home/pcars2/serverfiles +app_update 413770 validate +quit
Redirecting stderr to '/home/pcars2/Steam/logs/stderr.txt'
[ 0%] Checking for available updates...
[----] Verifying installation...
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.

Logging in user '******' to Steam Public...
Using cached credentials. . .
Logged in OK
Waiting for user info...OK
Update state (0x5) validating, progress: 0,00 (0 / 0)
Success! App '413770' fully installed.
But there are no game files afterwards.

Installation via steamcmd on Windows yesterday does not worked either but today it works.

23-09-2017, 17:32
Yes the Download over SteamCMD on Linux don't work correct.