PDA

View Full Version : Project cars 2 dropped frame/stuttering/freezing gameplay issue



jonston
23-09-2017, 13:57
Hi guys, was wondering if someone can help me, this problem just developed and i cant figure it out, i was playing it fine 3 days ago when i got my pre release license key, but this morning its started having an issue with the game play. i have tried changing the render frames ahead to 4,3,2 and 1 but it still does it. i have upgraded to the lastest nvidia driver and still the same. im getting an average of about 75 frames and my pc isnt a slouch. like i said it was running fine. now doesnt matter which c ar or track i drive in i get the same issue. i have turned off all the external programs to see if it helped but it was to the same too.

my pc specs

intel 7700k
32 gb ram
512gb m2 ssd
gigabyte aorus extrem 1080ti
3x benq xr3501
osw DD wheel
Hpp pedals
5dof motion

you can see it in this video, but its must worse in real life

https://www.youtube.com/watch?v=GqFLvCNX-og

any suggestions?

Kitt
23-09-2017, 15:04
Kinda looks like the same problem I had but not quite as bad,this fixed it it for me http://forum.projectcarsgame.com/showthread.php?51812-Stutter-Fix

jonston
24-09-2017, 09:50
Thanks but this did not fix it. my other friend is having the same issue now too. it was right after the patch was rolled out. anyone else having this issue?

pablito
25-09-2017, 06:21
Mine freezing in three cases.

First changing, saving car setup and second when someone joining/leaving online session.

Third most annoying...corners. Few corners after start new track is tragedy. Freeze, fast forward, wall :D

davidtriune
06-11-2017, 07:55
i just upgraded to a 1080 ti and am having these strange stutter issues that I never had on my 970. using zotac amp extreme core. The post above didn't help..

Raklodder
06-11-2017, 08:05
The way I was able to remove most of my stutter was to disable v-sync (or set it to "-fpscap 60" in my launch options) and playing in Windowed mode to get rid of a few unexpected freezes.

B1rdy
06-11-2017, 11:06
When this game becomes CPU bound (due to GPU upgrade maybe), you could experience weird slowdowns and speed-ups. Also Nvida driver 388 (and later) have reported bad frame timing in a number of games.

jonston
06-11-2017, 12:58
I tried all the above fixes and more. what made it better for me was to uninstall all the nvidia drivers, after i uninstalled one, the last one would show out in control panel, so i repeated all it until there was nothing left. it worked for a while, but then degraded again.

it must be something in the OS itself, because it got to a point where i just said fuck it, ill reinstall windows. did that 2 days ago, 388 drivers went on straight away, creaters update on, game mode off. now im getting 20 more frames then what i did before no turning off vsync, no fps cap bullshit and shes runs silky smooth. getting avg 75 fps on ultra/high @ 7680x1080

davidtriune
07-11-2017, 03:53
I think I fixed some of the lag by reducing my monitor refresh rate. I found my issue is called "judder" which only happens with head movement on the oculus (also see "stroboscope"). Playing on my monitor is no problem. If you VR then maybe try https://support.oculus.com/1636962739910975/. Another person reinstalled his OS and it went away https://www.reddit.com/r/oculus/comments/4k14kb/just_got_my_cv1_experiencing_serious_judder_what/

I'm going to try these as soon as I get my new computer from newegg (black november sales).

theborv
05-03-2018, 11:12
I get judder/freeze both in vr and on monitor (without vr). I have tried everything mentioned here and elsewhere:
Reinstalled windows
Tried different refreshrates
Tried different graphics settings
Disabled various services mentioned around on the internet

It was good for a few days after reinstalling windows, but degraded again.

I would think it's either driver related, or project cars software related. Something is poorly coded somewhere.

satco1066
06-03-2018, 20:04
if you have installed the latest nVidia driver, try to go back 1 or 2 versions.
some of our league had similar issues with 391.01

theborv
18-03-2018, 00:19
if you have installed the latest nVidia driver, try to go back 1 or 2 versions.
some of our league had similar issues with 391.01

tried that, no difference

Max Torque
20-03-2018, 22:34
I have mini-lags, too. For me, it only occurs if I have other cars close to me online (VR). It feels like reloading from hard disk. Game is installed on SSD, GTX 1080TI, 7700K, 16 Gig Ram. Should be fine. Runs perfectly smooth otherwise, only with other cars around I get this stuttering.

Max Torque
21-03-2018, 20:28
So you do not have any problems in Oculus? Could you upload your Oculussettings file?

flowerdealer
21-03-2018, 23:05
I also have mini lags with Windows MR. More visible with other cars around, but visible other times too. Feels like a stuttery reprojection.

Laserbeak43
03-04-2018, 07:56
Same here. was playing fine for a week on a new PC and new Rift, now it's unplayable.

theborv
03-04-2018, 22:00
Stuttering update: I installed Windows 8.1 Pro x64 instead of Windows 10 Pro x64, and so far the stuttering has gone. I will keep you posted.

bigj_pcars
05-04-2018, 12:24
hey guys ;)

My system is running stable and flawless in 4K@50Hz.

I opened this thread: http://forum.projectcarsgame.com/showthread.php?62456-pCars-2-running-flawlessly-here-system-specs-and-what-i-did-to-get-there

Maybe the ideas and info can help ;)

mvoosten
12-04-2018, 09:09
Same, some weird reprojection issue when moving head very fast. Like a brief stutter witth a double image on Oculus VR. Running 4790K, 1080TI 16GB on Windows 10 with latest NVIDIA divers. Tried clean install, different NVIDIA drivers. No solution though.
This happened about 2-3 weeks ago after swapping my 1070 to 1080i, might be cooincedence. What I did notice however is that when I DOWNCLOCK my videocard so it forces ASW (increasing performance settings to all high etc is a hit and miss with conditions) it seems ok... but then I'm at 45fps instead of desired 90fps

Please note that this reprojection issue ONLY occurs with PCars2. All other games tried to date with the new config don't show the issue. And yes, got enough headroom left according to Oculus debug tool. Even when it runs at 90fps the reprojection issue occurs.