PDA

View Full Version : Strange graphical issues in VR



rosko
23-09-2017, 17:18
I'm getting some strange glitches in VR. This could also be in standard monitor but i never use one. Hard to describe but i will try. A frame will quickly flash up (like a millisecond)that is completely different to what is currently happening in game, it's so quick it's hard to tell what it is. But it did it once when i got out of the car & i could clearly see the image was inside the car as could notice the dashboard lights. Maybe its a subliminal message for us to buy the next SMS game, you know that will be the next SMS conspiracy;). I think i noticed it happen when somebody was playing the game on youtube so i don't think it just affects me.

other less strange happenings.
Another issue is popup on some tracks is really quite bad. This is at the side of the fov, in Barcelona it is really bad for example & its unplayable for me.

Advertising boards (long thin ones around the track)can be really glitchy & the textures are flickering, it seems to do this consistently at parts of certain tracks.

Siberian Tiger
23-09-2017, 17:23
That one Frame will be solved in an upcoming Patch.
We did find this at the late Time of WMD Phase.

For Pop-Ups please take Screenshots from specific Tracks note your Graphic Settings, and Highlight those Objects that Pops-In.

For the Advertising Boards, that Sound like Z-Fighting you can Play with that Setting: Camera Near Clip Plane in the VR Settings...

rosko
23-09-2017, 17:38
That one Frame will be solved in an upcoming Patch.
We did find this at the late Time of WMD Phase.

For Pop-Ups please take Screenshots from specific Tracks note your Graphic Settings, and Highlight those Objects that Pops-In.

For the Advertising Boards, that Sound like Z-Fighting you can Play with that Setting: Camera Near Clip Plane in the VR Settings...

Can i take a screenshot in VR?

Siberian Tiger
23-09-2017, 17:45
Yes, should work... F12 Steam-Screenshot

edcwhite
23-09-2017, 18:59
A frame will quickly flash up (like a millisecond)that is completely different to what is currently happening in game, it's so quick it's hard to tell what it is

Same issue here. Glad to know I am not alone and even more glad to hear there is a fix on the way.

rosko
23-09-2017, 19:54
That one Frame will be solved in an upcoming Patch.
We did find this at the late Time of WMD Phase.

For Pop-Ups please take Screenshots from specific Tracks note your Graphic Settings, and Highlight those Objects that Pops-In.

For the Advertising Boards, that Sound like Z-Fighting you can Play with that Setting: Camera Near Clip Plane in the VR Settings...

I put this up to 0.10 and it helped alot although it's still there, it seems by far the worse at Fuji & Sugo. Its not advertising boards but just the white barrier around the track, seems maybe tyres behind are clipping through, maybe worth looking at.
Is there a disadvantage ie framerates at having this set to 0.10 over 0.04 as i really don't understand the setting?

Gloomy
23-09-2017, 20:58
I've had that frame flash as well, I just figured it was something to do with the poor performance of my 1070, good to know it'll be patched.
The last turn on nurburgring gp, the red and white fencing flicker really bad, I can see it flicker a bit on a couple of other turns, but it's the worse on that last turn. It's slightly noticeable outside of vr, but in vr it's really distracting.

RomKnight
23-09-2017, 21:24
I have played today some events trying to beat my times of late yesterday on triples (I did because VR is awesome :D) and in both CotA and Knockhill I had no issues.

But I know what you guys are talking about as I had that before.

Great to hear a fix is coming (not unexpected though).

Rikirk
24-09-2017, 12:00
Can you please confirm your setting in the signature are for the Vive and not triple screen. I have a Vive as well on 1080ti and can't find the best compromise yet to really enjoy this gorgeous 'SIM'.

rosko
24-09-2017, 13:00
The VR for me is in another league in terms of performance versus other games i really can't get over how great it looks. With certain cars it did struggle for some reason i'm not sure why. Might be an idea to start a specific thread for VR maybe a sticky & people can exchange tips & issues.

Morgan Henstridge
24-09-2017, 13:25
I put this up to 0.10 and it helped alot although it's still there, it seems by far the worse at Fuji & Sugo. Its not advertising boards but just the white barrier around the track, seems maybe tyres behind are clipping through, maybe worth looking at.
Is there a disadvantage ie framerates at having this set to 0.10 over 0.04 as i really don't understand the setting?

if you have this very low, then your headset can get right up close to things like the headrests on the drivers seat without clipping, but having this too low can then introduce Z fighting in the scenery. So its a balancing act to find what works well with your particular preferences and settings, but the default setting should be a good middle ground.

MarleyMoo
08-01-2018, 19:49
I thought resurrecting this thread might be more useful than starting a new one, so...

I just got the new HP Windows Mixed Reality headset, and I'm getting the problem described by OP, where the game randomly shows one frame from a very wrong perspective. The game is pretty smooth otherwise. Anyone else got this with WMR headsets?

Olijke Poffer
08-01-2018, 19:55
if you have this very low, then your headset can get right up close to things like the headrests on the drivers seat without clipping, but having this too low can then introduce Z fighting in the scenery. So its a balancing act to find what works well with your particular preferences and settings, but the default setting should be a good middle ground.

I altered this near clip. I can’t find what the default is. Any ideaż

satco1066
08-01-2018, 20:37
default is 0.07

Yorke
08-01-2018, 20:45
I've got an issue that seems pop up randomly with the Occulus, I will be driving and then this juttering begins, when I move my head left and right, vice versa. It happened several times during a league race, I could take the headset off and watch my monitor. And then put the headset back on and it would sometimes go away. It seems that taking the head set off resets it or something. A fellow league member has the same problem from time to time with the Occulus.

I put the recommended settings in and normally don't have problems, it's really come up lately. Not sure if its a Microsoft update issue or not. I reverted back on the Winter Update and a lot of problems went away, but that one continues to pop up randomly.

MarleyMoo
09-02-2018, 20:20
Any idea if this is fixed in the newest patch? I really can't tell from the change log.

rosko
09-02-2018, 20:38
Yes well at least so far.

Dunwich Horror
09-02-2018, 22:45
I've got an issue that seems pop up randomly with the Occulus, I will be driving and then this juttering begins, when I move my head left and right, vice versa. It happened several times during a league race, I could take the headset off and watch my monitor. And then put the headset back on and it would sometimes go away. It seems that taking the head set off resets it or something. A fellow league member has the same problem from time to time with the Occulus.

I put the recommended settings in and normally don't have problems, it's really come up lately. Not sure if its a Microsoft update issue or not. I reverted back on the Winter Update and a lot of problems went away, but that one continues to pop up randomly.

Yorke, I have the same exact issue. I think it started with an nVidia driver update months ago and every one since then, the issue still existed. I was hoping the latest PC2 patch (1.4) would fix, but unfortunately it doesn't appear so. If anything, I'd say the issue is actually worse now. I'm kinda gutted - I can no longer enjoy the game with this issue and I've tried every combination of pretty much setting imaginable trying to figure it out to no avail. I refuse to revert to some old nVidia driver to fix this. I have no other issues with any other VR game (I play quite a bit of RaceRoom - never had any problems with this jutter issue), just PC2.

morpwr
10-02-2018, 00:31
Yorke, I have the same exact issue. I think it started with an nVidia driver update months ago and every one since then, the issue still existed. I was hoping the latest PC2 patch (1.4) would fix, but unfortunately it doesn't appear so. If anything, I'd say the issue is actually worse now. I'm kinda gutted - I can no longer enjoy the game with this issue and I've tried every combination of pretty much setting imaginable trying to figure it out to no avail. I refuse to revert to some old nVidia driver to fix this. I have no other issues with any other VR game (I play quite a bit of RaceRoom - never had any problems with this jutter issue), just PC2.

Got it in a usb 3 or 2 port because it definitely doesn't happen on mine and hasn't in along time. Your pc specs might help too.

MarleyMoo
10-02-2018, 05:01
I just ran a few laps and it seems fixed. Good job SMS!

rosko
11-02-2018, 00:52
The flickering barriers & fences as described in my original post are worse than ever for me. It's very distracting Nuremberg especially bad. I have to dump my grx setting as it looked very blurry & super sampling didn't work, that is now fixed but now this glitch seems to have returned. Any solution for this?

MrTulip
11-02-2018, 08:41
The flickering barriers & fences as described in my original post are worse than ever for me. It's very distracting Nuremberg especially bad. I have to dump my grx setting as it looked very blurry & super sampling didn't work, that is now fixed but now this glitch seems to have returned. Any solution for this?

I haven't noticed (easily noticeable) flickering since late nVidia 388.xx drivers (currently using 388.71). Seeing that you have the same graphics card we could compare our settings.

Graphicsconfigoculusdc11.xml
----------------------------

<data class="GraphicConfigData" id="0x423448E0">
<prop name="Name" data="" />
<prop name="Build" data="980" />
<prop name="Version" version="2" />
<prop name="Mode" adapter="0" width="2160" height="1200" refresh_num="59972" refresh_dem="1000" />
<prop name="Vsync" vsync="1" />
<prop name="FrameLatency" framelatency="1" />
<prop name="AntiAlias" antialias="2" />
<prop name="SMAAFXAA" smaafxaa="0" />
<prop name="Windowed" windowed="1" />
<prop name="TextureFilter" texturefilter="5" />
<prop name="TextureResolution" textureresolution="2" />
<prop name="Brightness" brightness="10" />
<prop name="CarDetailLevel" cardetaillevel="3" />
<prop name="TrackDetailLevel" trackdetaillevel="3" />
<prop name="ShadowDetailLevel" shadowdetaillevel="4" />
<prop name="MotionblurLevel" motionblurLevel="0" />
<prop name="EffectsDetailLevel" effectsdetaillevel="2" />
<prop name="EnvmapDetailLevel" envmapdetaillevel="4" />
<prop name="MirrorEnabled" mirrorenabled="0" />
<prop name="MirrorEnhanced" mirrorenhanced="1" />
<prop name="EnvmapReflectionDetailLevel" envmapreflectiondetaillevel="4" />
<prop name="GraphicsLevel" graphicslevel="4" />
<prop name="SuperSampling" supersampling="0" />
<prop name="LowSuperSampling" lowsupersampling="0" />
<prop name="VRSuperSampling" vrsupersampling="4" />


Oculussettings.xml
------------------

<data class="OculusConfigData" id="0x42622C60">
<prop name="Name" data="" />
<prop name="Build" data="980" />
<prop name="FullScreen" data="false" />
<prop name="HideCrowds" data="false" />
<prop name="Limit Movement" data="false" />
<prop name="VSync" data="false" />
<prop name="OnlyPlayer" data="false" />
<prop name="ResetVR" data="9" />
<prop name="LimitCars" data="20" />
<prop name="NearZ" data="0.045" />
<prop name="GForce" data="0.75" />
<prop name="WorldMovement" data="0.75" />
<prop name="exposureFOV" data="60" />
<prop name="IPD_Scale" data="0.980391" />
<prop name="ResScale" data="1.4" />
<prop name="EyeOffsetY" data="0.03" />
<prop name="EyeOffsetZ" data="-0.05" />
<prop name="PointerSwitchTime" data="10" />
<prop name="PointerSwitchShortTime" data="3" />
<prop name="PointerTriggerTime" data="1.5" />
<prop name="PointerTriggerWarnTime" data="1" />
<prop name="PointerTriggerArea" data="0.01" />
<prop name="HUDSettings" offSetX="-0.011350" offSetY="-0.094500" offSetZ="-0.284419" scale="0.303003" rotateX="-0.231001" rotateY="0.003453" rotateZ="-0.001319" rotateW="0.972946" />
<prop name="FrontEndSettings" offSetX="0.000000" offSetY="0.000000" offSetZ="-1.000000" scale="1.000000" rotateX="0.000000" rotateY="0.000000" rotateZ="0.000000" rotateW="1.000000" />
<prop name="InGameSettings" offSetX="0.000000" offSetY="0.000000" offSetZ="-1.000000" scale="1.000000" rotateX="0.000000" rotateY="0.000000" rotateZ="0.000000" rotateW="1.000000" />


Edit: I tested at Nordscheife where I remember last seeing flickering shadows and graffiti issues in the fences but they were fine to me now. I've been lately driving with time starting at 16:00 with 15x accelerated time, and I think that these can affect it too.

My graphics settings are generally almost everything at max, anisotropic at 16 and AA at Medium. I haven't had need for lowering settings; if I have problems with performance, I lower VR supersampling (ReScale), which is currently at 1.4.

BigDad
11-02-2018, 09:56
Yorke, I have the same exact issue. I think it started with an nVidia driver update months ago and every one since then, the issue still existed. I was hoping the latest PC2 patch (1.4) would fix, but unfortunately it doesn't appear so. If anything, I'd say the issue is actually worse now. I'm kinda gutted - I can no longer enjoy the game with this issue and I've tried every combination of pretty much setting imaginable trying to figure it out to no avail. I refuse to revert to some old nVidia driver to fix this. I have no other issues with any other VR game (I play quite a bit of RaceRoom - never had any problems with this jutter issue), just PC2.

I've had this exact issue in RaceRoom on the VLN Nords when i've had SS to High and my FPS are dropping below 45 on the first sequence of corners , after that lot of corners my FPS increase but the stutter/judder persists and is only resolved by removing the HMD and putting it straight back on again . This won't happen again till i get to a point where the FPS drop below 45 .
If i just lower SS to a point where the FPS are stable above 45 it never happens .

Dunwich Horror
11-02-2018, 13:00
I've had this exact issue in RaceRoom on the VLN Nords when i've had SS to High and my FPS are dropping below 45 on the first sequence of corners , after that lot of corners my FPS increase but the stutter/judder persists and is only resolved by removing the HMD and putting it straight back on again . This won't happen again till i get to a point where the FPS drop below 45 .
If i just lower SS to a point where the FPS are stable above 45 it never happens .

Thanks for the info BigDad. I've done a ton of testing again since I last posted.

I'm editing this post because I think I have the problem solved. I now believe the primary source of the issue is/was Oculus Tray Tool. I saw somewhere on reddit in an old post someone stating it's a stutter-inducing tool - and whattya know - I'd been using it for so long in so many other games with no issue, I (stupidly) didn't think it could be the cause of the issue with PC2. I uninstalled it for good and now I've been able to dial up the settings again - everything looks and runs great now. Even if and when I notice some minor ghosting/juddering a bit when ASW kicks in, it will clear itself up once the fps gets back up to better speed. With the Tray Tool active and no matter what settings I used, the moment judder hits - there was no turning back. Even taking off the HMD didn't always resolve it. Sometimes I'd have to quit out of the game.

Thank Cthuhlu I can just get back to enjoying the game. :eagerness:

rosko
13-02-2018, 18:11
https://youtu.be/OyAy-H_hLn4

video of the fence issue at Nuremberg can see it on this bend & also final bend. Its a problem on many tracks & looks worse in VR. Looks like tyre wall are too close to the boarding & clip through.

i have gone through & try all setting for gfx & nothing seems to help.


-<data id="0x42622C60" class="OculusConfigData">
<prop name="Name" data=""/>
<prop name="Build" data="980"/>
<prop name="FullScreen" data="false"/>
<prop name="HideCrowds" data="false"/>
<prop name="Limit Movement" data="false"/>
<prop name="VSync" data="false"/>
<prop name="OnlyPlayer" data="false"/>
<prop name="ResetVR" data="9"/>
<prop name="LimitCars" data="20"/>
<prop name="NearZ" data="0.07"/>
<prop name="GForce" data="0.15"/>
<prop name="WorldMovement" data="0.5"/>
<prop name="exposureFOV" data="60"/>
<prop name="IPD_Scale" data="0.970874"/>
<prop name="ResScale" data="1.4"/>
<prop name="EyeOffsetY" data="0.03"/>
<prop name="EyeOffsetZ" data="-0.05"/>
<prop name="PointerSwitchTime" data="10"/>
<prop name="PointerSwitchShortTime" data="3"/>
<prop name="PointerTriggerTime" data="1.5"/>
<prop name="PointerTriggerWarnTime" data="1"/>
<prop name="PointerTriggerArea" data="0.01"/>
<prop name="HUDSettings" rotateW="0.991491" rotateZ="0.000239" rotateY="-0.001818" rotateX="-0.130163" scale="0.533526" offSetZ="-0.464928" offSetY="-0.071439" offSetX="-0.049721"/>
<prop name="FrontEndSettings" rotateW="1.000000" rotateZ="0.000000" rotateY="0.000000" rotateX="0.000000" scale="1.000000" offSetZ="-1.000000" offSetY="0.000000" offSetX="0.000000"/>
<prop name="InGameSettings" rotateW="1.000000" rotateZ="0.000000" rotateY="0.000000" rotateX="0.000000" scale="1.000000" offSetZ="-1.000000" offSetY="0.000000" offSetX="0.000000"/>
</data>


-<data id="0x423448E0" class="GraphicConfigData">
<prop name="Name" data=""/>
<prop name="Build" data="980"/>
<prop name="Version" version="2"/>
<prop name="Mode" refresh_dem="1000" refresh_num="59883" height="1050" width="1680" adapter="0"/>
<prop name="Vsync" vsync="1"/>
<prop name="FrameLatency" framelatency="1"/>
<prop name="AntiAlias" antialias="3"/>
<prop name="SMAAFXAA" smaafxaa="0"/>
<prop name="Windowed" windowed="0"/>
<prop name="TextureFilter" texturefilter="1"/>
<prop name="TextureResolution" textureresolution="2"/>
<prop name="Brightness" brightness="10"/>
<prop name="CarDetailLevel" cardetaillevel="2"/>
<prop name="TrackDetailLevel" trackdetaillevel="2"/>
<prop name="ShadowDetailLevel" shadowdetaillevel="4"/>
<prop name="MotionblurLevel" motionblurLevel="0"/>
<prop name="EffectsDetailLevel" effectsdetaillevel="2"/>
<prop name="EnvmapDetailLevel" envmapdetaillevel="3"/>
<prop name="MirrorEnabled" mirrorenabled="0"/>
<prop name="MirrorEnhanced" mirrorenhanced="0"/>
<prop name="EnvmapReflectionDetailLevel" envmapreflectiondetaillevel="3"/>
<prop name="GraphicsLevel" graphicslevel="4"/>
<prop name="SuperSampling" supersampling="0"/>
<prop name="LowSuperSampling" lowsupersampling="0"/>
<prop name="VRSuperSampling" vrsupersampling="4"/>
</data>

M4MKey
13-02-2018, 20:59
Some very very heavy shadow flickering at Fuji, around 6 AM. Tried on both clear and light cloud, it's doing the same. during midday it's perfect though.

https://www.youtube.com/watch?v=ig-X8C-Wo4s

MrTulip
13-02-2018, 21:09
I have lots of flickering at Fuji (inside cockpit, not on the track), but I have to say that I haven't seen flickering on the track for two days now that I've been paying attention to it. I'll check those places at Nurbs tomorrow to see if they flicker for me. I drive quite a lot on different tracks, so I'm bit puzzled why it is that bad for you.

That bug is familiar for me too, but I haven't seen it for a long time now. It was much more common with PCARS1 and with PCARS2 I recall seeing it only with buggy nvidia driver versions.

rosko
13-02-2018, 23:55
Some very very heavy shadow flickering at Fuji, around 6 AM. Tried on both clear and light cloud, it's doing the same. during midday it's perfect though.

https://www.youtube.com/watch?v=ig-X8C-Wo4s

Pretty sure that is caused by sun shining through trees. Irl the shadow would be diffused over distance.

M4MKey
14-02-2018, 07:30
Not sure about the tree thing Rosko. I mean, I don't even think there are trees on the way with the sun. And wherever I am on the track, the shadow ( only on cockpit ) are blinking like that. It's quite intrusive as well and I can't drive on this track during morning times. I need to check the sunset too to see if it's doing the same.

Bealdor
14-02-2018, 11:12
https://youtu.be/OyAy-H_hLn4

video of the fence issue at Nuremberg can see it on this bend & also final bend. Its a problem on many tracks & looks worse in VR. Looks like tyre wall are too close to the boarding & clip through.

i have gone through & try all setting for gfx & nothing seems to help.



Increase this setting: <prop name="NearZ" data="0.07"/>

This should reduce the Z-fighting.

MrTulip
14-02-2018, 17:51
https://youtu.be/OyAy-H_hLn4

video of the fence issue at Nuremberg can see it on this bend & also final bend. Its a problem on many tracks & looks worse in VR. Looks like tyre wall are too close to the boarding & clip through.

i have gone through & try all setting for gfx & nothing seems to help.


Yup, I too see this at Nurbs, exactly the same locations as in your video. Direction of the sun seems to affect it somewhat; at 4:00pm there is less of it and at 8:00am there is lots more flickering on almost all tyre wall textures, usually in direct or close to direct angle when sun shines behind the player (but it can be seen on the shadow side too sometimes from that angle).

NearZ does not seem to have any effect on it (I restarted the game in between changes and tried the default 0.045, 0.01, 0.07 and 0.1). Curiously I haven't seen flickering this noticeably on other tracks; usually I'm at Nords, Long Beach, Brae, Donington, Oulton, Brands, Algarve or Sakitto. The rest I keep changing, and Nurburgring GP track has not been my favorites.

rosko
14-02-2018, 19:41
Not sure about the tree thing Rosko. I mean, I don't even think there are trees on the way with the sun. And wherever I am on the track, the shadow ( only on cockpit ) are blinking like that. It's quite intrusive as well and I can't drive on this track during morning times. I need to check the sunset too to see if it's doing the same.

Yeah it does seem a bit crazy, is it just inside the car?

rosko
14-02-2018, 19:43
Increase this setting: <prop name="NearZ" data="0.07"/>

This should reduce the Z-fighting.

It doesn't seem to help in this instance, b4 patch it would reduce it i think.

M4MKey
15-02-2018, 11:13
Yeah it does seem a bit crazy, is it just inside the car?

Yes, only inside the car, and only the shadows on the cockpit ( those on the bonnet are looking fine )

rosko
17-02-2018, 12:49
Mods are any devs looking into this at all? for me it seems a bit of a shame to have these flickering shadows & textures in game when everything else looks so nice. I know there are sometimes limitations with game engines but it would be nice to know either way.

rosko
02-03-2018, 19:08
Can't really understand why this is not being looked at all its an issue on so many tracks, Monza, Nuremberg, Brno? If its down to the engine i would rather you just say.

Mahjik
02-03-2018, 19:15
Can't really understand why this is not being looked at

Who said it's not?

rosko
03-03-2018, 08:15
Who said it's not?

Well because nobody said it is.

Mahjik
03-03-2018, 16:03
Well because nobody said it is.

95% of the things on the Patch 4 list, no one (besides SMS) knew were being worked on. You've been here (and other game forums) long enough to know that you will never know everything that is going into game patches. The reverse psychology approach doesn't work.

rosko
04-03-2018, 00:22
95% of the things on the Patch 4 list, no one (besides SMS) knew were being worked on. You've been here (and other game forums) long enough to know that you will never know everything that is going into game patches. The reverse psychology approach doesn't work.

No reverse psychology here, i'm just trying to establish if i need to provide more video examples or if the issue is likely my pc. Often things are stated as being looked into http://forum.projectcarsgame.com/showthread.php?54338-Investigating-Bugs-Problems-with-weather-system-and-random-weather
& sometimes things are dismissed for various reasons. I often assume its the later if nothing is said, what else can i do other than guess :confused: if i don't know. And looking into something is one thing getting it patched something else entirely & yes the latter is not something i expect to know.

Charger
04-03-2018, 01:28
'latter'