PDA

View Full Version : [RESOLVED] Project Cars 2 - Failed To Save (Possible workaround for others)



SLOPPY1000
23-09-2017, 21:23
Does anyone know how to resolve my save issue, the game starts from the beginning every time I load it and it won't save even control settings! Not being lazy I've looked round the forum and it seems this was a known problem with PC1 but can't find much about PC2 other than I have checked the game is allowed passed the firewall and I only used Windows Defender running Windows 10 and to be honest I'm reluctant to turn my security off just to play a game, I really hope I don't have to reinstall the game. Screen shot below......

240351

Many thanks in advance :D

Dragnet
23-09-2017, 21:34
Same here, I have installed Malwarebytes and paused Windows Defender and still the same error...

(P1 works fine on the same PC.)

Mad Al
23-09-2017, 21:44
Make sure to add an exclusion in whatever AV/Malware/Internet security stuff you have for the <Steam Install dir>\SteamApps\common\Project CARS 2

see if that helps

Dragnet
23-09-2017, 21:52
Make sure to add an exclusion in whatever AV/Malware/Internet security stuff you have for the <Steam Install dir>\SteamApps\common\Project CARS 2

see if that helps

Only using Windows Defender now, still the same problem.

SLOPPY1000
24-09-2017, 15:08
RESOLVED woohooooo Its been a long afternoon but finally got it to save. Here's what I did....

It seems Project Cars 2 doesn't like my Windows 10 so I've now got the game to run in Compatibility Mode and to run as an Administrator, unfortunately you can't do this from your Project 2 icon that's on your desk top you need to change the said settings from the root installation directory but don't worry if you haven't done this before it's pretty easy......


We need to locate the pCARS2.exe so simply open Steam and goto your games library, right click over Project Cars 2 and select Properties at the bottom.......

240410

When the next window pops up select the Local Files tab, now select Browse Local Files........

240404

In the next window you will see the pCARS2.exe file.......

240411

Right click on that and select properties, change to Windows 7 in the dropdown box, then tick the box that says Run as an administrator, now click Apply.......

240405

All that's left to do is delete the original Project Cars 2 shortcut on your desktop and replace it with the one you've just amend in the folder, simply right click over the amended pCARS2.exe and select create desktop shortcut.

Boooom you're done....Enjoy :D

Mahjik
24-09-2017, 15:29
That's good information, but it seems there might be something else going on. Many people are running W10 without this issue so it may be a combination of things or a specific configuration of W10.

SLOPPY1000
24-09-2017, 15:35
Indeed I thought the same myself, I guess if there are a few people as is with the other poster with this issue they could try my workaround.

Thanks for the feed back :D

Dragnet
24-09-2017, 15:59
I have now tested this and no luck, same problem :mad:

Mad Al
24-09-2017, 16:19
I have now tested this and no luck, same problem :mad:

Did you change both pCARS2.exe and pCARS2AVX.exe ?

if you have newer hardware it should run the AVX version (not that I'm convinced this is anything other than a workaround that may help the odd person here and there..)

Dragnet
24-09-2017, 17:42
Did you change both pCARS2.exe and pCARS2AVX.exe ?

if you have newer hardware it should run the AVX version (not that I'm convinced this is anything other than a workaround that may help the odd person here and there..)

Not at first, did this now....no change :(

SLOPPY1000
24-09-2017, 21:08
Not at first, did this now....no change :(

I'm interested on what specs your system has, please will you give us your specs hardware and operating system :D

MISTER WU
24-09-2017, 22:06
Im guessing this might have more to do with user Account Control settings than anything else.?
Open elevated Dos prompt (Windows key + X in WIN10) then run UserAccountControlSettings.exe and set it to the second lowest setting.
See if that works.

Dragnet
25-09-2017, 06:42
Im guessing this might have more to do with user Account Control settings than anything else.?
Open elevated Dos prompt (Windows key + X in WIN10) then run UserAccountControlSettings.exe and set it to the second lowest setting.
See if that works.

As said in my other post http://forum.projectcarsgame.com/showthread.php?52064-Can-t-save-settings&p=1363978&viewfull=1#post1363978
it works if I run from a local account (Win 10 Creators update with a local Documents folder) and not my regular domain account with the Documents folder on my domain controler (Server 2012 Essentials).

Stocky
26-09-2017, 18:27
Tried everything in this thread, I can't save over existing saves either.

Only way to save, is to a new file, and then delete the other.

KING_JOHN22
07-02-2019, 18:07
type allowed apps beside the windows start menu on windows 10 click on+add an allowed app find project cars or any game that your having problems saving on then boom your good to go for anyone else having the problem