PDA

View Full Version : Clutch acting like a button?



reembank
23-09-2017, 22:12
I've been using my Logitech G920 on Project Cars 1 and Assetto Corsa for months with no issue with the clutch, where it can be pressed half way and tapered out to set off slowly, etc etc, but when it comes to Project Cars 2, it's basically staying 100% off until it bottoms out, and then goes 100% on.

Is anyone else having this issue, or is this part of the game design? I absolutely loved how the clutch worked in PC1 so I'm a tad confused as to why it's like this now. I've posted this on the Steam discussions page too, and other users have had the same problem. (can't link because new account)

Siberian Tiger
23-09-2017, 22:14
You can try to reassign the Clutch... (in the options menu)
There you will see if it is detected as an Axis....
Perhaps on default it's thinking thats it's a digital button...

reembank
23-09-2017, 22:19
Forgot to mention that I've tried calibrating, re-assigning and messing with deadzone and sensitivity without much change at all. Auto-clutch is disabled. :(

konnos
23-09-2017, 23:41
I am reporting the same thing. Clutch is an axis and it shows also in the telemetry. But, there is only like a 10% travel distance in which it works and that is towards almost fully pressed. So if I am in Neutral and i want to get rolling, it will engage almost immediately so I have to feather it with lots of gas especially in high power cars.

konnos
24-09-2017, 14:37
Shameless bump. Deadzone on clutch has no effect on the problem and neither does the sensitivity.

Coanda
24-09-2017, 14:46
For me i notice i can engage the clutch 80% which shows on the widget however it does nothing. Its all in the last 20%. Also I tested the Mercedes C9 & and whilst engaging the clutch the revs drop from 9k to idle in less than a second...

konnos
24-09-2017, 15:12
Yes that's what I am describing too. Ok maybe it's not exactly 10% travel distance, but something along that value, it's really low.

reembank
24-09-2017, 15:13
Glad other people are having the same issue - I was worried when I couldn't find anything on it.

Are we all using Logitech G920s or are there other wheels? One guy on a steam thread has said he's experiencing the same on a G27.

Siberian Tiger
24-09-2017, 15:13
So basically you would like to adjust the "Bite"-Point of the Clutch. Right?

konnos
24-09-2017, 15:14
Yes and if it's possible to control the range of it. It bites almost immediately and the effect has too little distance to activate, so it's almost on-off unless I really feather it.

Siberian Tiger
24-09-2017, 15:15
Go it... Added to the Wishlist... :)

reembank
25-09-2017, 00:57
Nice one, just seemed like it was broken rather than intentional.

BeG-PCARS
25-09-2017, 01:43
I copy that. I have the same feeling that the clutch basically is almost uncontrollable - almost impossible to hit the sweet spot to let clutch come in a controlled fashion. Despite the analog axis (Fanatec v3 pedals) it feels like a button like others have reported already.

Eric Rowland
25-09-2017, 07:49
I'm in the same boat as well. The clutch's bite point is at the far point of the pedal travel. The activation point needs to be in the 30-50% range I would think. Thank you.

Boneboys
25-09-2017, 08:51
Hello all, first post so let me explain my thoughts on this subject.
I have previously posted on the Steam Hub in a Topic that has unfortunately been lost in the flood and may have gone unnoticed.
********************************
"There is something fundamentally wrong with how the clutch works (or not) when driving a manual geared car in PC2.

Changing gear in a manual gear shift car without using the clutch should break the gear box or the gear concerned, if not at first then after repeated shifts with sound effects to match.

I've played around with the config by resetting the clutch pedal max limit to 50% without success.
If anyone has found a setting please post here.

By pushing the clutch fully down while driving in-game you will notice that the clutch does in fact function somewhat but not as it should.

I've been driving real cars for longer than I care to mention and the way that PC2 has this implemented is not how a clutch works.

If any of you that have played AC will know, there is a satisfactory and (near) realistic clutch/gear system.

I can only assume that this is an error/bug and will be fixed in the future.

G29 + shifter."
*********************


Thank you.

Tepp
25-09-2017, 09:19
Yea, the same here on CSL pedals. Things get worst because these pedals has a pretty long throw. I managed to use it by pressing fully down and keeping there longer than usually on up-shifts. It's strange, but I have no problems with the downshifts (heel-toe), maybe because the revs are lower, don't know. I thought this was my bad habit or wrong technique, but it worked fine in AC.

Edit:
- Other games have a saturation slider in config, it could help with that.
- I think (some) real life cars have the same clutch behavior (long throw and early/short engaging point), so this may be done on purpose to eliminate bad habits ... :)