PDA

View Full Version : Thrustmaster T300RS



foxy31pl
24-09-2017, 10:30
Hi guys,
I have a problem with my steering wheel. A wheel is working fine in other games and in its software, but when I want to play PC2 it just seems to not see it.
When I go to calibration it is not seeing it. Yesterday I read here that I should assign it first in configuration, then go to calibration. It worked and I was able to play the game, but when I went to PC2 today it's not working again. I tried to assign the buttons but it is not seeing anything. I can only assign pedals, but not turning left, or right.
i tried unticking all the boxes in Steam, but it did not helped. I tried to unplug a shifter and plug it again, as I saw this somewhere, but did not help.
Also, it behaves weird it the main menu, sometimes I can use turning right/left in the menu and after few minutes I cannot do anything with my wheel.
Everytime I close the game the steam is showing a new 'patch' has been installed. Is that normal? Seems to be weird.
My current version is V1.1.2.0.0866.AVX if that helps.
Please could anyone help me with that as I spent a whole morning trying to play!
Thanks a lot
Kate

Rich_hard1
24-09-2017, 10:58
check your wheel is in PS3 Mode, front left hand side of the wheel.
check windows to see if your wheel is working as it should in thrust master control panel.

foxy31pl
24-09-2017, 11:05
Yes it is on PS3 and is working ok in thrustmaster control panel.
All updates everywhere are done also..

Mahjik
24-09-2017, 13:46
What are you using for A/V? Some programs are aggressive and might think PC2 is a virus which interferes with it's saving.

foxy31pl
24-09-2017, 15:19
I'm using Biddefender, not really sure which option to disable to make it work?

Mahjik
24-09-2017, 15:26
I'm using Biddefender, not really sure which option to disable to make it work?

As a test, shut it completely off and see if you still have the same issue. If it works, then it will just be adding in the proper exclusions. If it doesn't make a difference with it not running, then the problem is somewhere else. However, Bitdefender is known to be a problem.

GTsimms
24-09-2017, 15:52
In game select the wheel in control scheme. Bottom reset to defaults and try calibration.

crowhop
24-09-2017, 15:57
Had an issue with my T300 also. Steam ended up being the reason I couldn't use it.

In Steam, go to:

STEAM > SETTINGS > CONTROLLER > GENERAL CONTROLLER SETTINGS

First, make sure all of your devices are listed there at the bottom.
Second, make sure you've disabled any of the check boxes.

Your screen should look like this:
240415

Dady Cairo
24-09-2017, 17:29
Take the Microsoft DEFENDER alone,that is enough security for the system.No Problems after years.
DC