PDA

View Full Version : Turtle beach x420+ headset loss of game sound



Pbucko
24-09-2017, 21:02
Iíve had this issue from day 1 of pCars 2. Race starts and Sometimes i loose all game sound. I have to restart p cars to get it back. I donít have this problem on any other game, including p cars 1.

transfix
24-09-2017, 21:34
Happening with the Stealth 600 as well. I thought it was because of the new wireless technology. Good to know other models have the same issue.

Pbucko
25-09-2017, 07:59
It might not be my headset, I always play with tv sound on 0. I haven’t checked to see if the game sound is still coming out of tv when headset fails. I’ll check next time it happens.

Just Another Frog
25-09-2017, 10:37
Have you tried changing your output audio in the XB1 settings? There are several alternatives that you could try in order to improve headset audio so it might be worth experimenting with them.

Settings >> All settings >> Display and sound >> Audio output

Just pause ingame, return to dashboard to change the setting then return to your game and try it out.... Repeat until all alternative have been tried.

transfix
25-09-2017, 10:54
Changing settings does not fix it.

Just Another Frog
25-09-2017, 11:49
Changing settings does not fix it.

ok. It was just a thought.

Fractured Life
27-09-2017, 17:03
Changing settings does not fix it.

Do you have a wheel and an external hard drive connected as well as the receiver for the 420X? Mine were cutting out every so often after I purchased a wheel. It mostly comes back but occasionally needed to power off headset and remove and reconnect Receiver to get sound back. I thought maybe the power draw was too sever or something.

When i'm not using the wheel it always seems fine, no headset disconnects when using pad.

transfix
27-09-2017, 18:01
Wheel and External drive yes but no receiver since the Stealth 600 connects wirelessly like an Xbox Controller.

Pbucko
27-09-2017, 20:48
x420+ headset, xbox one s, tx wheel, ext drive. head set is wireless, dongle in usb at back of xbox. I have to restart xbox to get game sound back. i've had it happen about 5 times since release.