PDA

View Full Version : Menu and sub menu lag? [Workaround posted]



BreadedVirus
24-09-2017, 21:36
Getting lag on the menus and sub menus. When I select a car or track it kinda hangs there with the previous car and or track for about 10 seconds.

PS4 is my system



MOD EDIT: Please try the workaround at post #9 (http://forum.projectcarsgame.com/showthread.php?52477-Menu-and-sub-menu-lag&p=1366575&viewfull=1#post1366575)

Dev Nibor
24-09-2017, 21:43
Same here, very annoying

Zenzic
24-09-2017, 21:45
Same here on original PS4. Screen freezes for a few seconds when I select a new track in private practice and all input is ignored. Same thing with setups: when I'm in the pit garage and go to the setup screen everything freezes for a few seconds while it tries to load a shared setup. Audio seems to be looping during that freeze as well.

Youloze
25-09-2017, 00:49
I get massive lag on nearly all screens, especially when backing out of a race type (i.e.: career, online, quick race, etc). Take upwards of 20-30 seconds before I can move. I've seen many people complain about this so hopefully it will be patched.

Raklodder
25-09-2017, 01:01
I haven't experienced any menu lag apart from the input lag, but most games have that with v-sync enabled.

Mahjik
25-09-2017, 02:22
Getting lag on the menus and sub menus. When I select a car or track it kinda hangs there with the previous car and or track for about 10 seconds.

It has been reported.

Skid_Mark
25-09-2017, 08:53
Hello, i'm new here and i'm happy that i found this thread as i have the same problems. The strange thing is that after installment of the 52 GB the issue was not there. During playing the last 3 days the lags became more and more. Now the intro video is lagging at the beginning too. I think it has to to with the ghost- and setupfiles which get more and more and which are saved with the 2 savegame files in the "savegamefolder".

I'm on PS4 Slim. Digital Deluxe Version from German PS Store.
Thank You.
Skid_Mark

blairmann99
25-09-2017, 18:16
It has got so bad for me now it takes around a minute to make one input it it actually unplayable now. I am on ps4 and the game is truly unplayable now because of this. Even the start intro lags and just displays a grey screen. The setup menu lags, when trying to pick a new car in a lobby is near impossible because it takes about 2 mins and by that time everyone has already ready up and the game starts. If they don't fix this problem in the next few days the game is going to die what is a shame because I have been enjoying it before their started to get bad.

CrazyEye7
25-09-2017, 19:04
So like others I was experiencing menu lag. But I noticed it getting gradually worse. The only thing I could point this at was all my saved car data and career data, because that was the only thing I have done that has changed.

I'm more of a multiplayer racer so losing my career stuff didn't bother me too much. My tune saves I didn't really k ow what I was doing anyway. So I figured what the hell why not right.

So I got into my settings on my playstation and deleted all my saved game data for PC2. Now I understand I shouldn't have to do this to get the game working correctly and I understand this needs t9 be fixed. But I can say no more menu lag for me.

Hope this helps everyone...

Civic
25-09-2017, 21:22
This is a bit shocking. I've noticed the menus lock me out until the yellow download icon stops flashing and I've noticed the amount of time it takes is longer than it was originally. I can live with it taking as long as it takes now but I really hope it doesn't get any longer.

KasperVJensen
25-09-2017, 21:27
Thanks for posting a work around.

It’s hardly a “fix” though is it... lol

Madwak55
25-09-2017, 21:31
I had three days of playing with no lag problems plus I was saving different car setups as well, then I decided to start a second career and BAM freeze after freeze lockup after lockup damn.... deleted my first career and everything is back to normal again.... hooray ��

Roger Prynne
25-09-2017, 21:36
I think this is more of a PS4 problem rather than a game problem for whatever reason.... but I could be wrong of course.

Umer Ahmad
25-09-2017, 21:37
Investigsting this, thanks for the report

CrazyEye7
25-09-2017, 21:48
Thanks for posting a work around.

It’s hardly a “fix” though is it... lol



Yea not really a fix, rather a work around. Just trying to pass on my findings so that everyone that was as frustrated as myself can have some sort of relief and be able to play again.

KasperVJensen
25-09-2017, 21:54
Yea not really a fix, rather a work around. Just trying to pass on my findings so that everyone that was as frustrated as myself can have some sort of relief and be able to play again.

Thanks for that. I wasn’t trying to be a smartass or anything. ����

sigurd
25-09-2017, 22:50
Nice catch! I haven't progressed in my career far enough to matter or saved enough setups that I can't live with gonna try to delete just career then full save file if needed.

Slightly curious if a PlayStation database rebuild would have any effect

loslogo
25-09-2017, 23:06
The menu hangs are making the game unplayable. I'm using a PS4 pro and they are now about two minutes every time.

klorptar
25-09-2017, 23:20
Nice catch! I haven't progressed in my career far enough to matter or saved enough setups that I can't live with gonna try to delete just career then full save file if needed.

Slightly curious if a PlayStation database rebuild would have any effect

I did a database rebuild Sunday night as I noticed the lag getting worse. It had no effect. The game booted faster, but the menus still lagged. I'm on a PS4 Pro.

loslogo
25-09-2017, 23:21
How is deleting your progress a fix????

sigurd
25-09-2017, 23:31
I can second the work around works. Deleted PS4 save files and the menus are snappy fast again. Obviously not ideal but I hadn't progressed much so it didn't matter all that much to me. I was having 10-15 second freezes with a PS4 pro and I even have an SSD in mine.

CrazyEye7
25-09-2017, 23:46
How is deleting your progress a fix????

More of a work around. My problems are fixed. Because I don't play single player. My menus are snappy fast again.

Nobody said you had to do it... wait for a patch if you'd like.

It was a fix for me. I did have some progress in single player. I also had a ton of setups for a lot of different cars. Maybe just deleting my career would have worked. I don't know this. But I do know I'm not dealing with the menu lag anymore

sigurd
25-09-2017, 23:54
More of a work around. My problems are fixed. Because I don't play single player. My menus are snappy fast again.

Nobody said you had to do it... wait for a patch if you'd like.

It was a fix for me. I did have some progress in single player. I also had a ton of setups for a lot of different cars. Maybe just deleting my career would have worked. I don't know this. But I do know I'm not dealing with the menu lag anymore

Deleting career wasn't enough for me had to delete entire save file unfortunately

Going to experiment by purposely not creating a career and just playing single player and saving some setups and see if it eventually starts slowing down and freezing again.

CrazyEye7
26-09-2017, 00:06
Deleting career wasn't enough for me had to delete entire save file unfortunately

Going to experiment by purposely not creating a career and just playing single player and saving some setups and see if it eventually starts slowing down and freezing again.

Post back with your findings. ��

Umer Ahmad
26-09-2017, 01:31
perhaps a work-around while we investigate the problem: http://forum.projectcarsgame.com/showthread.php?52755-Menu-hang-FIXED!&p=1366575&viewfull=1#post1366575

Mods: please merge these 2 threads (been a while since I did that, don't want to mess it up!)

Aldo Zampatti
26-09-2017, 01:34
Merged
Workaround posted in #9: http://forum.projectcarsgame.com/showthread.php?52477-Menu-and-sub-menu-lag&p=1366575&viewfull=1#post1366575

cwinnbari
26-09-2017, 03:13
Merged
Workaround posted in #9: http://forum.projectcarsgame.com/showthread.php?52477-Menu-and-sub-menu-lag&p=1366575&viewfull=1#post1366575



Just a thought..... is it affected by local HD saves or PS+ cloud saves?

SIR_Driftalot
26-09-2017, 08:33
You can also achieve the same outcome by deleting all your redundant set up saves, and leaving the career/profile saves alone.
I'm not sure why you need to save every set up, but the game obviously has issues once you have more then a few track/car combo set up saves going at the same time.
I imagine like me, most of us are jumping from car to car and track to track to check it all out, so the forced set up saves pile up pretty quick if you like to tweak the setups a little on every car before your start ie, drop the fuel load or shorten the steering ratio to suit your preferences.

pa_pinkelman
26-09-2017, 08:47
Oh man, this sums up the game for me. All these little and big bugs we have to live with. Why is the game shipped in this condition I wonder? Yesterday I took a look at my stats: I have lik 120 race starts and just 3 race finishes. And you know why? Because this game is bugged as hell and I am more busy with anything but the racing itself. Sorry for the strong words, but this is really pathetic. PC1 was a disaster and clearly PC2 is following its footsteps.

Civic
26-09-2017, 09:44
Oh man, this sums up the game for me. All these little and big bugs we have to live with. Why is the game shipped in this condition I wonder? Yesterday I took a look at my stats: I have lik 120 race starts and just 3 race finishes. And you know why? Because this game is bugged as hell and I am more busy with anything but the racing itself. Sorry for the strong words, but this is really pathetic. PC1 was a disaster and clearly PC2 is following its footsteps.

The bit I can't understand is how they can keep saying there are no game breaking bugs? If having to constantly delete your game and start again isn't game breaking what is?

So far when I say something is game breaking they delete my post, lets see if the trend continues.

sVig
26-09-2017, 10:22
The weird thing is though is that whilst you're actually playing career mode, the menu lag is not there...

CodeCmdr
26-09-2017, 11:59
I'm also noticing menu lag more and more. Navigating from manufacturer to manufacturer, car to car, livery to livery is taking like 2 seconds, and I my inputs are often not processed at all.

I don't want to delete my career, so I'll try to just live with this issue and hope a patch will fix it. :mad:

Madwak55
26-09-2017, 13:27
I'm also noticing menu lag more and more. Navigating from manufacturer to manufacturer, car to car, livery to livery is taking like 2 seconds, and I my inputs are often not processed at all.

I don't want to delete my career, so I'll try to just live with this issue and hope a patch will fix it. :mad:
You could always save your game setup to the cloud or a memory stick and then delete it from the console to see if it improves things? The save game file can then be reloaded at a later time and you won't lose anything :)

CrazyEye7
26-09-2017, 17:53
So aside from the menu lag, before I deleted my saves, I was having a ton of issues playing multiplayer. Disconnects from server. Not being able to join servers. Having no control of my car when a race starts from a rolling start for entire race while it still said "prepare to race". Even being spawn into rolling start sitting upside down on the track.

I played the entire day yesterday after deleting my saves, with only 1 issue. So I do believe it has fixed a ton of other problems I was having as well.

Civic
26-09-2017, 20:58
So aside from the menu lag, before I deleted my saves, I was having a ton of issues playing multiplayer. Disconnects from server. Not being able to join servers. Having no control of my car when a race starts from a rolling start for entire race while it still said "prepare to race". Even being spawn into rolling start sitting upside down on the track.

I played the entire day yesterday after deleting my saves, with only 1 issue. So I do believe it has fixed a ton of other problems I was having as well.

That is great information that could help a Dev track the issue, hopefully it will be passed on.

I'm not a Dev or anything like it but I'd suspect a memory issue based on your post.

chickano
26-09-2017, 22:09
Thanks for the workaround, far from ideal but I'll go without career for the time being. Menu lag was up to 30 seconds and more as I've been trying out alot of cars and was advanced from tier 6 to 5 in career.

Hope this is included in the first patch with the UDP issue, please devs. Pointless to start career or save setups currently. This coupled with UDP absence is just ridiculous to be fair. These aren't bugs, these are entire elements of the game we're talking about, with all due respect. Cheers.

sigurd
27-09-2017, 03:23
OK I have several hours in the game since completely removing my save fIles. All menus are still lag free and working great. I have driven several cars and saved numerous setups. Only thing I have not done is create a new career since the start over.

rotegoettin
27-09-2017, 10:41
I have only delete my car set up savings in the game safe files, and it works!!! No lag‘s and freeces anymore!

ThatJordGuy
27-09-2017, 11:07
Can you save your setup files to USB?

TerminatorGR
27-09-2017, 16:12
I can also confirm that this works. Go and delete every PC2 save you dont need and you are good.

Madwak55
27-09-2017, 16:24
Can you save your setup files to USB?

Yes but I don't know what happens if you reinsert them? I'm waiting until they've fixed the bug before I try to put them back in.

SGETI
01-10-2017, 13:24
So like others I was experiencing menu lag. But I noticed it getting gradually worse. The only thing I could point this at was all my saved car data and career data, because that was the only thing I have done that has changed.

I'm more of a multiplayer racer so losing my career stuff didn't bother me too much. My tune saves I didn't really k ow what I was doing anyway. So I figured what the hell why not right.

So I got into my settings on my playstation and deleted all my saved game data for PC2. Now I understand I shouldn't have to do this to get the game working correctly and I understand this needs t9 be fixed. But I can say no more menu lag for me.

Hope this helps everyone...

This old man needs a help. your settings? can you give a road map as to which files you are talking about and how to locate them.

thank you in advance.

Madwak55
01-10-2017, 15:15
This old man needs a help. your settings? can you give a road map as to which files you are talking about and how to locate them.

thank you in advance.
@SGETI
Go into settings on the PS4 system menu (picture of a toolbox)- select
Go down to application saved data management- select
Go to saved data in system storage-select
Go to delete- select
Go project cars2-select
Tick all the boxes with tuning setup
Move across to the Delete box and click then click ok :) then just exit back to the game and enjoy fast menus again?

thegt500
01-10-2017, 19:01
I had the slow menus, lagging vehicle selection, grey screen hanging at intro video and to top it all off, lost FFB in the straight ahead position when driving any car on any track !
Re booted, did a database rebuild, set all FFB back to default and still the same. The only way I got it back to normal was to delete save data (I did everything as I hadn't started a career).
Hopefully the patch will fix this as I want to start my career, but not until there's a fix that doesn't involve deleting my data and having to start afresh every time !

Civic
01-10-2017, 21:54
So far the work around hasn't been as bad as these threads originally had me thinking as simply deleting tuning files fixes the game for me but it only takes tuning a few cars again to slow the game right down requiring me to repeat the process of deletion. I wouldn't call this issue game breaking anymore, I've downgraded it to serious bug that is a PITA.

cwinnbari
03-10-2017, 22:02
Has any one seen a difference with the PS4 5.0 OS?

Madwak55
03-10-2017, 22:49
Has any one seen a difference with the PS4 5.0 OS?
It appears to have changed the graphics quality on my PS4 pro, game doesn't look as sharp as it did?