PDA

View Full Version : Sudden frame rate drop/freeze in multiplayer after standing race start



ATSS
25-09-2017, 11:19
This weird fps freezing/lag happens only at standing start races. (Multiplayer)

Frustrating and pretty much game breaking because you just cant do anything about it when it happens. When the lights go out after like 2-3s later its just freezes for some miliseconds. If you want to manouver inbeetween cars its often gets into some contacts with the others.

PC: FX 6300, GTX 1050 TI,8GB RAM; framerate is pretty good ~50-60 in med-high settings. I dont have this problem in singleplayer even with max 32 cars.

The thing is similar when someone is joining to the lobby and u get that little lag, but this is a bit longer and stronger.

Anyone else getting this?
I posted a similar thread on reddit and as i see im not alone.
Sorry for grammatical errors, i hope you guys understand what i mean. Yeaah and this started after the multiplayer patch.

drathuu
26-09-2017, 11:02
It appears when players crash into each other (or the wall) there is a freeze.. Same as whne someone joins or leaves a race..

I suspect your getting it as people crash into each other causing the issue.. The bug is known, i suspect its sending a burst of data and/or caching in some asset (Crash sound) or damage model.. that wasnt cached.. So should be able to be patched out - Preload assets and or resolve burst netcode.

ATSS
29-09-2017, 06:46
Its happening even when there are only like 8 cars and im starting from the back, so i clearly see there is zero contact and still freezes after the start. (like 1-2s later after the lights gone)

Krus Control
29-09-2017, 06:55
Yeah I get this basically every race. Every race with more than like 5 people. And it's a real problem too. I've had it skip frames really bad and not register my shift clicks or just make me not be going as fast and drop 5 places. This has to be a common issue.

ATSS
29-09-2017, 07:03
I've made two gifs; so u can clearly see the freeze after the start:

The first was a big one.

https://imgur.com/C8HR7ir
https://imgur.com/iPrxvQG

sergiumtz
29-09-2017, 07:15
this is game breaking if you ask me. Frame drops and freezes in a racing game is bad, happens to me as well in every single race. God knows how many missed turns I had so far because of this...
You'd think they could sort it out. The patience is running low if you ask me, they need to get their stuff together quickly.

HalfMoonRider
29-09-2017, 07:46
Okay, so we were not the onlyones who had this problem when we played online game with my friend. We left few open slots for human driver and filled other spots with AI. We fustrated of the fps freeze and lagging so much, that we had to stop playing:mad: First we thought that is there something about our network connection but after i tried another game, i had zero problems. So is the problem that when other human driver joins your race, the game freezes for a moment?? We had this problem during practise, qualify and race. I don't remember was there lagging/freeze during start of the race, but this appeared many times while we were driving.

There is so many bugs/problems in this game, that my patience is starting to run very low!

ATSS
29-09-2017, 11:25
I had one huge freeze yesterday in Laguna Seca when someone joined and i was in the middle of a turn. My car was in pieces afterwards..

CodeCmdr
29-09-2017, 12:48
Yeah, the frame-rates get extremely choppy for about a second when people join the game. Because the multiplayer game list shows races that already started, and a lot of people don't yet know this and accidentally join as spectators, this issue persists post qualifying and makes the race choppy at times as well. I really hope the engineers at SMS are working on this - it's the most annoying problem in the game for me at the moment. :mad: