PDA

View Full Version : Freetrack/Opentrack help required to get working if possible.



haydnbuzz
25-09-2017, 15:14
So I'm trying to use Freetrack (similar to TrackIR) and am having no luck. I previously used the following method in PCars 1 with no problem.

http://forum.projectcarsgame.com/showthread.php?22650-Workaround-for-Freetrack-support-(temp-fix)&highlight=FREETRACK

I've searched the forum and found a few topics relating to TrackIR but have had luck with some of the suggestions. Somebody out there must be using Freetrack/Opentrack and have the expertise to get it working? If so can they share their expertise?

Problem solving attempted so far:
I'm using helmet cam view.
Starting Opentrack before launching the game in Steam VR mode
Started Opentrack followed by Freetrack and launching in Steam VR mode
Used the above link .bat files with edited directories with PCars 2

I'm stuck, this is such an epic simulator which I feel I've not even scratched the surface of. Trouble is Freetrack has kind of become natural for me in using now and I don't want to go back to driving with a static view if it can at all be helped. I'll be venturing into VR one day but not just yet. I find Freetrack a perfect solution for racing awareness.

Thanks,
Haydn

Astrosloth
25-09-2017, 17:29
Hello,

i have the same problem and looking for a solution as well (EdTracker). I tried with Steam and Oculus VR Mode, as suggested for TrackIr users. Opentrack works perfectly with other games, inculding PC 1. :confused:

MABlosfeld
25-09-2017, 21:09
same problem here

Wolkenwolf
25-09-2017, 22:10
opentrack 2.3.7 is running here. No problems, only tried Oculus VR mode. ootb.

lazarov27
25-09-2017, 22:44
I'm also using OpenTrack 2.3.7.
You could also check where PC2 loads NPClient library from.
Check in regedit where HKCU\Software\NaturalPoint\NATURALPOINT\NPClient Location | Path key is pointing to - on my install it points to OpenTrack's modules directory, NPClient is loaded from there.

MABlosfeld
25-09-2017, 23:53
I am using version 2.3.0 and it does not work on pcars2, I will install version 2.3.9 and then I post here the result.
edit: I installed but it does not work in pcars2 game

edit2: was loading the game with steam VR mode, oculus VR works perfectly.

Thank you guys, you saved my day.

haydnbuzz
27-09-2017, 18:35
Absolutely brilliant. With the most recent version of Opentrack all is fine. Here are my steps if anybody is still unsure that work for me with Freetrack

Open Freetrack and start
Open Opentrack and start
Open PCars 2 in VR Oculus mode
Start session
Close Opentrack

There may be better ways but I've yet to explore. This made my day!

Wolkenwolf
28-09-2017, 08:21
can't you not only use the pointtracker input protocol from opentrack ?

Astrosloth
29-09-2017, 11:02
Thank you guys! Opentrack 2.3.9 has solved the problem and it also works with Steam VR Mode.