PDA

View Full Version : Possible Replay Bug?



cxMilk
26-09-2017, 18:16
Ran the final race in the Ginetta Junior series at Brands Hatch...in the snow. Based on a few comments here already, expected to fare poorly. Surprisingly, after a brutal seven laps, I won the race. Due to the intensity of the entire race, I decided to watch the replay. Eh...my game froze. The only thing I can do is back out to the XBox home screen. Oh wait, after a few minutes, the replay finally kicked in. Although, the first two laps of the replay were devoid of weather and then suddenly on the third lap, the snow just magically appeared.

Great! Delighted with my replay, I back out to cycle through all the results screens, collect my championship trophy and...my game froze...on a still photo of the replay shakily being moved around as it was still being viewed from one of the trackside cameras. Fortunately, I could back out to the XBox home screen once again, but that was all I could do this time. After letting the game sit on a shaky replay still for ten minutes, I decided the game was truly frozen this time and had to reset. Wasn't exactly happy as I had to do the race all over again since the end of race menus never made it as far as the autosave before freezing up.

Anyway, I've watched a couple other replays, but both from dry races I think - Knockhill and Snetterton, if memory serves. Never had an issue. Could snow somehow have borked the whole replay system here or was this simply a freak deal? Original thoughts were maybe something XBox exclusive given snow and replays. Dunno. Unfortunately, it's scared me away from watching replays for the time being, at least in career mode.