PDA

View Full Version : Oculus Rift - game doesn't switch to Rift Audio automatically



AlexxV
26-09-2017, 21:19
When launching in VR mode it doesn't automatically switch to Rift built-in headphones forcing me to switch default audio device to Rift Audio before game launch.

FriendCalledFive
26-09-2017, 21:25
It uses the windows default which I am grateful for as I use Voicemeeter Banana for audio sharing for my bass shaker. I think you may be able to change it in Audio settings.

John Hargreaves
26-09-2017, 21:39
I think it does if you plug in the Rift before you play, but if you leave your rift plugged in, you need to select Rift audio before launching the game if you have had it on another sound output. I've had this in a few games but you get used to it, I don't think it's just a PCARS thing.

crowhop
26-09-2017, 22:21
You can configure the output in the Audio Options. You can change this on the fly. This is extremely helpful. Great feature, SMS!

CP2
26-09-2017, 22:30
I agree with crowhop - being able to change the audio on the fly is helpful. I only wish that it saved the settings between the Oculus and standard version. I would like it set to Rift when I launch in VR, but to my speakers normally, and it retains the setting between the versions.

That Dude There
27-09-2017, 01:49
I was having this problem with other games, so I found and setup Voicemeeter. It runs audio through my sound card headphones output and rift at the same time, but only when it is open. Problem solved for me, plus my 3 year old can listen to me race.

CP2
27-09-2017, 03:43
If it's audio from both speakers and the Rift that you seek, there is also a setting within the Oculus Software that will work over having to have an additional app running. With Oculus Home open on the desktop, go to Settings -> Devices -> Rift -> "Audio Output in VR" - and set to Both(audio mirroring).

AlexxV
27-09-2017, 15:40
You can configure the output in the Audio Options. You can change this on the fly. This is extremely helpful. Great feature, SMS!

It doesn't change on the fly for me though - it would've made this "feature" much less frustrating. Also, you can choose audio output in Rift settings if you like to use something other than Rift built-in headphones.

AlexxV
27-09-2017, 15:42
I think it does if you plug in the Rift before you play, but if you leave your rift plugged in, you need to select Rift audio before launching the game if you have had it on another sound output. I've had this in a few games but you get used to it, I don't think it's just a PCARS thing.

My Rift is plugged 24/7 so it's not the case.

That Dude There
27-09-2017, 16:20
If it's audio from both speakers and the Rift that you seek, there is also a setting within the Oculus Software that will work over having to have an additional app running. With Oculus Home open on the desktop, go to Settings -> Devices -> Rift -> "Audio Output in VR" - and set to Both(audio mirroring).

that didn't work for me for some reason. I don't know, maybe I did something wrong.

OzzyNeil
01-10-2017, 01:04
I'm having this issue to, If I'm on desktop audio and start the game, it switches to desktop speakers even though i had Rift audio when i exited the previous session.
If i then change to Rift audio in game it does not switch to Rift, I have to restart the game and select Rift audio in my sound settings.

Disregard, working fine.not sure why but its ok now.

That Dude There
01-10-2017, 04:36
I was in a race with Voicemeeter on, and it kicked me out because oculus shut down saying audio switched. I quit using voicemeeter and just click oculus to default audio before I start the game.