View Full Version : G29 Steering Ratio Driving Me Slightly Mad....

26-09-2017, 22:21
PCars1 is fine with my G29, as is Assetto, F1 games, iRacing etc. I can easily tune the steering ratio to suit my desire.

With PCars2 i just cannot find a way of getting a steering ratio I can use. I have it set up at 900 degrees on the Logi profiler, calibrate in game to 900 degrees then 90degrees as per instruction and save. But on track I have to turn about 50% more than I should do, its just unplayable. Altering the steering ratio in the setup doesn't alter the response (i have tried 1:5 and 1:30) it just alters the in-game wheel rotation.

I have tried calibrating to 900 degress then going over or under 90 degrees steering movement and saving but it doesn't seem to help. It feels like PCars2 is always compensating something in the background. For example, at the Oulton banked hairpin I need more than 180 wheel movement which is horrible (and no i'm not understeering.....). At Spa, I can't get round LaSource even at crawling speed with 360 degrees wheel rotation......

Any help gladly recieved......After a few days of messing with every setting I can find I'm ready to throw it out of the window!

Morgan Henstridge
26-09-2017, 22:46
A couple of other Logitech users have reported this also, but most are OK.

Might be worth uninstalling the Logitech Profiler, and reinstalling it.

Also do you have the option to let the game change the settings set in the Logitech driver??

26-09-2017, 23:08
I have bought the G29 for Project Cars 2, but havent had a wheel before. So l'm not experienced at all and cant tell how well my wheel works, but l have a car IRL and have a general idea of how wheels respond, so l'm confident to say that my G29 really does need way more input as you would think going into corners. It just feels wrong.

27-09-2017, 07:51
If you put on the full HUD, there's a small steering wheel icon and next to it is a meter that shows how much the games thinks you are turning your wheel.

Edit: Also, you must tick the "Let game change settings" in your logitech driver settings as Morgan said. Then recalibrate the wheel.

27-09-2017, 14:46
Also make sure you don't have sensitivity over 50% on logitech profiler, as it screws anything past 90degrees. Once you've done the other things mentioned here, try going to suspension under steering menu and fiddle around with Steering Ratio.

27-09-2017, 18:14
Thanks for the above suggestions, I'll try these later and report back. Yours hopefully....!

27-09-2017, 22:35
I have the same problem with my G29. Funny thing is it seems to be really bad in some vehicles and not others. In the Karts I have to turn the wheel pretty much an entire rotation to get around a hairpin corner. IndyCars I have a similar problem too but not quite as bad. Would love to know the fix.

27-09-2017, 22:41
When in wheel configuration forget about the 90 and turn the wheel back to you see 900 on the display under the wheel animation. I was having them same issue and this fixed it for me.

28-09-2017, 19:06
Thanks for your replies - i have re-intsalled the Logitec Profiler, got the latest driver, re-done calibration but its the same. Stupidly high steering lock and changing the ratio in the step does nothing, only the visual ratio on screen. AARRGGHH!

28-09-2017, 23:13
Just deleted the Logitec driver, but made no difference. However if I close down the Logitec profiler and calibrate in windows, IT WORKS PERFECTLY! Must be a compatity issue with PCars2 and the profiler...

01-10-2017, 18:49
Oh well, I spoke too soon. I now cannot get the steering ratio right again. with the Logitec profiler, without it, calibrating in Game Controllers over and over again, calibrating in game over and over again, need to use double the steering lock. No idea what I did the other day to make it work but I have just spent 2 hrs trying and I cant get it right.

Fired up PCars1 and it works fine, just like all my other games.