PDA

View Full Version : HUDs "tilted" 45 deg up to the roof when using Oculus Rift



rasssta
27-09-2017, 17:33
Hi!

I'm using Oculus Rift when playing PC2 on Win10 and all of the HUDs, in Rift headset but not on standard screen, are tilted "up" to the roof like 45 degrees so I basically have to rise up from my chair to see what it says on the lap timing list and current delta time etc. Starting to become *really* annoying during qualies...

Any idea how to change this? Is it game setting related or something with my Rift setup? I'm using Steam VR mode when launching the game and I've run Steam VR multiple times without any changes. And I've looked through all settings in game but haven't found anything. My Oculus sensor is mounted slightly above my head straight ahead of my racing setup point down towards me.

If anyone could guide me on how to take screenshots from the Rift I'll upload a pic.

Thanks in advance!

Siberian Tiger
27-09-2017, 17:40
You can Map a Button to the Reset VR View Option.

It is located under:
Controls -> Edit Assignments -> Camera & View (You Need to scroll down)

Laiders
27-09-2017, 17:55
There are shortcut keys to rotate, pan and scale the VR hud. Go to the normal edit HUD option from the settings menu, then click help, it will show you the short cuts to do this (they use the numpad).

rasssta
27-09-2017, 18:31
You can Map a Button to the Reset VR View Option.

It is located under:
Controls -> Edit Assignments -> Camera & View (You Need to scroll down)

Tried this, didn't work. However, I noticed when I played around in the HUD menu and moved things around they all switched angles when returning to the game (pretty much 45 degress down instead of up) and they moved further away. But when I started a new game the angle was back to normal (45 deg up), even though the HUD settings were saved. And as soon as I moved something around in HUD settings they became tilted the other way around again, and back to "normal" when starting another new game. Has to be some sort of a bug?

Siberian Tiger
27-09-2017, 18:35
Did you tried Laiders Informations?

My Rift Sensor is installed like yours, no Problem... You could also try to start in Oculus VR Mode instead of Steam VR Mode...

rasssta
28-09-2017, 15:08
Is there any way to re-map those keys? Out of my 3 keyboards, none of them have numpads... :(

rasssta
28-09-2017, 15:08
Did you tried Laiders Informations?

My Rift Sensor is installed like yours, no Problem... You could also try to start in Oculus VR Mode instead of Steam VR Mode...

Made no difference starting in Oculus mode :(

Siberian Tiger
28-09-2017, 15:10
Is there any way to re-map those keys? Out of my 3 keyboards, none of them have numpads... :(

Nope, you will Need one with Numpad, since it's the only Thing you can try right now.. im afraid...

Gloomy
28-09-2017, 15:21
Nope, you will Need one with Numpad, since it's the only Thing you can try right now.. im afraid...

That's a shame, I use a roccat Sova, it doesn't have a numpad. So I have no way of adjusting either.

whip
28-09-2017, 15:28
edit hud menu and look at help

numpad keys move the hud around

maybe there a way you can use the built in windows virtual keyboard, maybe somehow bind them keys to something

rasssta
28-09-2017, 17:37
Bought a new keyboard, with numpad. That solved it. Thanks everyone!

DV8ing1
28-09-2017, 18:25
LOL quite the solution you had there! I feel that the game shouldn't absolutely REQUIRE a numpad and those options should be rebindable but glad you got it sorted anyways. This game in VR is amazing. Would love more performance improvements but it plays well enough. 1080ti and 4790k-4.6ghz.

Gloomy
28-09-2017, 23:52
I went through some buried boxes and dug out an old keyboard and was able to adjust mine too. 100% better now.