PDA

View Full Version : PC - CSL Elite and Clubsport V2 pedals - work but not in PC2



the_Real_Ole
07-12-2017, 16:01
so I'm hoping someone can point me in the right direction... I've tried 18 different things and tried to sort through 19 different threads... I cant figure out what is wrong...

My Clubsport V2 pedals were hooked up to my wheelbase... everything worked fine - then the pedals started cutting in/out - it would sometimes be the accelerator, sometimes the brake - then all of a sudden - totally unrecognized in game and in the CONTROLLERS WINDOW/APP thingy....

so I decided to hook the wheels up to the pc via USB
fine
now the CONTROLLERS window recognized them.... great.... all work perfect
wheel is recognized in its separate section of the CONTROLLERS window... great

I re-install most up to date wheel base software and update to the most up to date firmware...
fine

IN GAME HOWEVER --- I am having trouble
I can obviously select my fanatec csl elite wheelbase --- and I click on separate pedals...
fine.... I think all of that is right...

but when I go to calibrate the wheel and pedals --- nothing happens when I press the accelerator, brake or clutch...
now I can go and ASSIGN them..... so when I click edit assignments --- if I click on accelerator - and then press it - then it will register it....
but when I go back to try to calibrate - then they are not recognized and nothing happens on the screen when I press the pedals...

I have tried creating a custom wheel
this will recognize my pedals after I've assigned them.... so I like that...
but I cant calibrate my wheel as it says that I have too many inputs when I try to turn the wheel left or right to set those assignments...


sorry - that's a lot - but hopefully enough to where someone might have had a similar struggle and can point me to the (probably easy fix) that I'm missing
im at a loss
thx

Sankyo
07-12-2017, 17:45
What if you sign the pedals and then just skip calibrating then, do they work in-game?

the_Real_Ole
07-12-2017, 20:04
nope - if I assign the pedals (on the custom wheel) then it wont work on track
as I have to assign the "buttons" on the wheel - which means the left steer and right steer - --- but when I try to assign those - it says that all the buttons haven't been mapped - even though I have mapped all the necessary buttons... maybe I need to revisit my list of required buttons ---- but no - if I don't try to assign or calibrate it doesn't just magically know to turn left and right

Mad Al
07-12-2017, 22:27
put it on the correct choice for the wheel, not the custom option, then just edit assignments to assign the pedals. You shouldn't need to calibrate

the_Real_Ole
08-12-2017, 03:06
so tonight when I went on - I set the wheel to the correct wheel base... assigned the pedals.... they actually worked and I was able to calibrate - I assigned all my buttons to my wheel and it worked... stupid... don't know why that didn't work the other night... maybe just needed to reset or reboot or something... who knows... but yes Al - that's basically what happened - if I assigned the pedals - then I could calibrate those - and because I had the wheelbase selected - my right and left worked and all I had to do was assign the buttons... apparently I have a drinking problem....