PDA

View Full Version : Xbox One X - Low FPS and other issues



marcelok
05-02-2018, 15:26
Good Morning.

During our championship(Last week) we have bugs with some players:

- 3 players, including myself, time were not saved during qualify and race. I could see my time in my screen. But host were always seeing 00:00:00.
- Without time during the qualify, i was moved to the end of grid.
- During the race, without the time, i received the blue flag constantly.
- In the end of the race, i didn't appear in the finish list.


Just on my xbox X:
- My FPS during the entire race/qualify was 20 FPS or below. This is not the first time and it's not related to the number of cars on the grid/weather(was summer/clear day). Even during my training sessions on the same track(Brands Hatch) and without IA/Opponents i had this issue. I can fix this as soon i restart the game.

Marcelo

OddTimer
05-02-2018, 15:48
The issue with the frame rate...It's happened to me twice, always playing single player. In bothe occasions I quit the race and went back to race central. I notice then that the menus were very slow and crancky as well. I quit the game back to the dashboard and upon restart everything was back to normal. Weird. Patch 4 will be out soon and there are a couple of things to improve performance on the X so fingers crossed.

Nint
05-02-2018, 15:53
Just on my xbox X:
- My FPS during the entire race/qualify was 20 FPS or below. This is not the first time and it's not related to the number of cars on the grid/weather(was summer/clear day). Even during my training sessions on the same track(Brands Hatch) and without IA/Opponents i had this issue. I can fix this as soon i restart the game.

I think that happens if you quit to the main menu right after qualifying, before you even load the race itself.
Hope it's fixed for patch 4, because I forgot to report this bug when it happened to me! :D

Pete2000
22-02-2018, 08:59
I'm not really losing FPS but I get freezes and stutters regularly. If I restart the Xbox it clears it up for about an hour of play then it starts happening again.

Zaskarspants
22-02-2018, 11:04
I'm not really losing FPS but I get freezes and stutters regularly. If I restart the Xbox it clears it up for about an hour of play then it starts happening again.

You may have a fault with your x box x. I have never experienced what you describe.

nissan4ever
22-02-2018, 13:57
You may have a fault with your x box x. I have never experienced what you describe.

Even though I really don't play this game at all (maybe 3 hrs total since launch). I haven't experienced that with my Xbox One X.

OddTimer
22-02-2018, 14:13
I'm not really losing FPS but I get freezes and stutters regularly. If I restart the Xbox it clears it up for about an hour of play then it starts happening again.

I haven't either! If tthis only happens on Pcars2, I'd say you can try installing the game on an external hard drive (or the other way around) to see if it helps...don't move drives, do a fresh install.

g.stew
22-02-2018, 19:36
Where do you get the stats on FPS from? I've seen someone else mention specific numbers before too. Is there some kind of readout that shows the frame rate?

Gav88888
28-02-2018, 15:36
I was going to say the same, how do you know what FPS you were getting, or is it pure guess work?

marcelok
28-02-2018, 15:52
I was going to say the same, how do you know what FPS you were getting, or is it pure guess work?

You don't need a stats to feel your fps going from 60fps to 15fps! I'm talking about race the complete race with this 15fps! Anyone can notice this!

Zaskarspants
28-02-2018, 16:10
You don't need a stats to feel your fps going from 60fps to 15fps! I'm talking about race the complete race with this 15fps! Anyone can notice this!

Yes, I am sure I would notice it.

No, it has never happened, to me.

OddTimer
01-03-2018, 09:27
You don't need a stats to feel your fps going from 60fps to 15fps! I'm talking about race the complete race with this 15fps! Anyone can notice this!

again, refer to post number 2....and, did you try framerate or resolution mode? maybe you are on enhanced visuals and depending on the size of grid fps will drop, not to 15 though!

marcelok
01-03-2018, 18:48
again, refer to post number 2....and, did you try framerate or resolution mode? maybe you are on enhanced visuals and depending on the size of grid fps will drop, not to 15 though!

The issue was not the mode. I was running alone in the track once.
And as soon i restart the game and enter the same race/car/mode, the game ran properly.

Roushman624
02-03-2018, 01:45
again, refer to post number 2....and, did you try framerate or resolution mode? maybe you are on enhanced visuals and depending on the size of grid fps will drop, not to 15 though!

I use enhanced visuals and rarely have any problems or hiccups.

nissan4ever
02-03-2018, 02:51
I only use Enhanced Framerate. No issues at all despite grid size and weather. I've seen framerate drops & screen tearing at Long Beach using Enhanced Visuals with a full grid in light clouds.

For me, I'll take 1080p pretty much stable 60 fps with Enhanced Framerate anyday over the other 2 options.

A good practice to have with Xbox One this generation. Make sure no apps are running in the background. Quit everything physically when you leave it. I leave my console on instant on. I never suffer any weird performance issue with a game that's console related to stuff in the background.

OddTimer
02-03-2018, 10:58
I use enhanced visuals and rarely have any problems or hiccups.

This is weird...I am on enhanced resolution at Lemans, multiclass (gt3, gte, lmp2 and lmp1) 24 cars. Summer, 15x time progression, 4 weather slots (2 of them are random), race start 4pm. I can see tearing when I am behind another car approaching both S's just before the pit straigth. Also, when the AI pits, the game stutters, I can see the exact momement the hud shows PIT by the driver's name, the game stutters.

I am wondering if it could be a bugged profile causing it. I've had this profile since 2.0 and a carreer wipe bug...have you guys experienced anything like it?

Mon Pavion
14-03-2018, 15:57
This is weird...I am on enhanced resolution at Lemans, multiclass (gt3, gte, lmp2 and lmp1) 24 cars. Summer, 15x time progression, 4 weather slots (2 of them are random), race start 4pm. I can see tearing when I am behind another car approaching both S's just before the pit straigth. Also, when the AI pits, the game stutters, I can see the exact momement the hud shows PIT by the driver's name, the game stutters.

I am wondering if it could be a bugged profile causing it. I've had this profile since 2.0 and a carreer wipe bug...have you guys experienced anything like it?

Yes. Just posted about the bad stuttering when AI are pitting. I usually use Enhanced Visuals but I might switch to Enhanced framerate and see if that changes anything.

Zaskarspants
15-03-2018, 13:55
I only see occasional tearing on tracks with many assets, this clearly varies with the options.

Frame rate - almost no tears.
Res ( I use) - occasional, first corner.
Visuals - Slightly more than res.

OddTimer
15-03-2018, 16:26
Since my last post (02/03) i've reinstalled the game and deleted my save from console and cloud. I then went back to Lemans and performance has improved, same at a couple of other tracks. I think my save/profile was bugged and making performance suffer a bit. The improvement is not huge, but it is definitely there.
Performance does suffer at sundown, when the sun is just about the horizon line, the lighting effects seem to push things hard. On 10x time progression, starting a race at 4pm in the summer, race length 1hr, you are going to experience a bit of tearing and frame drop for about 2 laps. Redbull Ring is another example of that, not too bad.

Hopefully SMS is still working to improve performance on OG Xbox, and this could potentially result on better performance on the X.